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Workspace panels 
These include Files, 
Projects and Help 
Advisor panels. 
These panels can be 
moved, docked or 
clipped by clicking on 
the panel title and 
dragging it to a new 
location. 

Click on the tab at the 
bottom of the panel to 
display its contents.  

System Menu 
Click the down-arrow 
icon to display the 
System menu and set 
up the system 
preferences. All other 
menus and toolbars 
automatically change 
to suit the document 
being edited. 

Panel Control 
Editor specific 
and shared 
panels can be 
chosen from the 
Panel Control list.  

Help Advisor 
Use the natural 
language help 
system to quickly 
find the answer to 
your question. 

Workspace panels 
More pop out panels 
are displayed by 
clicking on these 
tabs. These panels 
can also be moved, 
docked or clipped.  

Workspace 
Common tasks 
are listed to get 
started quickly. 

Welcome to Protel DXP 
Welcome to the world of Protel DXP – a complete 32- bit electronic design system for Windows NT/XP. 
Protel DXP provides a completely integrated suite of design tools that lets you easily take your designs 
from concept through to final board layout. 

All Protel DXP tools run within a single application environment – the Design Explorer. Start Protel DXP 
and the Design Explorer opens, putting all your design tools at your fingertips. You benefit from a 
single, consistent, customizable user environment. 

This tutorial is designed to give you an overview of how to create a schematic, update the design 
information to a PCB and generate manufacturing output files. It also investigates the concept of 
projects, integrated libraries and circuit simulation. 

The Protel DXP Design Explorer 
The Design Explorer is your interface to your designs and the design tools. To start Protel DXP and 
open the Design Explorer, select Programs » Altium » Protel DXP from the Windows Start menu. When 
you open Protel DXP, the most common initial tasks are displayed for easy selection.  

 

As you create your design documents, you can easily switch between editors, for example, the 
Schematic Editor and the PCB Editor. The Design Explorer will change toolbars and menus according 
to the editor you are currently working in.  The name of some workspace panels will initially be 
displayed down the right side of the workspace. Click on these names to pop out the panels, which 
then can be moved, docked or clipped to suit your work environment. 

The following diagram shows the Design Explorer when several documents and editors are open at 
the same time and the windows have been tiled.  
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How the design documents are stored 
Protel DXP stores all the design documents and output files on your hard disk as individual files. You 
can use the Windows Explorer to search for them. Project files can be created that contain links to the 
design documents and are necessary for design verification and synchronization.  

Creating a new project 
A project in Protel DXP consists of links to all documents and setups related to a design. A project file, 
e.g. xxx.PrjPCB, is an ASCII text file that lists which documents are in the project and related output 
setups, e.g. for printing and CAM.  Documents that are not associated with a project are called ‘free 
documents’. Links to schematic sheets and a target output, e.g. PCB, FPGA, embedded (VHDL) or 
library package, are added to a project. Once the project is compiled, design verification, 
synchronization and comparison can take place. Any changes to the original schematics or PCB, for 
example, are updated in the project when compiled. 

The process of creating a new project is the same for all project types. We will use the PCB project as 
an example. We will create the project file first and then create the blank schematic sheet to add the 
new empty project. Later in this tutorial we will create a blank PCB and add it to the project as well. 

To start the tutorial, create a new PCB project: 

1. Click on Create a new Board Level Design Project in the Pick a Task section of the design window. 

 

Design Window 
Displays the documents 
that are currently open in 
this design. 

Mask Level  button  
Allows you to change 
the level of dimming of 
unmasked objects. 
Click Clear to clear 
the current mask.

Layer tabs 
Each PCB layer 
has its own tab. 

Document tabs 
Each open document 
has its own tab at the 
top of the design 
window. Right-click 
on a tab to close, 
split or tile the open 
windows. 

PCB Editor 

Schematic Editor 

Workspace panels 
Click on these 
buttons to display 
the associated 
workspace panel.

Workspace panels 
Click on these 
buttons to display 
the associated 
workspace panel. 

Graphical and List views 
You can choose between 
showing your documents 
in a graphical view in the 
design window, or as a list 
of objects with their 
properties in the List view 
(View » Workspace 
Panels > List), or both. 
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Alternatively, you could click on Blank Project (PCB) in the New section of the Files panel. If this 
panel is not displayed, select File » New, or click on the Files tab at the bottom of the Design 
Manager panel. 

2. The Projects panel displays. The new project file, PCB Project1.PrjPCB, is listed here with no 
documents added.  

 

3. Rename the new project file (with a .PrjPCB extension) by selecting File » Save Project As. 
Navigate to a location where you would like to store the project on your hard disk, type the name 
Multivibrator.PrjPCB in the File Name field and click on Save. 

Next we will create a schematic to add to the empty project file. The schematic will be for an astable 
multivibrator circuit. 

Creating a new schematic sheet 
Create a new schematic sheet by completing the following steps:  

1. Select File » New and click on Schematic Sheet in the New section of the Files panel. A blank 
schematic sheet named Sheet1.SchDoc displays in the design window and the schematic 
document is automatically added (linked) to the project. The schematic sheet is now listed under 
Schematic Sheets beneath the project name in the Projects tab. 

 

2. Rename the new schematic file (with a .SchDoc extension) by selecting File » Save As. Navigate to 
a location where you would like to store the schematic on your hard disk, type the name 
Multivibrator.SchDoc in the File Name field and click on Save. 
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You can save any 
schematic sheet as a 
document template (.dot) 
allowing you to include 
special information such 
as a custom company 
title block and logo. 

Protel DXP has a 
multilevel Undo, allowing 
you to undo any number 
of previous actions. The 
maximum number of 
Undo steps is user-
configurable and limited 
only by the available 
memory on your 
computer. 

When the blank schematic sheet opens you will notice that the workspace changes. The main toolbar 
includes a range of new buttons, new toolbars are visible and the menu bar includes new items. You 
are now in the Schematic Editor. 

You can customize many aspects of the workspace. For example, you can reposition the floating 
toolbars. Simply click-and-hold the title area of the toolbar and move the mouse to relocate the 
toolbar. To dock the toolbar, move it to left, right, top or bottom edge of the main window area.  

Now we can add our blank schematic to the project before proceeding with the design capture. 

Adding schematic sheets to a project 
If the schematic sheets you want to add to a project file have been opened as Free Documents, right-
click on the schematic document in the Free Documents section of the Projects panel and select Add 
to Project. The schematic sheet is now listed under Schematic Sheets beneath the project name in the 
Projects tab and is linked to the project file. 

Setting the schematic options 
The first thing to do before you start drawing your circuit is to set up the appropriate document 
options. Complete the following steps: 

1. From the menus, choose Design » Options and the Document Options dialog will open. For this 
tutorial, the only change we need to make here is to set the sheet size to standard A4 format. In 
the Sheet Options tab, find the Standard Styles field. Click the arrow next to the entry to see a list 
of sheet styles. 

2. Use the scroll bar to scroll up to the A4 style and click to select it. 

3. Click the OK button to close the dialog and update the sheet size. 

4. To make the document fill the viewing area again, select View » Fit Document.  

In Protel DXP, you can activate any menu by simply pressing the menu hotkey (the underlined letter in 
the menu name). Any subsequent menu items will also have hot keys that you can use to activate the 
item. For example, the shortcut for selecting the View » Fit Document menu item is to press the V key 
followed by the D key. Many submenus, such as the Edit » DeSelect menu, can be called directly. To 
activate the Edit » DeSelect » All menu item, you need only press the X key (to call up the DeSelect 
menu directly) followed by the A key. 

Next we will set the general schematic preferences. 

1. Select Tools » Preferences [shortcut T, P] from the menus to open the schematic Preferences 
dialog. This dialog allows you to set global preferences that will apply to all schematic sheets you 
work on. 

2. Click on the Default Primitives tab to make it active and enable the Permanent check box. Click 
the OK button to close the dialog. 

3. Before you start capturing your schematic, save this schematic sheet, so select File » Save 
[shortcut F, S]. 

Drawing the schematic 
You are now ready to begin capturing (drawing) the schematic. For this tutorial, we will use the circuit 
shown below (Figure 1). This circuit uses two 2N3904 transistors configured as a self-running astable 
multivibrator. 
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Figure 1. An astable multivibrator 

Locating the component and loading the libraries 
To manage the thousands of schematic symbols included with 
Protel DXP, the Schematic Editor provides powerful library 
search features. Although the components we require are in the 
default installed libraries, it is useful to know how to search 
through the libraries to find components. Work through the 
following steps to locate and add the libraries you will need for 
the tutorial circuit.  

First we will search for the transistors, both of which are type 
2N3904.  

1. Click on the Libraries tab to display the Libraries workspace 
panel. 

2. Press the Search button in the Libraries panel, or select Tools 
» Find Component. This will open the Search Libraries dialog. 

3. Ensure that the Scope is set to Libraries on Path and that the 
Path field contains the correct path to your libraries. If you 
accepted the default directories during installation, the path 
should be C:\Program Files\Altium\Library\. Ensure 
that the Include Subdirectories box is not selected (not 
ticked). 

4. We want to search for all references to 3904, so in the Name 
text field in the Search Criteria section, type *3904*. The * 
symbol is a wildcard used to take into account the different 
prefixes and suffixes used by different manufacturers. 

5. Click the Search button to begin the search. The Results tab 
displays as the search takes place. If you have entered the 
parameters correctly, a library will be found and displayed in 
the Search Libraries dialog. 

6. Click on the Miscellaneous Devices.IntLib library to 
select it. This library has symbols for all the available 
simulation-ready BJT transistors. 

7. Click the Install Library button to make this library available 
to your schematic. 

8. Close the Search Libraries dialog. 
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The link between the 
schematic component 
and the PCB component 
is the footprint. The 
footprint specified in the 
schematic is loaded from 
the PCB library when 
you load the netlist. 
Double-click on a 
schematic component to 
specify the footprint. 

The added libraries will appear at the top of the Libraries panel. As you click on a library name in 
the upper list, the components in that library are listed below. The component filter in the panel 
can then be used to quickly locate a component within a library. 

Placing the components on your schematic 
The first components we will place on the schematic are the two transistors, Q1 and Q2. For the 
general layout of the circuit, refer to the schematic drawing shown in Figure 1.  

1. Select View » Fit Document from the menus [shortcut V, D] to ensure your schematic sheet takes 
up the full window. 

2. Make sure the Libraries panel is displayed by clicking on the Libraries tab. 

3. Q1 and Q2 are BJT transistors, click on the Miscellaneous Devices.IntLib library to make it 
the active library. 

4. Use the filter to quickly locate the component you need. The default wildcard (*) will list all 
components found in the library. Set the filter by typing *3904* in the filter field below the 
Library name. A list of components which have the text “3904” as part of their Component Name 
field will be displayed. 

5. Click on the 2N3904 entry in the list to select it, then click the Place button. Alternatively, just 
double-click on the component name. 

The cursor will change to a cross hair and you will have an outlined version of the transistor 
“floating” on your cursor. You are now in part placement mode. If you move the cursor around, 
the transistor outline will move with it. 

6. Before placing the part on the schematic, first edit its properties. While the transistor is floating on 
the cursor, press the TAB key. This opens the Component Properties dialog for the component. 
We will now set up the dialog options to appear as below. 

 

7. In the Properties section of the dialog, set the value for the first component designator by typing 
Q1 in the Designator field. 

8. Next we will check the footprint that will be used to represent the component in the PCB. For this 
tutorial, we have used integrated libraries which mean that the recommended models for 
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To edit the attributes of 
an object placed on the 
schematic, double-click 
the object to open its 
Component Properties 
dialog. 

When you are in any editing or 
placement mode (a cross hair 
cursor is active), moving the 
cursor to the edge of the 
document window will 
automatically pan the document.  

If you accidentally pan too far 
while you are wiring up your 
circuit, press the V, F key 
sequence (View » Fit All Objects) 
to redraw the schematic window, 
showing all placed objects. This 
can be done even when you are in 
the middle of placing an object. 

Use the following keys to 
manipulate the part floating 
on the cursor: 

Y flips the part vertically 

X flips the part horizontally 

SPACEBAR rotates the part 
by 90°. 

footprints and circuit simulation are already included. Make sure that model name BCY-W3/D4.7 
is included in the Models list.  Leave all other fields at their default values. 

You are now ready to place the part. 

1. Move the cursor (with the transistor symbol attached) to position the transistor a little left of the 
middle of the sheet. 

2. Once you are happy with the transistor’s position, left-click or press ENTER to place the transistor 
onto the schematic. 

3. Move the cursor and you will find that a copy of the transistor has been placed on the schematic 
sheet, but you are still in part placement mode with the part outline floating on the cursor. This 
feature of Protel DXP allows you to place multiple parts of the same type. So let’s now place the 
second transistor. This transistor is the same as the previous one, so there is no need to edit its 
attributes before we place it. Protel DXP will automatically increment a component’s designator 
when you place a series of parts. In this case, the next transistor 
we place will automatically be designated Q2. 

4. If you refer to the schematic diagram (Figure 1) you will notice that 
Q2 is drawn as a mirror of Q1. To flip the orientation of the 
transistor that is floating on the cursor, press the X key. This flips 
the component horizontally. 

5. Move the cursor to position the part to the right of Q1. To position 
the component more accurately, press the PAGEUP key twice to 
zoom in two steps. You should now be able to see the grid lines. 

6. Once you have positioned the part, left-click or press ENTER to 
place Q2. Once again a copy of the transistor you are “holding” 
will be placed on the schematic, and the next transistor will be 
floating on the cursor ready to be placed. 

7. Since we have now placed all the transistors, we will exit part placement mode by clicking the 
right mouse button or pressing the ESC key. The cursor will revert back to a standard arrow. 

Next we will place the four resistors. 

1. In the Libraries panel, make sure the Miscellaneous Devices.IntLib library is active. 

2. Set the filter by typing res1 in the filter field below the Library name. 

3. Click on RES1 in the components list to select it, then click the Place button. You will now have a 
resistor symbol floating on the cursor. 

4. Press the TAB key to edit the resistor’s attributes. In the Properties section of the dialog, set the 
value for the first component designator by typing R1 in the Designator field. 

5. Make sure that model name AXIAL-0.3  is included in the Models list. 

6. Set up a parameter field for the resistor that will display on the schematic and be used by DXP 
when running a circuit simulation later in this tutorial. The =Value parameter can be used for any 
general information about the component but discrete components use it when simulating. We 
can also set the Comment to read this value and this maps the Comment information to the PCB 
layout tool. Rather than enter the value twice (in the parameter =Value and then in the Comment 
field), DXP supports ‘indirection’ which will replace the contents of the Comments field with the 
parameter’s string.  

Click Add in the Parameters list section to display the Parameter Properties dialog. Enter the name 
Value and a value of 100k. Make sure String is selected as the parameter type and the value’s 
Visible box is ticked. Click OK. 

7. In the Properties section of the dialog, click on the Comment field and select the =Value string 
from the drop down list and turn Visible off. Click the OK button to return to placement mode. 

8. Press the SPACEBAR to rotate the capacitor by 90° so it is in the correct orientation. 
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To reposition any object, 
simply place the cursor 
directly over the object, 
click-and-hold the left 
mouse button, drag the 
object to a new position 
and then release the 
mouse button. 

9. Position the resistor above the base of Q1 (refer to the schematic diagram in Figure 1) and left-
click or press ENTER to place the part. 

Don’t worry about making the resistor connect to the transistor just yet. We will wire up all the 
parts later. 

10. Next place the other 100k resistor R2 above the base of Q2. The designator will automatically 
increment when you place the second resistor. 

11. The remaining two resistors, R3 and R4, have a value of 1k, so press the TAB key to call up the 
Component Properties dialog and change the Value field to 1k (press Edit when the Value name is 
selected in the Parameters list). Click OK to close the dialogs. 

12. Position and place R3 and R4 as shown in the schematic diagram in Figure 1. 

13. Once you have placed all the resistors, right-click or press ESC to exit part placement mode.  

Now place the two capacitors. 

1. The capacitor part is also in the Miscellaneous Devices.IntLib library, which should 
already be selected in the Libraries panel. 

2. Type cap in the component’s filter field in the Libraries panel. 

3. Click on CAP in the components list to select it, then click the Place button. You will now have a 
capacitor symbol floating on the cursor. 

4. Press the TAB key to edit the capacitor’s attributes. In the Properties section of the Component 
Properties dialog, set the Designator to C1, check the PCB footprint model RAD-0.3 is added in 
the Models list.  

5. Set up a parameter field that will display on the schematic. Click Add in the Parameters list section 
to display the Parameter Properties dialog. Enter the name Value and a value of 20n. Make sure 
String is selected as the parameter type and the value’s Visible box is ticked. Click OK. 

6. In the Properties section of the dialog, click on the Comment field and select the =Value string 
from the drop down list and turn Visible off. Click the OK button to return to placement mode. 

7. Position and place the two capacitors in the same way that you placed the previous parts. 

8. Right-click or press ESC to exit placement mode. 

The last component to be placed is the connector, also in the Miscellaneous Connectors.IntLib 
library.  

1. The connector we want is a two-pin socket, so set the filter to *2*. 

2. Select HEADER2 from the parts list and click the Place button. Press TAB to edit the attributes and 
set Designator to Y1 and check the PCB footprint model is HDR1X2. No Value parameter is 
required as we will replace this component with a power source when simulating the circuit. Click 
OK to close the dialog. 

3. Before placing the connector, press X to flip it horizontally so that it is in the correct orientation. 
Place the connector on the schematic. 

4. Right-click or press ESC to exit part placement mode. 

5. Save your schematic by selecting File » Save from the menus [shortcut F, S]. 

You have now placed all the components. Note that the components in Figure 2 are spaced so that 
there is plenty of room to wire to each component pin. This is important because you can not place a 
wire across the bottom of a pin to get to a pin beyond it. If you do, both pins will connect to the wire.  

If you need to move a component, click-and-hold on the body of the component, then drag the 
mouse to reposition it. 
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To graphically edit the shape of a wire, or 
any other graphical object once it has been 
placed, position the arrow cursor over it 
and click once. 

Whenever a wire runs across the 
connection point of a component, or is 
terminated on another wire, Protel DXP will 
automatically create a junction. 

When placing wires, keep in mind the 
following points: 

- left-click or press ENTER to anchor the 
wire at the cursor position;  

- press BACKSPACE to remove the last 
anchor point;  

- after placing the last segment of a wire, 
right-click or press ESC to end the wire 
placement. The cursor will remain as a 
cross hair and you can begin placing 
another wire. 

A wire that crosses the 
end of a pin will connect 
to that pin, even if you 
delete the junction. 
Check that your circuit 
looks like Figure 3 before 
proceeding. 

 

Figure 2. Schematic with all parts placed. 

Wiring up the circuit 
Wiring is the process of creating connectivity between the various components of your circuit. To wire 
up your schematic, refer to the diagram in Figure 1 and complete the following steps. 

1. To make sure you have a good view of the schematic sheet, select View » Fit All Objects from the 
menus [shortcut V, F]. 

2. Firstly wire the resistor R1 to the base of transistor Q1 in the following manner. Select Place » 
Wire [shortcut P, W] from the menus or click on the Wire tool from the Wiring Tools toolbar to 
enter the wire placement mode. The cursor will change to a cross hair. 

3. Position the cursor over the bottom end of R1. When you are in the right position, a red 
connection marker (large asterisk) will appear at the cursor location. This indicates that the cursor 
is over an electrical connection point on the component. 

4. Left-click or press ENTER to anchor the first wire point. Move the cursor and you will see a wire 
extend from the cursor position back to the anchor point. 

5. Position the cursor so that it is below R1 and level with the 
base of Q1. Left-click or press ENTER to anchor the wire at this 
point. The wire between the first and second anchor points 
will be placed. 

6. Position the cursor over the base of Q1 until you see the 
cursor change to a red connection marker. Left-click or press 
ENTER to connect the wire to the base of Q1. 

7. Right-click or press ESC to finish placing this particular wire. 
Note that the cursor remains a cross hair, indicating that you 
are ready to place another wire. To exit placement mode 
completely and go back to the arrow cursor, you would right-
click or press ESC again – but don’t do this just now. 

8. We will now wire C1 to Q1 and R1. Position the cursor over 
the left connection point of C1 and left-click or press ENTER 
to start a new wire. 

9. Move the cursor horizontally till it is directly over the wire 
connecting the base of Q1 to R1. A connection marker will 
appear. 

10. Left-click or press ENTER to place the wire segment, then right-click or press ESC to indicate that 
you have finished placing the wire. Note how the two wires are automatically connected. 

11. Wire up the rest of your circuit, as shown in Figure 3. 
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Figure 3. The fully wired schematic 

12. When you have finished placing all the wires, right-click or press ESC to exit placement mode. The 
cursor will revert to an arrow. 

Nets and net labels 
Each set of component pins that you have connected to each other now form what is referred to as a 
net. For example, one net includes the base of Q1, one pin of R1 and one pin of C1. 

To make it easy to identify important nets in the design, you can add net labels.  

To place net labels on the two power nets: 

1. Select Place » Net Label from the menus. A dotted box will appear floating on the cursor. 

2. To edit the net label before it is placed, press the TAB key to display the Net Label dialog. 

3. Type 12V in the Net field, then click OK to close the dialog. 

4. Place the net label so that the bottom left of the net label touches the upper most wire on the 
schematic. The cursor will change to a red cross when the net label touches the wire. 

5. After placing the first net label you will still be in net label placement mode, so press the TAB key 
again to edit the second net label before placing it. 

6. Type GND in the Net field, click OK to close the dialog and place the net label. 

7. Select File » Save [shortcut F, S] to save your circuit. 

Congratulations! You have just completed your first schematic capture using Protel DXP.  

Before we turn the schematic into a circuit board, let’s set up the project options. 

Setting up Project Options 
The project options include the error checking parameters, a connectivity matrix, the Comparator 
setup, ECO generation, output paths and netlist options and any project parameters you wish to 
specify. Protel DXP will use these setups when you compile the project. 

When a project is compiled, comprehensive design and electrical rules are applied to verify the 
design. When all errors are resolved, the re-compiled schematic designs are loaded into the target 
document, e.g. a PCB document, by generated ECOs.  The project Comparator allows you to find 
differences between source and target files and update (synchronize) in both directions. 

All project-related operations, such as error checking, comparing documents  and ECO generation, 
are set up in the Options for Project dialog (Project » Project Options).  
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All project outputs, such as netlist, simulator, documentation (printing), assembly and fabrication 
outputs and reports are set up in the Outputs for Project dialog (Project » Output Jobs). See Setting up 
the Project Outputs for more information. 

1. Select Project » Project Options. The Options for Project dialog displays. 

 

All project-related options are set up through this dialog. 

Checking the electrical properties of your schematic 
Schematic diagrams in Protel DXP are more than just simple drawings – they contain electrical 
connectivity information about the circuit. You can use this connectivity awareness to verify your 
design. When you compile a project, DXP checks for errors according to the rules set up in the Error 
Reporting and Connection Matrix tabs and any violations generated will display in the Messages panel. 

Setting up Error Reporting 

The Error Reporting tab in the Options for Project dialog is used to set up design drafting checks. The 
Report Mode is the level of severity of a violation. If you wish to change a Report Mode, click on a 
Report Mode next to the violation you wish to change and choose the level of severity from the drop-
down list. For this tutorial we will use the default settings. 

Setting up the Connection Matrix 
The Connection Matrix tab (Options for 
Project dialog) displays the severity of an 
error type that is produced when error 
reporting is run to check electrical 
connections within the design, i.e. 
connections between pins, ports and sheet 
entries. The matrix gives a graphical 
representation of different types of 
connection points on a schematic and 
whether they are allowable or not.  

For example, look down the entries on the 
right side of the matrix diagram and find 
Output Pin. Read across this row of the 
matrix till you get to the Open Collector Pin 
column. The square where they intersect is 
orange indicating that an Output Pin 
connected to an Open Collector Pin on your 
schematic will generate an error condition 
when the project is compiled.  
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You can set each error type with a separate error level, e.g. from no report at all through to a fatal 
error.  

To make changes to the Connection Matrix: 

1. Click on the Connection Matrix tab in the Options for Project dialog.  

2. Click on the box that is at the intersection of two types of connection, e.g. Output Sheet Entry and 
Open Collector Pin.  

3. Click until the box changes to the color of the errors as listed in the legend, e.g. an orange box 
indicates that an error will be generated if such a connection is found. 

Our circuit contains only Passive Pins (on resistors, capacitors and the connector) and Input Pins (on 
the transistors. Let’s check to see if the connection matrix will detect unconnected passive pins. 

1. Look down the row labels to find Passive Pin. Look across the column labels to find Unconnected. 
The square where these entries intersect indicates the error condition when a Passive Pin is found 
to be Unconnected in the schematic. The default is a green square, which indicates that no report 
will be generated.  

2. Click on this intersection box until it turns yellow so that a warning will be generated for 
unconnected passive pins when we compile the project. We will purposely create an instance of 
this error to check it later in this tutorial. 

Setting up the Comparator 
The Comparator tab in the Options for Project dialog sets which differences between files will be 
reported or ignored when a project is compiled. For this tutorial, we do not need to show differences 
between some features that refer to hierarchical schematic designs only, such as rooms. Make sure 
you do not accidentally ignore components when you meant to ignore component classes! 

1. Click on the Comparator tab and find Changed Room Definitions, Extra Room Definitions and 
Extra Component Classes in the Difference Associated with Components section.  

2. Select Ignore Differences from the drop-down list in the Mode column to the right of the these 
options. 

 

Now we are ready to compile the project and check for any errors. 
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If you wish to clear 
messages from the 
Messages panel, right-
click in the window and 
select Clear All. 

Compiling the project 
Compiling a project checks for drafting and electrical rules errors in the design documents and puts 
you into a debugging environment. We have already set up the rules in the Error Checking and 
Connection Matrix tabs of the Options for Project dialog. 

1. To compile our Multivibrator project, select Project » Compile PCB Project. 

2. When the project is compiled, any errors generated will display in the Messages panel at the 
bottom of the design window. The compiled documents will be listed in the Compiled panel, 
together with a flattened hierarchy, components and nets listed and a connection model that can 
be browsed. 

If your circuit is drawn correctly, the Messages panel should be blank. If the report gives errors, check 
your circuit and ensure all wiring and connections are correct. 

We will now deliberately introduce an error into our circuit and recompile the project: 

1. Click on the Multivibrator.SchDoc tab at the top of the design window to make the schematic 
sheet the active document. 

2. Click in the middle of the wire that connects C1 to the base wire of Q1. Small, square editing 
handles will appear at each end of the wire and the selection color will display as a dotted line 
along the wire to indicate that it is selected. Press the DELETE key to delete the wire.  

3. Recompile the project (Project » Compile PCB Project) to check that any errors are found. 

The Messages panel will open giving a warning message that you have an unconnected input pin 
in your circuit. A floating input pin error will also be generated as there is a special option to 
check for floating input pins in the Error Reporting tab of the Project Options dialog. 

4. Click on an error in the Messages panel and the Compile Error window will display with details of 
the violation. From this window, you can click on an error and jump to the violating object in a 
schematic to check or correct the error. 

Before we finish this section of the tutorial, let’s fix the error in our schematic. 

1. Click on the tab of the schematic sheet to make it active. 

2. Select Edit » Undo from the menus [shortcut E, U]. The wire you deleted previously should now 
be restored. 

3. To check that the undo was successful, recompile the project (Project » Compile PCB Project) to 
check that no errors are found. The Messages panel should show no errors. 

4. Select View » Fit All Objects [shortcut V, F] from the menus to restore your schematic view and 
save your error-free schematic. 
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Creating a new PCB document 
Before you transfer the design from the Schematic editor to the PCB editor, you need to create the 
blank PCB with at least a board outline. The easiest way to create a new PCB design in Protel DXP is to 
use the PCB Wizard, which allows you to choose from industry-standard board outlines as well as 
create your own custom board sizes.  At any stage you can use the Back button to check or modify 
previous pages in the wizard. 

To create a new PCB using the PCB Wizard, complete the following steps: 

1. Create a new PCB by clicking on PCB Board 
Wizard in the New from Template section at the 
bottom of the Files panel. If this option is not 
displayed on the screen, close some of the 
sections above by clicking on the up arrow icons. 

2. The PCB Board Wizard opens. The 
first screen you see is the 
introduction page. Click the 
Next button to continue. 

3. Set the measure units to 
Imperial, i.e. 1000 mils = one 
inch. 

4. The third page of the wizard 
allows you to select the 
board outline you wish to 
use. For this tutorial we will 
enter our own board size. 
Select Custom from the list 
of board outlines and click Next. 

5. In the next page you enter custom board options. 
For the tutorial circuit, a 2 x 2 inch board will give 
us plenty of room. Select Rectangular and type 
2000 in both the Width and Height fields. 
Deselect Title Block & Scale, Legend String and 
Dimension Lines. Click Next to continue.  

6. This page allows you to select the number of layers in the board. We will need two signal layers 
and no power planes. Click Next to continue. 

7. Choose the via styles used in the design by selecting Thru-hole vias only and click Next. 

8. The next page allows you to set the component/track technology (routing) options. Select the 
Thru-hole components option and set the number of tracks between adjacent pads to One Track. 
Click Next to continue. 

9. The next page allows you to set up some of the design rules that apply to your board. Leave the 
options on this screen set to their defaults. Click the Next button to continue. 

10. The final page allows you to save your custom board as a template, allowing you to create new 
boards based on the parameters you have just entered. We do not want to save our tutorial board 
as a template, confirm that this option is unchecked and click Finish to close the Wizard. 

11. The PCB Wizard has now collected all the information it needs to create your new board. The PCB 
Editor will now display a new PCB file named PCB1.PcbDoc. 

12. The PCB document displays with a default sized white sheet and a blank board shape (black area 
with grid). To turn off the sheet, select Design » Options and deselect Design Sheet in the Board 
Options dialog. 
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You can create a report 
of ECOs to print out by 
clicking on the Report 
Changes button. 

For more tutorials, press 
F1 to access the Protel 
DXP Help  and Online 
Documentation system 
and click on the Articles 
& Tutorials link. 

 

You can add your own border, grid reference and title block from other PCB templates supplied 
with Protel DXP. For more information about using board shapes, sheets and templates, see the 
Board Shapes and Sheets tutorial. 

13. Now the sheet has been turned off, display the board shape only by selecting View » Fit Board 
[shortcut V, F]. 

14. The PCB document is automatically added (linked) to the project and is listed under PCBs 
beneath the project name in the Projects tab. 

15. Rename the new PCB file (with a .PcbDoc extension) by selecting File » Save As. Navigate to a 
location where you would like to store the PCB on your hard disk, type the name 
Multivibrator.PcbDoc in the File Name field and click on Save. 

Adding a new PCB to a project 
If the PCB you want to add to a project file has been opened as a Free Document, right-click on the 
PCB document in the Free Documents section of the Projects panel and select Add to Project. The 
PCB is now listed under PCBs beneath the project in the Projects tab and is linked to the project file. 

Transferring the design 
Before transferring the schematic information to the new blank PCB, make sure all the related libraries 
for both schematic and PCB are available. Since only the default installed integrated libraries are used 
in this tutorial, the footprints will already be included. Once the project has been compiled and any 
errors in the schematic fixed, use the Update PCB command to generate ECOs that will transfer the 
schematic information to the target PCB.  

Updating the PCB 
To send the schematic information to the target PCB in your project: 

1. Select Design » Update PCB (Multivibrator.PcbDoc). The project compiles and the 
Engineering Change Order dialog displays.  

2. Click on Validate Changes. If all changes are validated, the checks appear in the Status list. If the 
changes are not validated, close the dialog, check the Messages panel and clear any errors. 
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3. Click on Execute Changes to send the changes to the PCB. When completed, the Status changes 
to Done.  

4. Click Close and the target PCB opens with components positioned ready for placing on the board. 
Use the shortcut keys V, D (View Document) if you cannot see the components in your current 
view. 

 

Figure 4. The components next to the board, ready for positioning. 

Designing the PCB 
Now we can start placing the components on the PCB and routing the board. 

Setting up the PCB workspace 
Before we start positioning the components on the board, we need to set up the PCB workspace, such 
as the grids, layers and design rules. 

Grids 
We need to ensure that our placement grid is set correctly before we start positioning the 
components. All the objects placed in the PCB workspace are aligned on a grid called the snap grid. 
This grid needs to be set to suit the routing technology that you intend to use.  

Our tutorial circuit uses standard imperial components that have a minimum pin pitch of 100mil. We 
will set the snap grid to an even fraction of this, say 50 or 25mil, so that all component pins will fall on a 
grid point when placed. Also, the track width and clearance for our board are 12mil and 13mil 
respectively (the default values used by the PCB Board Wizard), allowing a minimum of 25mil between 
parallel track centers. The most suitable snap grid setting would, therefore, be 25mil.  

To set the snap grid, complete the following steps:  

1. Select Design » Options from the menus [shortcut D, O] to open the Board Options dialog. 

2. In the Grids tab, set the value of the Snap X, Snap Y, Component X and Component Y fields of the 
dialog to 25mil. Note that this dialog is also used to define the electrical grid. The electrical grid 
operates when you place an electrical object, it overrides the snap grid and snaps electrical 
objects together. Click OK to close the dialog. 

Let’s set some other options that will make positioning components easier. 

1. Select Tools » Preferences from the menus [shortcut T, P] to open the System Preferences dialog. 
In the Editing Options section of the Options tab, make sure the Snap to Center option is 
checked. This ensures that when you “grab” a component to position it, the cursor is set to the 
component’s reference point. 

2. Click the Display tab in the System Preferences dialog to make it active. In the Show section of this 
tab, uncheck the Show Pad Nets, Show Pad Numbers and Via Nets options. In the Draft 
Thresholds section of this dialog, set the Strings field to 4 pixels and then close the dialog. 

The PCB Editor supports 
imperial and metric units. 
Select View » Toggle 
Units to switch. 
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Defining the layer stack and other non-electrical layers 
If you look at the bottom of the PCB workspace, you will notice a series of layer tabs. The PCB Editor is 
a multi-layered environment and most of the editing actions you perform will be on a particular layer. 
Use the Board Layers dialog (Design » Board Layers) to display, add, remove and rename and set the 
colors of the layers. 

 

There are three types of layers in the PCB Editor: 

• Electrical layers – these include the 32 signal layers and 16 plane layers. Electrical layers are added 
to and removed from the design in the Layer Stack Manager, select Design » Layer Stack Manager 
to display this dialog. 

• Mechanical layers – there are 16 general purpose mechanical layers for defining the board outline, 
placing dimensions on, including fabrication details on, or any other mechanical details the 
design requires. These layers can be selectively included in print and Gerber output generation. 
You can add, remove and name mechanical layers in the Board Layers dialog. 

• Special layers – these include the top and bottom silkscreen layers, the solder and paste mask 
layers, drill layers, the Keep-Out layer (used to define the electrical boundaries), the multilayer 
(used for multilayer pads and vias), the connection layer, DRC error layer, grid layers and hole 
layers. The display of these special layers is controlled in the Board Layers dialog. 

Layer Stack Manager 
The tutorial is a simple design and can be routed as a single-sided or double-sided board.  If the 
design was more complex, you would add more layers in the Layer Stack Manager.  

1. Select Design » Layer Stack Manager to display the Layer Stack Manager dialog. 
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2. New layers and planes are added below the currently selected layer. Layer properties, such as 
copper thickness and dielectric properties are used for signal integrity analysis. Click OK to close 
the dialog.  

The new board has opened with many more layers enabled than you will use, so let’s turn off all the 
unnecessary layers.  

To turn off layers, complete the following steps: 

1. Press the L shortcut key to display the Board Layers dialog. 

2. Right-click and select Used On to disable all layers except those that have something on them. 

3. Make sure the four Mask layers and the Drill Drawing layer will not display by clicking off the tick 
in the Show button next to their layer names. Click OK to close the dialog. 

Setting up new design rules 
The Protel DXP’s PCB editor is a rules-driven environment. This means that as you work in the PCB 
editor and perform actions that change the design, such as placing tracks, moving components, or 
autorouting the board, the PCB editor constantly monitors each action and checks to see if the design 
still complies with the design rules. If it does not, then the error is immediately highlighted as a 
violation.  

Setting up the design rules before you start working on the board allows you to remain focused on the 
task of designing, confident in the knowledge that any design errors will immediately be flagged for 
your attention. 

The design rules fall into 10 categories and are further divided into design rule types. The design rules 
cover electrical, routing, manufacturing, placement and signal integrity requirements. 

We will now set up new design rules to specify the width that the power nets must be routed. 

To set up these rules, complete the following steps: 

1. With the PCB as the active document, select Design » Rules from the menus. 

2. The PCB Rules and Constraints Editor dialog will appear. Each category of rules is displayed in the 
Design Rules panel (left hand side) of the dialog. Double-click on the Routing category to expand 
the category and see the related routing rules. Then double-click on Width to display the width 
rules available. 

 

3. Click once on each rule in the Design Rules panel to select it. As you click on each rule, the right 
hand side of the dialog displays the rule’s scope (what you want this rule to target) in the top 
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section and the rule’s constraints in the bottom section. These rules are either defaults, or have 
been set up by the Board Wizard when the new PCB document was created. 

4. Click on the Width_1 rule to display its constraints and scope. This rule applies to the entire 
board. 

 

One of the powerful features of Protel DXP’s design rule system is that multiple rules of the same type 
can be defined, each targeting different objects. The exact set of objects that each rule targets is 
defined by that rule’s scope. The rule system uses a pre-defined hierarchy to work out which rule to 
apply to each object. 

For example, you could have a width constraint rule for the whole board (meaning all tracks must be 
this width), a second width constraint rule for the ground net (this rule overrides the previous rule), 
and a third width constraint rule for a particular connection on the ground net (which overrides both 
of the previous rules). Rules are displayed in their order of priority. 

Currently there is one width constraint rule for your design, which applies to the whole board. We will 
now add a new width constraint rule for the 12V and GND nets. To add new width constraint rules, 
complete the following steps: 

1. With the Width category selected in the Design Rules panel, right-click and select New Rule to 
add a new width constraint rule set up to target the 12V net only.  

A new rule named Width_2 appears.  Click on the new rule in the Design Rules panel to modify 
the scope and constraints. 

2. Type 12V or GND in the Name field. The name will refresh in the Design Rules panel when you 
click back in the Design Rules panel when you have finished setting the rule. 

3. Next we set the rule’s scope using the Query Builder but you can always type in the scope directly 
if you know the correct syntax.  

Click on Net in the Where the First object matches section.  The query InNet( ) appears in the 
Query Kind section.  Click on the dropdown list next the All button and select 12V from the list of 
available nets. The query updates to read InNet (‘12V’). 
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4. Next we will use the Query Builder to expand the scope to include the GND net as well. Click on 
Advanced (Query) and then click on Query Builder. The Query Helper dialog displays. 

 

5. Click in the Query section to the right of the query InNet(‘12V’) and click on the Or button.  
The query now reads InNet(‘12V’) or and this sets the scope to apply the rule to both nets. 

6. Click on Membership Checks in the PCB Functions category and double-click to select the InNet 
query in the Name section.  

7. Click once between the parenthesis of the new InNet( ) query in the Query section to add in 
the net name for the GND net. Click on Nets in the PCB Objects List category and double-click to 
select GND from the list of nets available.  Check that the query InNet(‘12V’) or 
InNet(‘GND’) is created.  

8. Click on Check Syntax to confirm the query is correct and click OK to close the resulting message. 
Fix the query syntax if an error message displays. 

9. Click OK to close the Query Helper dialog. The scope in the Full Query section has now been 
updated with the new query.  

10. In the bottom section of the PCB Rules and Constraints Editor dialog, change the Minimum, 
Preferred and Maximum width fields to 25mil by clicking on the old constraints text (10mil) and 
typing in the new values. Note that you must set the Maximum width field first before you can 
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change the Minimum value. The new rule is now set up and will save when you choose another 
rule in the Design Rules panel or close the dialog. 

 

11. Finally, double-click to edit the original Board scope width rule named Width_1 and confirm that 
the Minimum, Maximum and Preferred width fields are all set to 12mil. Click OK to close the PCB 
Rules and Constraints Editor dialog. 

When you route the board manually or using the autorouter, all tracks will be 12mils wide, except the 
GND and 12V tracks which will be 25mils. 

Positioning the components on the PCB 
Now we can start to place the components in their right positions.  

1. Press the V, D shortcut keys to zoom in on the board and components. The footprints have been 
placed in a room named ‘Multivibrator’.  Click on the room and press Delete if not required. 

2. To place the connector Y1, position the cursor over the middle of the outline of the connector, 
and click-and-hold the left mouse button. The cursor will change to a cross hair and jump to the 
reference point for the part. 

3. While continuing to hold down the mouse button, move the mouse to drag the component. 

4. While dragging the connector, press the SPACEBAR to rotate it by 90°, and position it toward the 
left-hand side of the board (ensuring that the whole of the component stays within the board 
boundary), as shown in Figure 5. 

  

Figure 5. Components placed on the PCB 
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The connection lines are 
automatically re-optimized 
as you move a component. 
In this way you can use the 
connection lines as a guide 
to the optimum position and 
orientation of the 
component as you place it. 

5. When the component is in position, release the mouse button to drop it into place. Note how the 
connection lines drag with the component. 

6. Reposition the remaining components, using Figure 5 as a guide. Use the SPACEBAR key as 
necessary to rotate components as you drag them, so that the connection lines are as shown in 
Figure 5. Don’t forget to re-optimize the connection lines as you position each component. 

Component text can be repositioned in a similar fashion – click-and-hold to drag the text, press the 
SPACEBAR to rotate it. Before repositioning the text we will use Protel DXP’s powerful global editing 
in the next part of the tutorial to hide the component comments (values), as these will not be required 
on the final board. 

Protel DXP also includes powerful interactive placement tools. Let’s use these to ensure that the four 
resistors are correctly aligned and spaced. 

1. Holding the SHIFT key, left-click on each of the four resistors to select them. A selection box will 
display around each of the selected components in the color set for the system color called 
Selections. To change this selection color, select Design » Board Layers. 

2. Click on the Align Tops of Selected Components button on the Component Placement toolbar. 
The four resistors will align along their top edge. 

3. Now click on the Make Horizontal Spacing of Selected Components Equal button on the 
Component Placement toolbar. 

4. Click elsewhere in the design window to deselect all the resistors. The four resistors are now 
aligned and equally spaced. 

Changing a footprint 
Now that we have positioned the footprints, the capacitor footprint appears too big for our 
requirements! Let’s change the capacitor footprint to a smaller one. 

1. First we will browse for a new footprint. Click on the Libraries panel and select Miscellaneous 
Deivices.IntLib from the Libraries list. Click on Footprints to display footprints available in the 
active library. We want a smaller radial type footprint, so type rad in the Filter field. Click on the 
Footprint names to see the footprints associated with them. The footprint RAD-0.1 will do the job.  

2. Double-click on the capacitors and change the Footprint field to RAD-0.1 in the Component 
dialog. Click OK and the new footprints are displayed on the board. Reposition the designators as 
required. 

3. Your board should now look like the PCB design below. 

 

With everything positioned, it’s time to lay some tracks! 
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You may find using a 
larger crosshair cursor 
useful when placing 
tracks. To change the 
cursor size, select Tools 
» Preferences. Select  
Large 90 from the 
Cursor Type list in the 
Options tab of the 
Preferences dialog. 

Manually routing the board 
Routing is the process of laying tracks and vias on the board to connect the components. Protel DXP 
makes the job of routing easy by providing a number of sophisticated manual routing tools as well as 
the new powerful Situs topological autorouter, which optimally routes the whole or part of a board at 
the touch of a button.  

While autorouting provides an easy and powerful way to 
route a board, there will be situations where you will 
need exact control over the placement of tracks – or you 
may want to route the board manually just for the fun of 
it! In these situations you can manually route part or all 
of your board. In this section of the tutorial, we will 
manually route the entire board “single-sided”, with all 
tracks on the bottom layer. 

We will now place tracks on the bottom layer of the 
board, using the “ratsnest” connection lines to guide us. 

In Protel DXP, tracks on a PCB are made from a series of 
straight segments. Each time there is a change of 
direction, a new track segment begins. Also, by default 
Protel DXP constrains tracks to a vertical, horizontal or 
45° orientation, allowing you to easily produce 
professional results. This behavior can be customized to 
suit your needs, but for this tutorial we will stay with the 
default. 

1. Select Place » Interactive Routing from the menus 
[shortcut P, T] or click the Interactive Routing button 
on the Placement toolbar. The cursor will change to 
a cross hair indicating you are in track placement 
mode. 

2. Examine the layer tabs that run along the bottom of 
the document workspace. The TopLayer tab should 
currently be active. To switch to the bottom layer 
without dropping out of track placement  mode, 
press the * key on the numeric keypad. This key 
toggles between the available signal layers. The 
BottomLayer tab should now be active. 

3. Position the cursor over the bottom-most pad on the 
connector Y1. Left-click or press ENTER to anchor the 
first point of the track. 

4. Move the cursor towards the bottom pad of the 
resistor R1. Note how the track is laid. By default, 
tracks are constrained to vertical, horizontal or 45° 
directions. Also note that the track has two 
segments. The first (coming from the starting pad) is 
solid blue. This is the track segment you are actually 
placing. The second segment (attached to the cursor) 
is called the “look-ahead” segment and is drawn in 
outline. This segment allows you to look ahead at 
where the next track segment you lay could be 
positioned so that you can easily work your way 
around obstacles, maintaining a 45°/90° track orientation. 

5. Position the cursor over the middle of the bottom pad of resistor R1 and left-click or press the 
ENTER key. Note that the first track segment turns blue, indicating that it has been placed on the 
Bottom Layer. Move the cursor around a little and you will see that you still have two segments 

 

First click starts 
you placing a 
track. Now move 
the cursor toward 
the bottom pad on 
R1. 

 

 

 

 

 

Note how the 
connection line 
guides you to the 
target pad. 

 

 

Segment you are 
currently placing 

 

Look-ahead 
segment 

Position the cursor 
over the pad on 
R1. 

 

 

Click a second 
time to place this 
track segment. 

 

 

 

Third click to place 
the next track 
segment.  

You have now 
routed this 
connection. 
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attached to the cursor: a solid blue segment that will be placed with the next mouse click and an 
outlined “look-ahead” segment to help you position the track. 

6. Re-position the cursor over the bottom pad of R1. You will have a solid blue segment extending 
from the previous segment to the pad. Left-click to place the solid blue segment.  

You have just routed the first connection. 

7. Move the cursor to position it over the bottom pad of 
resistor R4. Note a solid blue segment extends to R4. Left-
click to place this segment. 

8. Now move the cursor to the bottom pad of resistor R3. 
Note that this segment is not solid blue, but drawn in 
outline indicating it is a look-ahead segment. This is 
because each time you place a track segment the mode 
toggles between starting in a horizontal/vertical direction 
and starting at 45°. Currently it is in the 45° mode. Press the 
SPACEBAR key to toggle the segment start mode to 
horizontal/vertical. The segment will now be drawn in solid 
blue. Left-click or press the ENTER key to place the 
segment. 

9. Move the cursor to the bottom of resistor R2. Once again 
you will need to press the SPACEBAR key to toggle the segment start mode. Left-click or press the 
ENTER key to place the segment. 

10. You have now finished routing the first net. Right-click or press the ESC key to indicate that you 
have finished placing this track. The cursor will remain a cross hair, indicating that you are still in 
track placement mode, ready to place the next track. Press the END key to redraw the screen so 
that you can clearly see the routed net. 

11. You can now route the rest of the board in a similar manner to that described in the previous 
steps. Figure 6 shows the manually routed board. 

 

Figure 6. Manually routed board, with tracks placed on the bottom layer. 

12. Save the design. 

Keep in mind the following points as you are placing the tracks: 

• Left-clicking the mouse (or pressing the ENTER key) places the track segment drawn in solid color. 
The outlined segment represents the look-ahead portion of the track. Placed track segments are 
shown in the layer color. 

 

Note that the look-ahead segment is clipping 
(no longer attached to the cursor). The PCB 
Editor will prevent you from accidentally 
placing a track across another object that 
would cause a violation. This connection must 
be routed around the capacitor. 
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• Press the SPACEBAR key to toggle between the start horizontal/vertical and start 45° modes for 
the track segment you are placing. 

• Press the END key at any time to redraw the screen. 

• Press the V, F shortcut keys at any time to redraw the screen to fit all objects. 

• Press the PAGEUP and PAGEDOWN keys at any time to zoom in or out, centered on the cursor 
position. 

• Press the BACKSPACE key to “unplace” the last track segment. 

• Right-click or press the ESC key when you have finished placing a track and want to start a new 
one. 

• You cannot accidentally connect pads that should not be wired together. Protel DXP continually 
analyzes the board connectivity and prevents you from making connection mistakes or crossing 
tracks. 

• To delete a track segment, left-click on it to select it. The segment’s editing handles will appear 
(the rest of the track will be highlighted). Press the DELETE key to clear the selected track 
segment. 

• Re-routing is easy in Protel DXP – simply route the new track segments, when you right-click to 
finish the old redundant track segments will automatically be removed. 

• When you have finished placing all the tracks on your PCB, right-click or press the ESC key to exit 
placement mode. The cursor will change back to an arrow. 

Congratulations! You have manually routed your board design. 

Automatically routing the board 
To see how easy it is to autoroute with Protel DXP, complete the following steps: 

1. First, un-route the board by selecting Tools » Un-Route » All from the menus [shortcut U, A]. 

2. Select Autoroute » All from the menus [shortcut A, A]. 

3. When the autorouter has finished, press the END key to redraw the screen. 

It’s as simple as that! Protel DXP’s autorouter provides results comparable with that of an 
experienced board designer and because Protel DXP routes your board directly in the PCB 
window, there is no need to wrestle with exporting and importing route files. 

4. Select File » Save [shortcut F, S] to save your board. 

Note that the tracks placed by the autorouter appear in two colors: red indicates that the track is on 
the top signal layer of the board and blue indicates the bottom signal layer. The layers that are used by 
the autorouter are specified in the Routing Layers design rule, which was set up by the PCB Board 
Wizard.  You will also notice that the two power net tracks running from the connector are wider, as 
specified by the two new Width design rules you set up. 

Don’t worry if the routing in your design is not exactly the same as Figure 7; the component placement 
will not be exactly the same, so neither will be the routing. 
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Protel DXP supports 
hierarchical design rules. 
You can set any number 
of rules of the same 
class, each with a 
defined scope. The rule 
scope determines the 
rule’s precedence. 

 

Figure 7. Fully autorouted board 

Because we originally defined our board as being double-sided in the PCB Board Wizard, you could 
manually route your board “double-sided” using both the top and bottom layers. To do this, un-route 
the board by selecting Tools » Un-Route » All from the menus [shortcut U, A]. Start routing as before, 
but use the * key to toggle between the layers while placing tracks. Protel DXP will automatically insert 
vias if necessary when you change layers. 

Verifying your board design 
Protel DXP provides a rules-driven environment in which to design PCBs and allows you to define 
many types of design rules to ensure the integrity of your board. Typically, you set up the design rules 
at the start of the design process and then verify that the design complies with the rules at the end of 
the design process. 

Earlier in the tutorial we examined the routing design rules and added a new width constraint rule. We 
also noted that there were already a number of rules that had been created by the PCB Board Wizard. 

To verify that the routed circuit board conforms to the design rules, we will now run a Design Rule 
Check (DRC): 

1. Choose Design » Board Layers [shortcut L] and ensure that Show button next to the DRC Error 
Markers option in the System Colors section is checked (ticked) so that the DRC error markers 
will be displayed, if any. 

2. Choose Tools » Design Rule Check from the menus [shortcut T, D]. Both the on-line and batch 
DRC options are configured in the Design Rule Checker dialog. Click on a category to see all the 
rules. 
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3. Leave all options at their defaults and click the Run Design Rule Check button. The DRC will run 
and the results will be displayed in the Messages panel. Also, you will see that the transistor pads 
are highlighted in green, indicating a design rule violation. 

4. Look through the errors list. It lists any violations that occur in the PCB design. Notice that there 
are four violations listed under the Clearance Constraint rule. The details show that the pads of 
transistors Q1 and Q2 violate the 13mil clearance rule.  

5. Double-click on an error in the Messages panel to jump to its location on the PCB. 

Normally you would set up the clearance constraint rules before laying out your board, taking account 
of routing technologies and the physical properties of the devices. Let’s analyze the error then review 
the current clearance design rules and decide how to resolve this situation. 

To find out the actual clearance between the transistor pads: 

1. With the PCB document active, position the cursor over the middle of one of the transistors and 
press the PAGEUP key to zoom in. 

2. Select Reports » Measure Primitives [shortcut R, P]. The cursor will change to a cross hair. 

3. Position the cursor over the middle of the lower pad on the transistor and left-click or press 
ENTER. Because the cursor is over both the pad and 
the track connected to it, a menu will pop up to 
allow you to select the desired object. Select the 
transistor pad from the popup menu. 

4. Position the cursor over the middle of one of the 
other transistor pads and left-click or press ENTER. 
Once again select the pad from the popup menu. 
An information box will open showing the 
minimum distance between the edges of the two pads is 10.63mil. 

5. Close the information box, then right-click or press ESC to exit the measurement mode and then 
use the V, F shortcut to re-zoom the document. 

Let’s look at the current clearance design rules. 

1. Select Design » Rules from the menus [shortcut D, R] to open the PCB Rules and Constraints 
Editor dialog. Double-click on the Electrical category to display all electrical rules in the right side 
of the dialog. Double-click on the Clearance type (listed in the right side) and then click on 
Clearance_1 to open it. The region at the bottom of the dialog will contain a single rule, 
specifying that the minimum clearances for the whole board are 13mil. The clearance between the 
transistor pads is less than this, which is why they generate a violation when we run a DRC. 

We now know the minimum distance between transistor pads is a little over 10mil, so let’s set up a 
design rule that allows the clearance constraint to be 10mil for the transistors only. 

2. Select the Clearance type in the Design Rules panel, right-click and select New Rule to add a new 
clearance constraint rule. 

3. Double-click on the new Clearance rule and in the Constraints section of the resulting dialog, set 
the Minimum Clearance to 10mil. 

4. Click on Advanced (Query) and then click on Query Builder to construct the query from the 
Memberships Checks, or type in the query in the Query field: 
HasFootprintPad(‘BCY-W3/D4.7’,’*’) 
The * (asterisk) indicates ‘any pad’ on the footprint named BCY-W3/D4.7.   

5. Click OK to close the dialog.  

6. You can now re-run the DRC from the Design Rules Checker dialog (Tools » Design Rule Check) 
by clicking the Run Design Rule Check button. There should be no rule violations. 

Well done! You have completed the PCB layout and are ready to produce the output documents. 
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When in the Print 
Preview, select Edit » 
Copy from the right-click 
menu  to copy the 
current printout to the 
clipboard and paste it 
into another Windows 
application.  

Select File » 
ExportMetafile  to 
export the printouts to 
the hard disk as EMF 
files. 

If you do not want output 
files to automatically 
open when they are 
created, select Project » 
Project Options, click 
on the Paths tab and 
deselect Open Outputs 
after compile. 

Setting up the Project Outputs 
Project outputs, such as printing and output files, are set up in the Outputs for Project dialog. 

1. Select Project » Output Jobs. The Project 
[project_name] dialog displays. 

2. Click on the output you wish to set up. If the 
Configure button is active (not grayed out) 
you will be able to modify the setups of that 
output. 

3. Click Close when you have finished your 
setups. 

4. If you want the outputs to be sent to 
individual folders according to the output 
type, select Project » Project Options, click 
on the Options tab and click on Use separate 
folder for each output type and click OK.  

Printing to a Windows printing 
device 
Once the layout and routing of the PCB is 
complete, you are ready to produce the output 
documentation. This documentation might 
include a manufacturing drawing detailing the 
fabrication information and assembly drawings 
detailing component location information and 
loading order. 

To produce these drawings, Protel DXP includes a 
sophisticated printing engine that gives you 
complete control over the printing process. You can define precisely what mix of PCB layers you want 
to print, preview the drawings (called printouts) and set the scaling and orientation to see exactly how 
it will look on the page before you print it. 

Now we will create a print preview using default output settings and then change the setups. 

1. Select File » Print Preview from the PCB menus. The PCB will be analyzed and a default printout 
displayed in the print preview window.  Click on Close. 

2. To examine the set of PCB layers that are included in the printout, select Project » Output Jobs. 
The Project dialog displays. Select Composite Drawing from the Documentation Outputs section 
and click on the Configure button. The PCB Printout Properties dialog displays. You can add or 
delete layers using the right-click menu options. Click OK to close the dialog. 

3. While we are in still the Project dialog, we will change the layer configurations for the 
Combination Drill Guide. Select Composite Drill Drawing from the Fabrication Outputs section 
and click on the Configure button. By default, this printout includes both the drill guide, a system 
layer which includes a small cross at each drill site, and the drill drawing layer, which includes a 
special shape at each drill site, unique for each drill size.  

The drill guide layer is not required in a typical drill drawing, so to remove it, right-click on the 
DrillGuide layer in the Printouts & Layers column and select Delete from the menu. Click OK to 
close the dialog. 
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4.  Now click on Print Preview to view your drill drawing. You can then click on Print to display your 
printer setups and then click OK to send your drawing to the specified printer. 

 

5. Click Close to close the print preview window. 

6. To change the target printer and set the page orientation and scaling, you can select the Page 
Setup button in the Project dialog (or File » Page Setup from the menus). Choose your preferred 
printer and set the printer page to Landscape.  

7. When you have completed your setups, close all open dialogs. 

Manufacturing output files 
The final phase of the PCB design process is to generate the manufacturing files. The set of files that 
are used to manufacture and fabricate the PCB include Gerber files, NC drill files, pick and place files, 
a bill of materials and testpoint files. Output files can be set in the Project dialog (Project » Output 
Jobs) or through individual commands on the File » Fabrication Outputs menu. The setups for the 
manufacturing documents are stored as part of the project file. 

Generating Gerber files 
Each Gerber file corresponds to one layer in the physical board – the component overlay, top signal 
layer, bottom signal layer, the solder masking layers and so on. It is advisable to consult with your PCB 
manufacturer to confirm their requirements before generating the Gerber and NC drill files required 
to fabricate your design. 

To create the manufacturing files for the tutorial PCB: 

1. Make the PCB the active document, then select File » Fabrication Outputs »Gerber files. The 
Gerber Setup dialog displays. 
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2. Click OK to accept the default settings. The Gerber files are produced and CAMtastic! opens to 
display the files. The Gerber files are stored in the Project Outputs folder which is 
automatically created in the folder where your project files reside. Each file has  the file extension 
added that corresponds to the layer name, e.g. Multivibrator.GTO for Gerber Top Overlay. 

Bill of Materials 
1. To create a Bill of Materials, first configure your report. Choose Project » Output Jobs and select 

Bill of Materials in the Report Outputs section of the Project dialog. 

2. Click on Create Report. In this dialog, you can set up which information you require for your 
BOM report by clicking and dragging the column headings between the Visible and Hidden 
Column sections.   

 

3. Click on Report… to display a print preview of your BOM. This preview can then be printed using 
the Print button or exported to a file format, such as .xls for Microsoft Excel, using the Export 
button. 

4. Close the dialogs. 

Congratulations! You have completed the PCB design process. 
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Simulating the design 
Protel DXP allows you to run a vast array of circuit simulations directly from a schematic. In the 
following sections of the tutorial we will simulate the output waveforms produced by our 
multivibrator circuit. 

Setting up for simulation  
Before we can run a simulation we need to add a few things to our circuit: a voltage source to power 
the multivibrator; a ground reference for the simulations and some net labels on the points of the 
circuit where we wish to view waveforms. 

1. Click on the Multivibrator.SchDoc tab at the top of the window to make the schematic the 
active document. 

2. We must replace the connector with a voltage source. To delete the connector, click once on the 
body of the connector to select it (a dotted selection box will appear around the connector), then 
press the DELETE key on the keyboard. 

3. At the moment there is not enough room for the voltage source, so we’ll move the free ends of 
the wires. To move the dangling end of the 12V wire, click once on the wire to select it. When the 
small square editing handles appear, click once on the handle on the free end of the wire, then 
move the handle up almost to where the wire changes direction (but not all the way up). Click 
again to “drop” the handle. 

4. Repeat this process for the dangling end of the GND wire, moving it toward the bottom of the 
sheet. 

5. Select View » Toolbars » Simulation Sources to display the Simulation Sources toolbar. 

6. Click the +12V source button on the Simulation Sources toolbar. A source symbol will appear 
floating on the cursor. Press the TAB key on the keyboard to edit its attributes. In the resulting 
dialog, click the Attributes tab to make it active and set the Designator field to V1. Click the OK 
button to close the dialog and then place the source between the dangling ends of the 12V and 
GND wires. 

7. Using the same technique you used to move the dangling ends of the 12V and GND wires apart, 
move them again to attach each wire end to either end of the voltage source, as shown in Figure 9 
(simulation-ready schematic). 

 

Figure 9. Simulation-ready schematic 
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The electrical “hot spot” 
of a net label is the 
bottom left corner, so 
ensure that this corner 
touches the wire. 

Our last task before running a simulation is to place net labels at appropriate points on the circuit so 
we can easily identify the signals we wish to view. In the tutorial circuit, the points of interest are the 
base and collectors of the two transistors.  

1. Select Place » Net Label from the menus [shortcut P, N]. Press the TAB key to edit the net label 
attributes. In the Net Label dialog, set the Net field to Q1B and close the dialog. 

2. Position the cursor over the wire coming from the base of Q1. See Figure 9 for net label 
placement. Left-click or press ENTER to place the net label on the wire. 

3. Press the TAB key and change the Net field to Q1C. 

4. Position the cursor over the wire coming from the collector of Q1 and left-click to place the 
second net label. 

5. Similarly, place net labels with designators Q2B and Q2C on the base and collector wires of Q2 
respectively. 

6. When you have finished placing net labels, right-click, or press ESC, to exit placement mode. 

7. To save your simulation-ready circuit with a different name to that of your original schematic, 
select File » Save As [shortcut F, A] and type Multivibrator simulation.SchDoc in the Save 
As dialog. 

Running a transient analysis 
Your schematic now has all the necessary additions, so let’s set up a transient analysis of the circuit. In 
our tutorial circuit, the RC time constant is 100k x 20n = 2 milliseconds. To view five cycles of the 
oscillation, we will set up to view a 10ms portion of the waveform. 

1. Select Design » Simulate » Mix Sim from the menus to display the Analyses Setup dialog. All the 
simulation options are set up here. 

 

2. First we will set up the nodes in the circuit that you wish to observe. In the Collect Data For field, 
select Node Voltage and Supply Current from the list. This option defines what type of data you 
want calculated during the simulation run. 

3. In the Available Signals field, double-click on the Q1B, Q2B, Q1C and Q2C signal names. As you 
double-click on each one, it will move to the Active Signals field. 

4. Make sure the Operating Point Analysis and the Transient/Fourier checkboxes are enabled 
(ticked) for this analysis. If the Transient/Fourier Analysis Setup does not display automatically, 
click on the Transient/Fourier analysis name. 

5. Check that the Use Transient Defaults option is disabled, so that the Transient Analysis 
parameters are available. 
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6. To specify a 10ms simulation window, set the Transient Stop Time field to 10m. 

7. Now set the Transient Step Time field to 10u, indicating that the simulation should display a point 
every 10us (giving 1000 display points in all, enough to give an accurate picture of the results). 

8. During simulation, the actual timestep is varied automatically to achieve convergence. The 
Maximum Step field limits the variation of the timestep size, set the Transient Max Step Time to 
10u. 

You are now ready to run a transient simulation. 

1. Click the OK button at the bottom of the Analyses Setup dialog to run the simulation. 

2. The simulation will be performed, when it is finished you should see output waveforms similar to 
those shown in Figure 10. 

 

Figure 10. Output waveforms from the multivibrator. 

Congratulations! You have simulated your circuit and displayed its output waveforms.  
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If you like, you can change the values of some of the components on your schematic and re-run the 
simulation to see the effects. Try changing the value of C1 to 47n (double-click on C1 to edit its 
attributes) and re-running the transient analysis. The output waveforms will show an uneven 
mark/space ratio. 

Further explorations 
This tutorial has introduced you to just some of the powerful features of Protel DXP. We’ve captured a 
schematic, run a transient simulation on the design, and designed and routed a PCB, all with the 
integrated tools provided in Protel DXP. But we’ve only just scratched the surface of the design power 
provided by Protel DXP. 

Once you start exploring Protel DXP you will find a wealth of features to make your design life easier. 
To demonstrate the capabilities of the software, a number of example files are included. You can open 
these examples in the normal way, select File » Open from the Design Explorer menus then navigate 
to the \Program Files\Altium\Examples\ folder. As well as the board design examples in this 
folder, there are a number of sub-folders with examples that demonstrate specific features of Protel 
DXP. 

Check out the \Circuit Simulation\ sub-folder to explore Protel DXP’s analog and digital 
simulation capabilities. As well as analog examples that demonstrate various circuit designs, such as 
amplifiers and power supplies, there are mixed-mode examples, a math function example, an example 
that includes linear and non-linear dependent sources  and even a vacuum tube example! 

With faster logic switching and design clock speeds, the quality of the digital signals becomes more 
important. Protel DXP includes a sophisticated signal integrity analysis tool that can accurately model 
and analyze your board layout. The signal integrity requirements such as impedance, overshoot, 
undershoot, and slope are defined as PCB design rules, and then tested during the standard design 
rule check. 

If there are nets that you need to analyze in more detail, you can select Tools » Signal Integrity » Setup 
and Run to pass the design to the Signal Integrity Analyzer, where you can perform reflection and 
cross talk simulations. The results are displayed in an oscilloscope-like waveform analyzer, where you 
can examine the performance and take measurements directly from the waveforms. 

Add-ons 
Protel’s Design Explorer is built on an open client/server architecture, so you can extend the 
functionality of Protel DXP with add-ons available from both Protel and third-party vendors. Add-ons 
integrate seamlessly into the Design Explorer environment, providing additional functions and 
services – extending the capabilities of your Protel DXP design tools. The Protel web site at 
www.protel.com provides an up-to-date list of the latest Add-ons, many of which are directly 
downloadable. 

Thanks for participating in the Protel DXP introductory tutorial. 

http://www.protel.com/
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Shortcut keys 

Design Explorer Shortcuts 
Left-Click Select document under cursor 

Double Left-Click Edit document under cursor 

Right-Click  Display context sensitive pop-up menu  

Ctrl + F4 Close active document 

Ctrl + Tab Cycle through open documents 

Drag & Drop from 

• one project to another   Move selected document   

• File Explorer to Design Explorer  Open selected document as a free document   

Alt + F4 Close Design Explorer DXP 

Common Schematic and PCB Shortcuts 
Shift While autopanning to pan at higher speed 

Y While placing an object to flip it along the Y-axis 

X While placing an object to flip it along the X-axis 

Shift+ ↑ ↓ ← → Move cursor ten grid increments in direction of arrow key   

↑ ↓ ← → Move cursor one grid increment in direction of arrow key 

Space Abort screen re-draw  

Esc Escape from current process 

End Redraw the screen 

Home Redraw screen with center at the cursor point   

PageDown or Ctrl + mouse wheel Zoom out 

PageUp or Ctrl + mouse wheel Zoom in (zooms around cursor, position the cursor first) 

Mouse wheel Pan Up/Down 

Shift + mouse wheel Pan Left/Right 

Ctrl + Z Undo 

Ctrl + Y  Redo 

Ctrl + A  Select All 

Ctrl + S  Save current document 

Ctrl + C  Copy 

Ctrl + X Cut 

Ctrl + V  Paste 

Ctrl + R Copy and repeat paste selected objects 

Delete Delete Selection 

V + D View Document 

V + F View Fit placed objects 

X + A De-select all 

Right-Click & Hold Display slider hand & slide view 

Left-Click Focus or select object  

Right-Click Pop-up floating menu, or escape from current operation  

Right-Click on object, select Find Similar  

 Load object under cursor into Find Similar dialog 

 

Left-Click, Hold & Drag Select inside area  

Left-Click & Hold Move object/selection under cursor  
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Left Double-Click Edit object 

Shift + Left-Click Select/deselect object 

TAB Edit attributes while placing 

Shift + C Clear current Filter 

Shift + F Click on object to display Find Similar dialog 

Y Popup Quick Queries menu 

F11 Toggle Inspector panel on/off 

F12 Toggle List panel on/off 

Schematic Shortcuts 
Alt Constrain object movement in line horizontally and vertically 

G Cycle through snap grid setting 

Spacebar Rotate object being moved by 90 degrees 

Spacebar Toggle start/end mode while placing a wire/bus/line 

Shift + Spacebar Step through placement modes while placing a wire/bus/line 

Backspace Remove the last vertex when placing a wire/bus/line/polygon 

Left-Click, Hold +Delete When a wire is focused to delete a vertex 

Left-Click, Hold +Insert When a wire is focused to add a vertex 

Ctrl + Left-Click & Drag Drag object 

PCB Shortcuts 
Shift + R  Cycle through three routing modes (ignore, avoid or push 

obstacle) 

Shift + E Toggle electrical grid on/off 

Ctrl + G Pop up snap grid dialog 

G Pop up snap grid menu 

N Hide the ratsnest while moving a component 

L Flip component being moved to the other side of board 

Backspace Remove last track corner during track placement  

Shift + Space Step through corner modes during track placement 

Space Toggle start/end mode during track placement 

Shift + S Toggle single layer mode on/off 

O + D + D + Enter Set all primitives to display in draft mode 

O + D + F + Enter  Set all primitives to display in final mode 

O + D Show/Hide Tab of Preferences dialog 

L View Board Layers dialog  

Ctrl + H Select connected copper 

Ctrl + Shift + Left-Click Break track 

+ Next layer (numeric keypad) 

- Previous layer (numeric keypad) 

* Next routing layer (numeric keypad) 

M + V Move split plane vertices 

Alt Hold to temporarily switch from avoid-obstacle to ignore-
obstacle mode 

Ctrl Hold to temporarily disable electrical grid while routing 

Ctrl + M  Measure distance 

Shift + Space Rotate object being moved (clockwise) 

Space Rotate object being moved (anti-clockwise) 

Q Toggle units (metric/imperial). 
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