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Notice to Users: Read Before Using

Disclaimer
The Saber® simulator and all other software products offered to the customer (Customer) by
Analogy, Inc. (Analogy Products) are software programs designed and engineered by
Analogy® or its licensors. Analogy Products incorporate the latest ideas and theories in
advanced technologies to assist an experienced, highly qualified engineer in the design of
Customer’s product. Analogy Products have been designed to provide limited analysis and
are not intended to replace testing or other analysis of Customer’s product. The advanced
level engineer must use Analogy Products only as “tools” to help understand the potential
performance of Customer’s product while continuing to rely upon his or her own expertise.

Analogy Products are based on mathematical abstractions of real world
environments or devices. Because Analogy Products work with abstractions, the
use of Analogy Products can only provide an estimation of possible future
performance of Customer’s product. Customer acknowledges these limitations and
agrees that it will not rely solely upon the results derived from any usage of
Analogy Products in determining the final design, composition, structure, safety,
reliability, or performance of any Customer product. Analogy will not be legally
liable for any use of Analogy Products by Customer, including Customer misuse,
errors in judgment or application of Analogy Products in the development or use
of Customer’s products.

Analogy does not represent that it has sufficient professional expertise in the application of
Customer’s product to determine the difference between the performance predicted by
Analogy Products and the performance of any real product or device. Therefore, Analogy
expects Customer will test Customer’s product prior to any actual use. Where the failure of
Customer’s product may result in bodily harm, Customer must take additional measures, in
accordance with the applicable standard of care, to ascertain that Customer’s product
conforms to Customer’s specifications and standard engineering design practices. Regardless
of end use application, any Customer product developed with the assistance of Analogy
Products must be tested independently to confirm the results obtained from Analogy
Products. Where a higher standard of care is required, Analogy recommends that the results
of simulation obtained from Analogy Products be confirmed by outside independent
professionals, including additional product testing and quality control.





Preface
SaberDesigner Tutorial

This tutorial provides an introduction to design creation and simulation with
SaberDesigner, and covers only a few of its many features. To gain more
familiarity with the application, you can repeat the tutorial and vary the
simulation approach from that presented.

The SaberDesigner tutorial is divided into the following topics:

• Creating a Design Using SaberDesigner

• "Placing the Parts" on page 1-3

• "Editing the Symbol Properties" on page 1-8

• "Wiring the Schematic" on page 1-12

• "Modifying Wire Attributes" on page 1-14

• Analyzing the Design Using SaberDesigner

• "Performing a Transient and DC Analysis" on page 2-2

• "Placing Probes in the Design" on page 2-5

• "Performing AC Analysis and Invoking SaberScope" on page 2-6

• "Analyzing Waveforms with SaberScope" on page 2-7

• "Performing Measurements on a Waveform" on page 2-8

• "Varying a Parameter" on page 2-10

• "Displaying the Parameter Sweep Results" on page 2-12

• "Measuring a Multi-Member Waveform" on page 2-14
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Preface
Viewing Manuals With SaberBook

SaberBook is Analogy’s online documentation viewing tool based on the
HyperHelp product from Bristol Technology Inc.

SaberBook can be started from either a UNIX shell command line
(saberbook ) or from an Analogy application such as SaberSketch using the
Help  menu item in the main session window.

On UNIX systems, before using SaberBook, you need to change the
HyperHelp environment to the default Analogy settings by placing the
following command in each user’s start-up file, such as .profile  or .cshrc :

xrdb -merge saber_home/app-defaults/app-defaults

If a user has modified HyperHelp background and foreground colors in their
~/.Xdefaults file, the previous command will overwrite those definitions. To
restore a user’s custom changes, they need to add another line to their
start-up file right after the previous xrdb  command as follows:

xrdb -merge ~/.Xdefaults

Conventions

This manual uses the following conventions:

keywords Keywords are reserved words such as the MAST
language word template that are shown in the font style
at left.

~/tutorial/
circuit

File and directory paths appear in the Courier  font.

placeholder An item shown in italic in a command line indicates that
you must supply the specific text to be used in its place.

bold Menu items, Dialog box names, and button names are
shown in bold .

emphasis Emphasized text such as a manual titles and new terms
appears in italic.

[ ] Italicized square brackets enclosing text indicate
optional entries.

Single Click Press and release a mouse button once quickly.
ii Getting Started with SaberDesigner (July 2001)
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Revision History
The following convention is used in this manual to indicate a menu selection
from a sub-menu as shown in the following example:

Analyses > Operating Point > DC Transfer

In this example, the DC Transfer menu item is selected by first selecting the
item Analyses  from a top-level menu, then selecting Operating Point  from a
sub-menu, and finally selecting DC Transfer  from a second sub-menu.

Revision History

Press and Hold Press a mouse button and do not release it.

Double Click Press and release a mouse button twice quickly.

November 1999 Update text to reflect changes to the user
interface.

March 1999 Update text to reflect changes to the user
interface.

March 1998 Update text to reflect changes to the user
interface.

October 1996 Total rewrite to include SaberSketch and
move Frameway Integration tutorials to
the Getting Started Using Frameway
Integrations manual.

December 1995 First publication, accompanying Release 4.0
of SaberDesigner.
Getting Started with SaberDesigner (July 2001) iii
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chapter 1
Creating a Design Using SaberDesigner
The first part of this tutorial shows how to use SaberDesigner to create a
single-stage transistor amplifier that includes load resistance and
capacitance. You are shown the following tasks:

• How to use the Parts Gallery to find and place symbols

• How to use the Property Editor to modify property values

• How to wire the design

Before running this tutorial, make sure that SaberDesigner is properly
installed and ready to run on your system (see your system administrator).

NOTE
For NT Mouse users: The left and right buttons on a
two-button mouse should map to the left and right
mouse functions respectively as described in this
tutorial. If this tutorial specifies a middle mouse
function, an alternate way is also described to complete
the task.

Creating the Tutorial Directories

You need to create two directories to organize the data for the single-stage
amplifier circuit you are creating.

1. Create (if necessary) a directory/folder called avanti_tutorial ,
where you will create the tutorial example.

2. Navigate to the avanti_tutorial  directory.

3. Create a directory called amp.

4. Navigate to the amp directory.
Getting Started with SaberDesigner (July 2001) 1-1
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Chapter 1: Creating a Design Using SaberDesigner
Creating the Design Using SaberSketch

In this part you create the design for a single-stage transistor amplifier using
SaberSketch.

1. Invoke SaberSketch using one of the methods as follows:

(UNIX) On a command line, enter install_home/bin/sketch

(Windows NT) Start > Avant! > saberdesigner > SaberSketch

An empty schematic window appears.

2. Provide a name for the design as follows:

a. Save the currently empty design by selecting the File > Save As...
menu item. A Save Schematic As dialog box appears.

b. In the File Name field, do one of the following:

(UNIX) Enter the name single_amp .

(Windows NT) Enter the complete path or browse to
your_path\avanti_tutorial\amp\single_amp .

c. Click Save.

3. Examine the SaberSketch work surface.

a. Place the mouse cursor over any icon and hold it there. A text
window is displayed to identify the icon. Also look in the Help field at
the bottom of the work surface for information about the icon.

b. Notice that a Schematic window named single_amp appears in the
work surface.
1-2 Getting Started with SaberDesigner (July 2001)
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Placing the Parts
Placing the Parts

In this part of the tutorial you place symbols on the schematic block as shown
in the following figure. Parts designators such as r1  and r2  have been added
to the figure for reference.

For more information on the design parameters that were used with this
amplifier, refer to Appendix A.

1. Find and place the npn transistor symbol as follows:

a. Click the Parts Gallery icon.
The Parts Gallery dialog box appears.

b. Set the following Parts Gallery fields:

Category Name /

Search String npn

Available Categories Leave unselected for the remainder
of this tutorial

Single-Stage Transistor Amplifier Parts Placement

*opt*

*opt* *opt* *opt*

*opt*

*opt*

*opt*

q_3p

*req*

v

r1

r2

rc

cin

q1

re rload cload
initial:*req*
pulse:*req*
tr:*req*
tf:*req*

v

vccvccvcc
Getting Started with SaberDesigner (July 2001) 1-3
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Chapter 1: Creating a Design Using SaberDesigner
c. Choose the Options > Preferences  menu item. The Parts Gallery
Preferences form appears.

d. Click the Search tab and select the settings as follows:

e. Click OK. If it disappears, double click the Parts Gallery icon to
bring the Parts Gallery to the front.

f. In the Parts Gallery, click the Search  button.

A list of all part descriptions that contain "npn" appear in the
Available Parts list.

g. In the Available Parts list, select BJT, 3 pin NPN .

h. Place the npn symbol by clicking the Place  button.

2. Find and place five resistor symbols as follows:

a. In the Parts Gallery, set the fields as follows:

b. Choose the Options > Preferences  menu item. The Parts Gallery
Preferences form appears.

c. Click the Search tab and select the settings as follows:

d. Click OK.

e. In the Parts Gallery, click the Search  button.

f. In the Available Parts list, select Resistor (|) .

g. Place five resistors by clicking the Place  button five times.

Search part by: Part Name

Search match: Containing

Ignore case when doing
search

selected in the remainder of this
tutorial

Category Name /

Search String res

Search part by: Part Name

Search match: Beginning with
1-4 Getting Started with SaberDesigner (July 2001)
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Placing the Parts
h. Turn on the grid in the Schematic window by clicking , the Toggle
Grid icon in the SaberSketch Icon Bar.

i. Position the five resistors in relation to the transistor as shown in
the previous Parts Placement figure on page 1-3 as follows:

• One-by-one, position the mouse cursor on each resistor

• Press and hold the left mouse button

• Drag the part to the desired location and release the mouse
button

j. In the SaberSketch Icon Bar, click the Zoom to Fit  icon. Use the
Zoom icons to help manage the size of displayed contents.

3. Find and place the v_pulse symbol using the following Parts Gallery
settings and the previous Parts Placement figure on page 1-3:

a. Choose the Options > Preferences  menu item. The Parts Gallery
Preferences form appears.

b. Click the Search tab and select the settings as follows:

c. Click OK.

d. In the Parts Gallery, click the Search  button.

e. In the Available Parts list, select Voltage Source, Pulse .

f. Place the v_pulse symbol by clicking the Place  button and then
move it into position.

4. Find and place the v_dc symbol using the following Parts Gallery
settings:

Category Name /

Search String v_pulse

Search part by: Symbol Name

Search match: Beginning with

Category Name /

Search String v_dc
Getting Started with SaberDesigner (July 2001) 1-5
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Chapter 1: Creating a Design Using SaberDesigner
a. The Parts Gallery Preferences form settings you used in the previous
search will work for this search. Click the Search  button.

b. In the Available Parts list, select Voltage Source, Constant
Ideal DC Supply .

c. Place the v_dc symbol by clicking the Place button and then move it
into position.

5. Find and place the horizontal capacitor symbol as follows:

a. Choose the Options > Preferences  menu item.

b. Click the Search tab and select the settings as follows:

c. Click OK.

d. Click the Search  button.

e. In the Available Parts list, select Capacitor (-) .

f. Place the ch symbol by clicking the Place  button.

g. Position the symbol as shown in the previous Parts Placement figure
on page 1-3. Rotate the symbol 180 degrees as follows:

• Move the mouse cursor over the symbol to select it.

• Press-and-hold the right mouse button to bring up the popup
Symbol Menu. Choose the Rotate > 180 menu item and release the
mouse button.

• Reposition the symbol as necessary.

6. Find and place the vertical capacitor symbol as follows:

a. In the Parts Gallery, use the same settings as you did for step 5,
except in the Available Parts list, select Capacitor (|) .

b. Place and position the symbol as shown in the previous Parts
Placement figure on page 1-3.

Category Name /

Search String cap

Search part by: Part Name

Search match: Beginning with
1-6 Getting Started with SaberDesigner (July 2001)
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Placing the Parts
7. Find and place six ground symbols using the following Parts Gallery
settings:

a. The Parts Gallery Preferences form settings you used in the previous
search will work for this search. Click the Search  button.

b. In the Available Parts list, select Ground, (Saber Node 0) .

c. Place the gnd symbols by clicking the Place  button six times.

d. Position the symbols as shown in the Parts Placement figure on page
1-3.

8. Find and place three vcc symbols using the following Parts Gallery
settings:

a. Using the same search settings that you used in the previous steps,
click the Search  button.

b. In the Available Parts list, select vcc .

c. Place the vcc symbols by clicking the Place  button three times.
Position the symbols as shown in the Parts Placement figure on page
1-3.

9. Close the Parts Gallery.

Category Name /

Search String ground

Category Name /

Search String vcc
Getting Started with SaberDesigner (July 2001) 1-7
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Chapter 1: Creating a Design Using SaberDesigner
Editing the Symbol Properties

Once all the parts are placed on the schematic, you can put property values
that are specific to this design on each symbol. The following figure shows
many of the property values that you will add in this part of the tutorial.

1. For those symbols that have property value place-holders (*opt* )
already displayed such as the resistor and capacitor symbols, you can
change the value on each by doing the following:

a. Position the mouse cursor at the end of the desired text field.

b. Click the left mouse button.

c. Backspace (use the backspace key) over the existing text to delete it.

d. Type in the new text.

e. For example, position the mouse cursor at the end of the text field
for rload  as shown in the previous Property Values figure on page
1-8 and replace the *opt*  field with 10k .

f. Repeat steps a through d for each of the following components:

r1 61k

r2 17.6k

q_3p

12

v

v

vccvccvcc

Single-Stage Transistor Amplifier Symbol Property Values

61k 1.1k

r1 rc

33n
cin

vcc

q1

sig_source
initial:1.2
pulse:2.3
tr:10n
tf:10n
width:0.5u
period:1u

17.6k
r2

300
re

10k
rload

0.1n
cload
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Editing the Symbol Properties
When you need to change properties values that are not visible, you
must use the Property Editor as described in the next step.

2. To change properties on the v_dc symbol, do the following:

a. Position the mouse cursor over the v_dc symbol to select it. It
changes color to show it is selected. Also note in the Help field at the
bottom that the symbol name (v_dc), along with an instance
number (such as _7), is displayed.

b. Press the right mouse button and hold it. The popup Symbol Menu
appears.

c. In the Symbol menu, move the mouse cursor over the Properties...
item and release the mouse button. The Properties dialog box is
displayed.

d. In the Properties dialog box for the selected v_dc symbol, change the
ref  property to vcc .

e. Change the dc_value  property to 12 , which defaults to volts.

f. In the Properties dialog box, click the Apply  button.

g. Notice that the Visibility Indicators (the circles to the right of the
Value column) are set so that the Value is displayed for a number of
properties. Experiment with these indicators by clicking on one of
them and then clicking the Apply  button to see what is displayed in
the Schematic window. Repeat the process, clicking the indicator,
followed by the Apply  button to see what happens with each of the
different settings.

h. Close the Properties dialog box (click OK)

3. The procedure for using the Properties dialog box is slightly different for
one of the properties on the q_3p.q1  transistor as follows:

a. Position the mouse cursor over the q_3p symbol to select it.

b. Press the right mouse button and hold it. The popup Symbol Menu
appears.

c. In the Symbol menu, move the mouse cursor over the Properties...
item and release the mouse button. The Properties dialog box is
displayed.

re 300

rc 1.1k

cin 33n

cload 0.1n
Getting Started with SaberDesigner (July 2001) 1-9
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Chapter 1: Creating a Design Using SaberDesigner
d. In the Properties dialog box for the selected q_3p symbol, change the
ref  property to q1 .

e. Move the mouse cursor to the (type=_n)  value for the
saber_model property. The cursor changes to a slanted arrow. This
indicates that the property value is a either a structure or an array.

f. Click on the (type=_n)  value. A STRUC model list box appears.

g. In the STRUC model list box, scroll down to the bf list item. Change
the bf  entry to 200 .

h. In the STRUC model list box, click OK.

i. In the Properties dialog box, click the OK button to apply the change
and close the Properties dialog box.

4. To change the properties on the rest of the symbols, repeat the following
steps for each symbol listed in the corresponding table:

a. Select one symbol at a time by moving the cursor over the symbol
and then pressing the right mouse button and holding it. The popup
Symbol Menu appears.

b. In the Symbol menu, move the mouse cursor over the Properties...
item and release the mouse button. The Properties dialog box is
displayed.

c. Fill out the fields in the Properties dialog box as shown in the
following table. The Symbol references shown in the table
corresponds to the references shown in the previous Property Values
figure on page 1-8. Prior to changing the references, they have ref
values such as v1 , res1 , c1  and so on.

If a property appears in the Properties dialog box but is not listed in
the table, do not change the default value.

d. When you are finished entering the property values for each symbol,
click the Apply  button.

You can get more information about any of the properties on a selected
symbol by choosing the Help > Help on Part menu item in the Properties
dialog box. In the Properties dialog box, use the scroll bar if necessary to
1-10 Getting Started with SaberDesigner (July 2001)
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Editing the Symbol Properties
see additional properties that do not fit in the displayed list.

5. Close the Properties dialog box.

Symbol.Reference Property Name Value

v_pulse.sig_source ref sig_source

initial 1.2

pulse 2.3

tr 10n

tf 10n

width 0.5u

period 1u

ac_mag 1

r.r1 (61k) ref r1

r.r2 (17.6k) ref r2

r.rc (1.1k) ref rc

r.re (300) ref re

r.rload (10k) ref rload

c.cin (33n) ref cin

c.cload (0.1n) ref cload
Getting Started with SaberDesigner (July 2001) 1-11
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Chapter 1: Creating a Design Using SaberDesigner
Wiring the Schematic

After the symbols are placed and the properties are set, you can wire the parts
together as shown in the following figure.

In the following procedure, do not wire the intersection of cin , q1 , r1  and r2
until specifically instructed to do so.

1. The simplest way to create a wire between two ports is as follows:

a. Position the mouse cursor over the first port (start with the top of
the v_dc symbol).

b. Click the left mouse button.

c. Position the mouse cursor over the second port (the vcc symbol
above the v_dc symbol).

d. Click the left mouse button again.

e. Repeat steps a through d to connect each ground and vcc symbol to
the associated part as shown in the previous figure.

2. Position the cursor on the bottom of rc and click the left mouse button.
Move the cursor to the top of cload  and click the mouse button again.
Notice that a right-angle was formed above the cload  symbol. By

q_3p

12

v

v

vccvccvcc

61k 1.1k

r1 rc

33n
cin

vcc

q1

sig_source

17.6k
r2

300
re

10k
rload

0.1n
cload

Single-Stage Transistor Amplifier Wire Connections
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Wiring the Schematic
repositioning the top segment of this wire, you can connect it to the
collector of q1  as follows:

a. Move the mouse cursor to the wire segment that connects to rc .

b. Press-and-hold the left mouse button.

c. Drag the wire segment down until it contacts the collector of q1 .

d. Release the mouse button.

3. Connect re  to the q1  emitter.

4. Connect rload  straight up to the wire formed from the cload -rc
connection.

5. Connect sig_source  to cin .

6. Connect the base of q1  to cin . Refer to the previous Wire Connections
figure on page 1-12 as needed.

7. To connect r1  and r2  to the q1-cin  intersection, you must draw two
wires; one from r1  to the intersection, and one from r2  to the
intersection. If you draw a wire from r2  to r1 , there will be no
connection point at the cin -q1  intersection.
Getting Started with SaberDesigner (July 2001) 1-13
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Chapter 1: Creating a Design Using SaberDesigner
Modifying Wire Attributes

If you do not label wires, SaberSketch automatically provides names for each
wire, such as _n30 . It can be helpful later on during design analysis if you
label the wires with a meaningful designator that is easy to read and
understand.

Wires connected to vcc or ground are labeled by SaberSketch with vcc  and
gnd  respectively. There is no need to change those designators.

To add the four wire attributes that are shown in the previous figure, do the
following:

1. For the first wire attribute, move the mouse cursor to the desired wire
to select it. It changes color.

2. Press and hold the right mouse button to display the popup Wire Menu.

3. In the popup Wire Menu, select the Attributes...  item and release the
mouse button. The Wire Attributes dialog box is displayed.

4. Change the value in the Name field to the desired text string. Refer to
the previous Wire Attributes figure.

5. In the Wire Attributes dialog box, click Yes in the Display Name field.

Single-Stage Transistor Amplifier Wire Attributes

inp

aout

Add these
wire attributes

in

q_3p

12

v

v

vccvccvcc

61k 1.1k

r1 rc

33n
cin

vcc

q1

sig_source

17.6k
r2

300
re

10k
rload

0.1n
cload

emitter
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Modifying Wire Attributes
6. Click the Apply  button followed by the Close  button.

7. Select the next wire by moving the mouse cursor to the desired wire and
clicking the left mouse button. The existing wire name appears in the
Wire Attributes dialog box Name field.

8. Repeat steps 4 through 7 until you have finished changing the wire
attributes.

9. Close the Wire Attributes dialog box.

10.Save the design by clicking the Save icon.

At this point you have a completed design that is ready to be analyzed. In the
next part of the tutorial, you use SaberGuide to simulate the amplifier.
Getting Started with SaberDesigner (July 2001) 1-15
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chapter 2
Analyzing the Design Using SaberDesigner
Once you have a design created with SaberSketch that is ready to simulate,
you can access the SaberGuide Simulation Environment and analyze the
design.

In this part of the tutorial you use SaberGuide to analyze the single-stage
amplifier design that you created in the previous part with SaberSketch.
These procedures show the following:

• How to perform a transient analysis that automatically performs the
necessary DC analysis

• How to perform a small-signal frequency analysis

• How to vary the output load and analyze the results

• How to place probes and view simulation results on the schematic

Starting SaberGuide from SaberSketch

In the following procedure you start SaberGuide from SaberSketch, which
already has the single-stage amplifier design open:

1. If the SaberGuide Icon bar is not visible, click the
Show/Hide SaberGuide icon in SaberSketch.

2. If the SaberGuide Transcript window is not open, click
the Simulation Transcript icon.

The SaberGuide Transcript window contains the result of any command
execution.
Getting Started with SaberDesigner (July 2001) 2-1
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Chapter 2: Analyzing the Design Using SaberDesigner
Performing a Transient and DC Analysis

In this part you perform a transient analysis. In the next part of this tutorial
you display the results with SaberScope to check the output signal shape.

Before the transient analysis is executed, it is important to find the DC
operating point of the circuit. The DC operating point is used as the first data
point in the transient (time-domain) analysis. The DC analysis is initiated
from the Time-Domain Transient (tr) Analysis dialog box.

Before any of the analysis can occur, a netlist must be created for the design.
This is done automatically when you initiate the transient analysis.

1. Click the Transient Analysis icon  to bring up the Time-Domain
Transient Analysis dialog box. The Basic form is displayed.

2. Fill out the Basic form as follows:

For general information on DC analysis, refer to Appendix B, DC
Operating Point Analysis.

3. You use these transient analysis setup values later in the tutorial, so
save them now as follows:

End Time 10u This value informs Saber to simulate
the circuit for 10us.

Time Step .1u This value gives Saber a time
increment to begin solving the
circuit.

Run DC Analysis First Yes The DC Operating point must be
determined before the transient
analysis can be calculated.
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Performing a Transient and DC Analysis
a. In the Time-Domain Transient Analysis dialog box, click Defaults . The
set up for tranalysis dialog box appears as follows:

b. In the set up for tranalysis dialog box, enter a unique name amp_tr
in the Tag Name field.

c. With the Current tag selected, click Set Tag.

The amp_tr  tag name is added to the Tags list and the values you
entered in the set up for tranalysis dialog box appear in the Form
Values list.

d. Still in the set up for tranalysis dialog box, click Apply .

e. In the Time-Domain Transient Analysis dialog box, click the
Input/Output tab.

f. In the Signal List field set to plot all by clicking Select > All Signals
(/... ).

g. Change the Include Signal Types field to the All Variables  setting (to
include both across and through variables). This will allow you to
plot current (pin flow) and voltage data later on.

h. In the Time-Domain Transient (tr) Analysis dialog box, click OK.

i. A Yes or No dialog box may be displayed that informs you that the
single_amp design will be saved before netlisting and asks if you
want to continue. Click Yes. The netlister starts.

The values you entered in the Time-Domain Transient Analysis dialog
box are not saved if you leave the application. To do a save-on-exit,

A tag called Current is
selected to display the
current Time-Domain

Transient (tr) Analysis
dialog box values here.

Supply a unique tag
name, such as,
amp_tr here.
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Chapter 2: Analyzing the Design Using SaberDesigner
choose the following SaberSketch window menu item:
File > Configuration > Save on Exit .

4. Look in the SaberGuide Transcript window. (You should have opened this
window from the topic "Starting SaberGuide from SaberSketch" on
page 2-1, Step 2.)

The transcript window displays the license information, followed by the
specific commands that were executed after the netlister finished. You
can scroll the window to see the text. This window first displays
information such as the version of Saber being used, the specific
licenses, and templates used by this design.

The DC analysis (dc) execution time is displayed. In this step you did
not fill out the Operating Point Analysis form, so default settings were
used to determine the DC values for each node in the design. In most
cases, the Saber simulator finds the operating point using the default
settings in the Operating Point Analysis form. A file with a .dc extension
is created to hold the results of the analysis. If you want to display the
DC analysis results, do the following:

a. In the SaberSketch window, choose the Results > Operating Point
Report...  menu item to display the Operating Point Report dialog box.

b. In the Operating Point Report dialog box, click OK. This informs
Saber to use the default settings to display the most recent DC
operating point values in the Report Tool window.

c. Refer to the DC results in the Report Tool window and the schematic
to help analyze the results. If necessary, you can resize the window
or use the scroll bar to view all of the results. The results are also
displayed in the SaberGuide Transcript window.

d. Close the Report Tool window.

Before you did steps a through c, the transient analysis (tr) execution
time was displayed in the SaberGuide Transcript window; this indicates
the completion of the transient simulation. A file with a “.tr.ai_pl”
extension was created to hold the results of the transient analysis.
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Placing Probes in the Design
Placing Probes in the Design

One way to view simulation results is to place a probe on a wire or node in a
design as described in the following steps:

1. In the Schematic window, move the mouse cursor to the aout  wire to
select it. The wire changes color.

2. Press and hold the right mouse button to display the popup Wire Menu.

3. In the popup Wire Menu, select the Probe  item and release the mouse
button. A Probe window is displayed and attached to the aout  wire
with a voltage waveform displayed.

At this point it might be helpful to click the Zoom to Fit icon.

You can resize a Probe window by moving the mouse cursor to one of the
corners and (grabbing) clicking-and-holding the left mouse button while
repositioning the corner. You can also move the window around in the
design similarly by grabbing any side of the window.

4. If the transient results are not already displayed in the Probe window,
you can load a plot file as follows:

a. Move the mouse cursor inside of the aout Probe window.

b. Press and hold the right mouse button to display the popup Probe
Menu.

c. In the popup Probe Menu, select the Open Plotfile...  item. An Open
Plotfile dialog box is displayed.

d. In the list box, select single_amp.tr.ai_pl .

e. Click the Open  button. Click Yes in the resulting dialog box. The
output waveform is displayed in the Probe window.

5. Place a probe on the input (in ) signal as you did in the previous steps.

6. From the results you can see that the shape of the output is being
rounded by the circuit capacitance.

7. Delete the Probe windows on the input (in ) signal as follows:

a. Move the cursor inside the Probe window and click-and-hold the
right mouse button to display the popup Probe Menu.

b. Select the Delete  menu item.

8. Plot the current flowing through the cload  capacitor as follows:
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Chapter 2: Analyzing the Design Using SaberDesigner
a. Move the cursor to the Probe arrow currently on the aout  signal (it
turns color).

b. Click-and-hold the left mouse button and drag the arrow to the
middle of the cload  capacitor symbol. Release the mouse button. A
Select Port & Signal window appears.

c. In the Select Port & Signal window, select the p pin.

d. Then change the Signal Type to Through  and click OK. A current
flow waveform is displayed in the Probe window.

e. Delete the remaining Probe window from the schematic. (See Step
7).

Performing AC Analysis and Invoking SaberScope

In this part of the tutorial you perform a small-signal frequency analysis to
check the frequency response and gain of the amplifier. In addition, you invoke
SaberScope.

1. Bring up the Small-Signal Frequency Analysis dialog box by clicking
the Frequency Response icon. The Basic form is displayed.

2. Fill out the form as follows:

3. Without changing the other fields, click OK. The AC analysis execution
time is recorded in the SaberGuide Transcript window. A file is created
with a .ac.ai_pl  extension to hold the results of the analysis.

The last action recorded in the SaberGuide Transcript window was the
invocation of SaberScope because you set the Plot After Analysis field to
Yes - Open Only . SaberScope is displayed along with the Signal
Manager window and a single_amp.ac Plot File window. From the Plot
File window you can select and plot the signal of interest as described in
the next topic.

Start Frequency 100  (Hertz is the default unit.)

End Frequency 10meg

Plot After Analysis Yes - Open Only
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Analyzing Waveforms with SaberScope
Analyzing Waveforms with SaberScope

After the transient and AC analysis are complete, you can view the results
with the SaberScope Waveform Analyzer.

1. To remove some screen clutter, iconify the SaberSketch window.

2. In the single_amp.ac Plot File window, select signal aout by left-clicking
it. The signal is highlighted.

3. Plot the selected signal on the graph by either clicking the Plot  button
in the Plot File window, or by moving the mouse cursor to the Graph
window and clicking the middle-mouse button. The aout  waveforms
are displayed in the Graph window.

4. In this tutorial you do not need the Phase(deg):f(Hz)  waveform. To
delete it from the Graph window, do the following:

a. Move the mouse cursor to the aout signal name associated with the
Phase(deg):f(Hz)  plot. The aout  signal name and the waveform
changes color.

b. Press and hold the right mouse button to bring up the Signal Menu.

c. Select the Delete Signal  item.

5. Even though you have already seen the results of the transient
analysis, do the following to see how you can plot additional waveforms
to the Graph window:

a. In the Signal Manager dialog box, click the Open Plotfiles...  button.
The Open Plotfiles dialog box appears.

b. In the File Name list, click on single_amp.tr.ai_pl .

c. Click the Open  button. A single_amp.tr Plot File window is displayed.

d. From the single_amp.tr Plot File window, plot the aout  and in
signals as you did in steps 2 and 3. Two new waveforms are added to
the graph window.

e. Note that the (V):t(s)  plots of the in  and aout  waveforms are
identical to those displayed on the design in SaberSketch. Delete the
in  and aout  waveforms when you have finished viewing them.

6. Look at the aout dB(V):f(Hz) (dB in volts versus frequency in Hertz)
waveform in the Graph window.

From the waveform you can see that the gain is about 10dB from about
2000 Hz to 75 kHz. The next part of this tutorial uses the Measurement
Tool on this waveform to get some accurate readings on the gain and
the frequency response.
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Chapter 2: Analyzing the Design Using SaberDesigner
Performing Measurements on a Waveform

The Measurement Tool within SaberScope provides a method of performing
various measurements on a waveform. You check the bandwidth and gain of
the single-stage amplifier output signal (aout ) as follows:

1. Close the Plot File windows and the Signal Manager window.

2. In the Tool Bar located at the bottom of the
SaberScope window, click the Measurement icon.

The Measurement dialog box appears.

3. Select the Bandpass measurement as follows:

a. Move the mouse cursor to the right of the Measurement field and
press and hold the left mouse button on the down arrow  button.

b. Move the mouse cursor down to the Frequency Domain  menu.

c. Select Bandpass .

To summarize, choose the Measurement >
Frequency Domain > Bandpass menu item.

d. Because there is only one signal in the Graph window, aout  should
appear in the Signal field in the Measurement dialog box as shown in
the following figure.

e. If you want to see values displayed on the graph for Topline and
Offset that are used in the bandpass calculation, click the visibility
indicator buttons to the right of the perspective Reference Levels
fields.

Measurement = Bandpass

Signal = aout

Click these buttons to
display levels on graph.
Click them again to hide
the values.
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Performing Measurements on a Waveform
f. Click the Apply  button. The bandwidth is displayed on the graph.

4. Select the Gain Margin measurement by doing the following:

a. Choose the Measurement > Frequency Domain > Gain Margin menu
item.

b. Click the Apply  button. The gain margin is displayed on the graph.

5. You can get more information about each of the measures you
performed or control the amount of information displayed in the Graph
window by using the Measure Results dialog box as follows:

a. In the Graph window, move the mouse cursor to the aout  signal
name.

b. Use the popup menu and choose the Signal Menu > Measure Results...
item. A Measure Results dialog box appears.

c. In the Measure Results dialog box, be sure the Bandpass item in the
left column is selected as shown in the following figure:

d. Notice in the Measure Results dialog box, in the right column, the
different values that are available from executing the bandpass
measurement.

e. Click on the various visibility indicators to choose which values are
displayed in the Graph window.

Select this button

Click these buttons to
display levels on graph.
Click them again to hide
the values.

Visibility
indicators
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Chapter 2: Analyzing the Design Using SaberDesigner
f. When you have finished exploring the Measure Results dialog box,
close it.

Varying a Parameter

In this part of the tutorial you vary the value of the emitter resistor (re ) from
200 to 400 ohms in 20 ohm steps while performing three analyses for each
resistor value: DC operating point analysis, transient analysis, and
small-signal analysis.

1. Iconify the SaberScope window and bring up the SaberSketch window.

2. Click on the Vary icon, . The Looping Commands dialog box appears.

3. In the Looping Commands dialog box, click the vary button. A Parameter
Sweep dialog box appears.

4. Fill out the Parameter Sweep dialog box as follows:

Click Accept .

5. Define which analysis to run on each swept parameter value as follows:

a. In the Looping Commands dialog box, choose the
AddAnalysis > Within Loop(s) > Transient menu item. A new button
(tranalysis ) appears in the Looping Commands dialog box.

b. Click tranalysis . The Time-Domain Transient Analysis dialog box
appears. If you have not closed SaberSketch since you began this
tutorial, you see the values you entered earlier. Steps c through e
show how to restore previously-saved settings.

c. To recall the transient analysis settings you previously stored, click
Defaults... in the Time-Domain Transient Analysis dialog box. The set
up for tranalysis dialog box appears.

Parameter Name r.re Specify the parameter using the
primitive name (r ) followed by the
symbol reference (re )

Variation Type Step By

from
to
by

200
400
20

Causes Saber to vary the resistor
from 200 ohms to 400 ohms in
increments of 20 ohms.

Unit _ You can leave this field as an
underscore (_) or enter ohms.
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Varying a Parameter
d. Select amp_tr in the Tags list. This is the name of the file you saved
previously.

Note that the saved transient analysis settings specified that a DC
operating point would be executed prior to each transient analysis.
A new operating point should be computed for each value of the re
resistor.

e. In the set up for tranalysis dialog box, click Apply .

f. In the Time-Domain Transient Analysis dialog box, click the
Input/Output tab.

g. In the Plot File and Data File fields, add the string “vary_ ” in front of
the existing “tr ” string so that it reads “vary_tr ”. The results of
this transient looping do not overwrite the previous plot files
because you are specifying different file names.

h. If you do not need to view pin flow data for this vary operation, limit
the data to across variables. This will produce a smaller plot file. Set
the Include Signal Types field to Across Variables Only .

i. In the Time-Domain Transient Analysis dialog box, click Accept .

j. In the Looping Commands dialog box, choose the
AddAnalysis > Within Loop(s) > Small Signal AC menu item. A new
button (acanalysis ) appears in the Looping Commands dialog box.

k. Click acanalysis . The Small-Signal Frequency Analysis dialog box
appears. If you have not closed SaberSketch since you began this
tutorial, you see the values you entered earlier.

l. In the Basic tab verify the following settings.

m. Click the Input/Output tab.

n. In the Plot File and Data File fields, add the string “vary_ ” in front of
the existing “ac ” string so that it reads “vary_ac ”. This creates a
new name for the plot and data file and prevents the new results
from overwriting the existing files.

o. In the Small-Signal Frequency Analysis dialog box, click Accept .

6. Execute the parameter sweep by clicking the OK button in the Looping
Commands dialog box.

Start Frequency 100  (Hertz is the default unit.)

End Frequency 10meg

Plot After Analysis No
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Chapter 2: Analyzing the Design Using SaberDesigner
Observe the looping activity in the SaberGuide Transcript window. After
the simulation has completed, you can display the results of the
parameter sweep.

7. Exit the SaberSketch application (File > Exit ). You can choose to save the
design upon exiting.

Displaying the Parameter Sweep Results

In this part you load the plot files produced from the vary simulation and
display them with SaberScope.

1. Bring up the SaberScope window.

2. From the SaberScope icon bar, click the Clear Graph icon to remove
previous waveforms.

3. If it is open, close the single_amp.ac Plot File window.

4. From the Signal Manager, click the Open Plot Files...  button. The Open
Plot Files dialog box is displayed.

5. Make sure that Plot Files  is selected in the Files of Type field.

6. From the Open Plot Files dialog box, click on
single_amp.vary_ac.ai_pl , then shift-click on
single_amp.vary_tr.ai_pl  file.

7. Click Open .

8. From the single_amp.vary_ac Plot File window, plot aout . The graph
shows a multi-member waveform that shows the effect of varying the
r.re  resistor.

9. Delete the Phase(deg):f(Hz)  waveform from the Graph.

10.From the single_amp.vary_ tr Plot File window, plot the aout and in
signals on the same X/Y axis as the previous aout  signal by doing the
following:

a. In the single_amp.vary_ tr Plot File window, select both the aout
and in  signals. (<Control>-click each item.)

b. (3-button mouse system) Move the mouse cursor to the Graph
window and click the middle-mouse button.

(2-button mouse system) Do the following:

a. Click the Plot  button.

b. In the Graph window, select both the new aout  and in  signals.

2-12 Getting Started with SaberDesigner (July 2001)

Copyright © 1995-2001 Avant! Corp.



Displaying the Parameter Sweep Results
c. Move the cursor to the middle of the Graph, and click-and-hold
the right mouse button to display the Graph menu.

d. In the Graph menu, select the following choice: Selected Signals >
Stack Region > Analog 0 .

11.To help manage the displayed data, do the following:

a. Select the dB(V):f(Hz) aout  signal.

b. Choose the (popup) Signal Menu > Members... menu item. A Members
Attributes dialog box is displayed.

c. Click on the Hide All button. The results of the small-signal analysis
are now hidden from the graph.

12.You can now observe the multi-member (V):t(s) aout  signal as
follows:

a. Select the (V):t(s) aout  signal.

b. Choose the (popup) Signal Menu > Members...  menu item. The
Members Attributes dialog box displays the aout  data.

c. Click the Hide All  button. The waveforms disappear.

d. Click the Loop Highlight  button. The graph loops through each
waveform until you click the Loop Highlight  button again to stop the
looping.

e. Experiment with the Member Attributes dialog box until you are
comfortable with the various features.

13.Delete the (V):t(s) aout and in signals from the Graph window. The
Member Attributes dialog box is now controlling the remaining
dB(V):f(Hz) aout  signal.

14.In the Member Attributes dialog box, click the Show All Members  button.

15.Close the Member Attributes dialog box.
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Measuring a Multi-Member Waveform

The Graph window shows how the output signal, aout  fluctuates as you
change the resistor value. What would be more useful is a graph that
correlates the actual resistance value with the output voltage level.

NOTE
To perform a measurement on a multi-member
waveform, you must have either the InSpecs Parametric
Analysis Option or the InSpecs Statistical Analysis
Option installed. Skip to the Conclusion section if you
do not have either of these options.

1. Fill out the Measurement dialog box as shown in the following figure
and described as follows:

a. In the Measurement dialog box, the Measurement field, select Levels
> Maximum .

b. In the Signals field, verify that aout is selected (it is the only signal
in the list.)

c. Be sure that Create New Waveform on Active Graph is selected.
(Using the down-arrow next to this field, you could also choose to
create a new graph.)

d. Be sure that Levels vs. r.re is selected.

Measurement = Levels

Levels versus res.re resistor values

Signal = aout

Measurement = Maximum

New Waveform on Active Graph
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Measuring a Multi-Member Waveform
e. Apply the measurement to the entire waveform.

2. Click Apply .

A new waveform for signal Max(dB(aout)) has been created. The
resistor value is plotted on the X-axis and the dB(V) level is plotted on
the Y-axis.

The graph appears as a continuous curve, when in actuality, you only
simulated every 20 ohms, which you specified in the vary form. You
have full control over how graphs are displayed, (shown in a later step).

3. Delete the un-needed waveform for aout .

4. To help analyze the new graph, display the Point Marker using the
Measurement Tool as follows:

a. In the Measurement dialog box, the Measurement field, choose the
General > Point Marker  menu item. (Check that the Signal field entry
is Max(dB(aout)) .

b. Using the default values for the rest of the fields, click Apply . A
marker appears on the Max(dB(aout))  waveform.

5. Move the mouse cursor to the Point Marker. Left-click, hold, and pan
the Point Marker until the Y-value equals a gain of 10. An emitter
resistor value of around 307 (X-value) produces a gain of 10.

6. To get a feel for the graphing options available, do the following:

a. Select the Max(dB(aout))  signal name on the graph.

b. With the mouse, right-click and hold in the graph area and choose
the popup Graph Menu > Selected Signals > Style > None  menu item.

c. With Max(dB(aout))  signal selected, again, right-click in the
graph area and choose the Selected Signals > Symbol > "square
symbol."

In the resulting graph, a square represents each plotted data point
from the analysis. You may want to try out some of the other options
on your own.

7. Close SaberScope by choosing the File > Exit  menu choice.
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Conclusion

In the first part of this tutorial you were introduced to design creation using
SaberSketch. You have seen how to choose and place parts and edit symbol
and wire properties.

In the second part of the tutorial you have seen how to analyze a design. You
have covered the concepts of establishing an operating point for a circuit. You
performed a time-domain analysis and displayed the results on the design
schematic much as you might probe an actual circuit with an oscilloscope. You
evaluated the circuits frequency response in SaberScope and performed
measurements on the waveforms, which greatly simplifies the design
verification process.

The procedures shown in this tutorial cover only a few of the many features in
SaberDesigner. You may want to re-run through the steps, varying the
simulation approach from that suggested in this tutorial.
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appendix A
Amplifier Design Parameters
The transistor amplifier used in this tutorial is a text-book example. To create
this example for SaberDesigner, some design parameters were set that
determined which symbols were needed. For example, we wanted to set the
beta of the transistor rather than use a characterized part. Therefore, we
needed a symbol that would allow us to do so, such as the q_3p symbol allows.

The design needed an input signal source. The v_pulse symbol was chosen so
that we could apply a square wave to the input. The vcc required a DC source,
and the v_dc symbol was chosen.
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Appendix A: Amplifier Design Parameters
Single-Stage Transistor Amplifier Design Parameters
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appendix B
SaberDesigner Concepts
DC Operating Point Analysis

The DC operating point needs to be established prior to performing certain
types of analyses (including time-domain and frequency-based simulations).
The DC analysis determines a stable condition for the circuit when time = 0,
effectively removing the dynamic elements in the design. For electrical
circuits (as shown in this tutorial), the DC analysis solves the system with all
capacitors opened and all inductors shorted.

The DC operating point analysis can be started prior to a small-signal or
transient analysis from the SaberGuide Icon bar by clicking the Operating
Point icon. It can also be specified to run when you fill out the form for the
small-signal or transient analysis.

After you verify that the calculated DC operating point is correct, you are
ready to proceed to checking the time-domain specification. The DC operating
point is used as the first data point in the transient (time-domain) analysis
run.
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	chapter 1
	Creating a Design Using SaberDesigner
	Creating the Tutorial Directories
	1. Create (if necessary) a directory/folder called avanti_tutorial, where you will create the tut...
	2. Navigate to the avanti_tutorial directory.
	3. Create a directory called amp.
	4. Navigate to the amp directory.


	Creating the Design Using SaberSketch
	1. Invoke SaberSketch using one of the methods as follows:
	2. Provide a name for the design as follows:
	a. Save the currently empty design by selecting the File�>�Save As... menu item. A Save Schematic...
	b. In the File Name field, do one of the following:
	c. Click Save.

	3. Examine the SaberSketch work surface.
	a. Place the mouse cursor over any icon and hold it there. A text window is displayed to identify...
	b. Notice that a Schematic window named single_amp appears in the work surface.



	Placing the Parts
	1. Find and place the npn transistor symbol as follows:
	a. Click the Parts Gallery icon. The Parts Gallery dialog box appears.
	b. Set the following Parts Gallery fields:
	c. Choose the Options > Preferences menu item. The Parts Gallery Preferences form appears.
	d. Click the Search tab and select the settings as follows:
	e. Click OK. If it disappears, double click the Parts Gallery icon to bring the Parts Gallery to ...
	f. In the Parts Gallery, click the Search button.
	g. In the Available Parts list, select BJT, 3 pin NPN.
	h. Place the npn symbol by clicking the Place button.

	2. Find and place five resistor symbols as follows:
	a. In the Parts Gallery, set the fields as follows:
	b. Choose the Options > Preferences menu item. The Parts Gallery Preferences form appears.
	c. Click the Search tab and select the settings as follows:
	d. Click OK.
	e. In the Parts Gallery, click the Search button.
	f. In the Available Parts list, select Resistor (|).
	g. Place five resistors by clicking the Place button five times.
	h. Turn on the grid in the Schematic window by clicking , the Toggle Grid icon in the SaberSketch...
	i. Position the five resistors in relation to the transistor as shown in the previous Parts Place...
	j. In the SaberSketch Icon Bar, click the Zoom to Fit icon. Use the Zoom icons to help manage the...

	3. Find and place the v_pulse symbol using the following Parts Gallery settings and the previous ...
	a. Choose the Options > Preferences menu item. The Parts Gallery Preferences form appears.
	b. Click the Search tab and select the settings as follows:
	c. Click OK.
	d. In the Parts Gallery, click the Search button.
	e. In the Available Parts list, select Voltage Source, Pulse.
	f. Place the v_pulse symbol by clicking the Place button and then move it into position.

	4. Find and place the v_dc symbol using the following Parts Gallery settings:
	a. The Parts Gallery Preferences form settings you used in the previous search will work for this...
	b. In the Available Parts list, select Voltage Source, Constant Ideal DC Supply.
	c. Place the v_dc symbol by clicking the Place button and then move it into position.

	5. Find and place the horizontal capacitor symbol as follows:
	a. Choose the Options > Preferences menu item.
	b. Click the Search tab and select the settings as follows:
	c. Click OK.
	d. Click the Search button.
	e. In the Available Parts list, select Capacitor (-).
	f. Place the ch symbol by clicking the Place button.
	g. Position the symbol as shown in the previous Parts Placement figure on page 1-3. Rotate the sy...

	6. Find and place the vertical capacitor symbol as follows:
	a. In the Parts Gallery, use the same settings as you did for step 5, except in the Available Par...
	b. Place and position the symbol as shown in the previous Parts Placement figure on page 1-3.

	7. Find and place six ground symbols using the following Parts Gallery settings:
	a. The Parts Gallery Preferences form settings you used in the previous search will work for this...
	b. In the Available Parts list, select Ground, (Saber Node 0).
	c. Place the gnd symbols by clicking the Place button six times.
	d. Position the symbols as shown in the Parts Placement figure on page 1-3.

	8. Find and place three vcc symbols using the following Parts Gallery settings:
	a. Using the same search settings that you used in the previous steps, click the Search button.
	b. In the Available Parts list, select vcc.
	c. Place the vcc symbols by clicking the Place button three times. Position the symbols as shown ...

	9. Close the Parts Gallery.


	Editing the Symbol Properties
	1. For those symbols that have property value place-holders (*opt*) already displayed such as the...
	a. Position the mouse cursor at the end of the desired text field.
	b. Click the left mouse button.
	c. Backspace (use the backspace key) over the existing text to delete it.
	d. Type in the new text.
	e. For example, position the mouse cursor at the end of the text field for rload as shown in the ...
	f. Repeat steps a through d for each of the following components:

	2. To change properties on the v_dc symbol, do the following:
	a. Position the mouse cursor over the v_dc symbol to select it. It changes color to show it is se...
	b. Press the right mouse button and hold it. The popup Symbol Menu appears.
	c. In the Symbol menu, move the mouse cursor over the Properties... item and release the mouse bu...
	d. In the Properties dialog box for the selected v_dc symbol, change the ref property to vcc.
	e. Change the dc_value property to 12, which defaults to volts.
	f. In the Properties dialog box, click the Apply button.
	g. Notice that the Visibility Indicators (the circles to the right of the Value column) are set s...
	h. Close the Properties dialog box (click OK)

	3. The procedure for using the Properties dialog box is slightly different for one of the propert...
	a. Position the mouse cursor over the q_3p symbol to select it.
	b. Press the right mouse button and hold it. The popup Symbol Menu appears.
	c. In the Symbol menu, move the mouse cursor over the Properties... item and release the mouse bu...
	d. In the Properties dialog box for the selected q_3p symbol, change the ref property to q1.
	e. Move the mouse cursor to the (type=_n) value for the saber_model property. The cursor changes ...
	f. Click on the (type=_n) value. A STRUC model list box appears.
	g. In the STRUC model list box, scroll down to the bf list item. Change the bf entry to 200.
	h. In the STRUC model list box, click OK.
	i. In the Properties dialog box, click the OK button to apply the change and close the Properties...

	4. To change the properties on the rest of the symbols, repeat the following steps for each symbo...
	a. Select one symbol at a time by moving the cursor over the symbol and then pressing the right m...
	b. In the Symbol menu, move the mouse cursor over the Properties... item and release the mouse bu...
	c. Fill out the fields in the Properties dialog box as shown in the following table. The Symbol r...
	d. When you are finished entering the property values for each symbol, click the Apply button.

	5. Close the Properties dialog box.


	Wiring the Schematic
	1. The simplest way to create a wire between two ports is as follows:
	a. Position the mouse cursor over the first port (start with the top of the v_dc symbol).
	b. Click the left mouse button.
	c. Position the mouse cursor over the second port (the vcc symbol above the v_dc symbol).
	d. Click the left mouse button again.
	e. Repeat steps a through d to connect each ground and vcc symbol to the associated part as shown...

	2. Position the cursor on the bottom of rc and click the left mouse button. Move the cursor to th...
	a. Move the mouse cursor to the wire segment that connects to rc.
	b. Press-and-hold the left mouse button.
	c. Drag the wire segment down until it contacts the collector of q1.
	d. Release the mouse button.

	3. Connect re to the q1 emitter.
	4. Connect rload straight up to the wire formed from the cload-rc connection.
	5. Connect sig_source to cin.
	6. Connect the base of q1 to cin. Refer to the previous Wire Connections figure on page 1-12 as n...
	7. To connect r1 and r2 to the q1-cin intersection, you must draw two wires; one from r1 to the i...


	Modifying Wire Attributes
	1. For the first wire attribute, move the mouse cursor to the desired wire to select it. It chang...
	2. Press and hold the right mouse button to display the popup Wire Menu.
	3. In the popup Wire Menu, select the Attributes... item and release the mouse button. The Wire A...
	4. Change the value in the Name field to the desired text string. Refer to the previous Wire Attr...
	5. In the Wire Attributes dialog box, click Yes in the Display Name field.
	6. Click the Apply button followed by the Close button.
	7. Select the next wire by moving the mouse cursor to the desired wire and clicking the left mous...
	8. Repeat steps 4 through 7 until you have finished changing the wire attributes.
	9. Close the Wire Attributes dialog box.
	10. Save the design by clicking the Save icon.




	chapter 2
	Analyzing the Design Using SaberDesigner
	Starting SaberGuide from SaberSketch
	1. If the SaberGuide Icon bar is not visible, click the Show/Hide SaberGuide icon in SaberSketch.
	2. If the SaberGuide Transcript window is not open, click the Simulation Transcript icon.


	Performing a Transient and DC Analysis
	1. Click the Transient Analysis icon to bring up the Time-Domain Transient Analysis dialog box. T...
	2. Fill out the Basic form as follows:
	3. You use these transient analysis setup values later in the tutorial, so save them now as follows:
	a. In the Time-Domain Transient Analysis dialog box, click Defaults. The set up for tranalysis di...
	b. In the set up for tranalysis dialog box, enter a unique name amp_tr in the Tag Name field.
	c. With the Current tag selected, click Set Tag.
	d. Still in the set up for tranalysis dialog box, click Apply.
	e. In the Time-Domain Transient Analysis dialog box, click the Input/Output tab.
	f. In the Signal List field set to plot all by clicking Select > All Signals (/...).
	g. Change the Include Signal Types field to the All Variables setting (to include both across and...
	h. In the Time-Domain Transient (tr) Analysis dialog box, click OK.
	i. A Yes or No dialog box may be displayed that informs you that the single_amp design will be sa...

	4. Look in the SaberGuide Transcript window. (You should have opened this window from the topic "...
	a. In the SaberSketch window, choose the Results > Operating Point Report... menu item to display...
	b. In the Operating Point Report dialog box, click OK. This informs Saber to use the default sett...
	c. Refer to the DC results in the Report Tool window and the schematic to help analyze the result...
	d. Close the Report Tool window.



	Placing Probes in the Design
	1. In the Schematic window, move the mouse cursor to the aout wire to select it. The wire changes...
	2. Press and hold the right mouse button to display the popup Wire Menu.
	3. In the popup Wire Menu, select the Probe item and release the mouse button. A Probe window is ...
	4. If the transient results are not already displayed in the Probe window, you can load a plot fi...
	a. Move the mouse cursor inside of the aout Probe window.
	b. Press and hold the right mouse button to display the popup Probe Menu.
	c. In the popup Probe Menu, select the Open Plotfile... item. An Open Plotfile dialog box is disp...
	d. In the list box, select single_amp.tr.ai_pl.
	e. Click the Open button. Click Yes in the resulting dialog box. The output waveform is displayed...

	5. Place a probe on the input (in) signal as you did in the previous steps.
	6. From the results you can see that the shape of the output is being rounded by the circuit capa...
	7. Delete the Probe windows on the input (in) signal as follows:
	a. Move the cursor inside the Probe window and click-and-hold the right mouse button to display t...
	b. Select the Delete menu item.

	8. Plot the current flowing through the cload capacitor as follows:
	a. Move the cursor to the Probe arrow currently on the aout signal (it turns color).
	b. Click-and-hold the left mouse button and drag the arrow to the middle of the cload capacitor s...
	c. In the Select Port & Signal window, select the p pin.
	d. Then change the Signal Type to Through and click OK. A current flow waveform is displayed in t...
	e. Delete the remaining Probe window from the schematic. (See Step 7).



	Performing AC Analysis and Invoking SaberScope
	1. Bring up the Small-Signal Frequency Analysis dialog box by clicking the Frequency Response ico...
	2. Fill out the form as follows:
	3. Without changing the other fields, click OK. The AC analysis execution time is recorded in the...


	Analyzing Waveforms with SaberScope
	1. To remove some screen clutter, iconify the SaberSketch window.
	2. In the single_amp.ac Plot File window, select signal aout by left-clicking it. The signal is h...
	3. Plot the selected signal on the graph by either clicking the Plot button in the Plot File wind...
	4. In this tutorial you do not need the Phase(deg):f(Hz) waveform. To delete it from the Graph wi...
	a. Move the mouse cursor to the aout signal name associated with the Phase(deg):f(Hz) plot. The a...
	b. Press and hold the right mouse button to bring up the Signal Menu.
	c. Select the Delete Signal item.

	5. Even though you have already seen the results of the transient analysis, do the following to s...
	a. In the Signal Manager dialog box, click the Open Plotfiles... button. The Open Plotfiles dialo...
	b. In the File Name list, click on single_amp.tr.ai_pl.
	c. Click the Open button. A single_amp.tr Plot File window is displayed.
	d. From the single_amp.tr Plot File window, plot the aout and in signals as you did in steps 2 an...
	e. Note that the (V):t(s) plots of the in and aout waveforms are identical to those displayed on ...

	6. Look at the aout dB(V):f(Hz) (dB in volts versus frequency in Hertz) waveform in the Graph win...


	Performing Measurements on a Waveform
	1. Close the Plot File windows and the Signal Manager window.
	2. In the Tool Bar located at the bottom of the SaberScope window, click the Measurement icon.
	3. Select the Bandpass measurement as follows:
	a. Move the mouse cursor to the right of the Measurement field and press and hold the left mouse ...
	b. Move the mouse cursor down to the Frequency Domain menu.
	c. Select Bandpass.
	d. Because there is only one signal in the Graph window, aout should appear in the Signal field i...
	e. If you want to see values displayed on the graph for Topline and Offset that are used in the b...
	f. Click the Apply button. The bandwidth is displayed on the graph.

	4. Select the Gain Margin measurement by doing the following:
	a. Choose the Measurement > Frequency Domain > Gain Margin menu item.
	b. Click the Apply button. The gain margin is displayed on the graph.

	5. You can get more information about each of the measures you performed or control the amount of...
	a. In the Graph window, move the mouse cursor to the aout signal name.
	b. Use the popup menu and choose the Signal Menu > Measure Results... item. A Measure Results dia...
	c. In the Measure Results dialog box, be sure the Bandpass item in the left column is selected as...
	d. Notice in the Measure Results dialog box, in the right column, the different values that are a...
	e. Click on the various visibility indicators to choose which values are displayed in the Graph w...
	f. When you have finished exploring the Measure Results dialog box, close it.



	Varying a Parameter
	1. Iconify the SaberScope window and bring up the SaberSketch window.
	2. Click on the Vary icon, . The Looping Commands dialog box appears.
	3. In the Looping Commands dialog box, click the vary button. A Parameter Sweep dialog box appears.
	4. Fill out the Parameter Sweep dialog box as follows:
	5. Define which analysis to run on each swept parameter value as follows:
	a. In the Looping Commands dialog box, choose the AddAnalysis�>�Within�Loop(s)�>�Transient menu i...
	b. Click tranalysis. The Time-Domain Transient Analysis dialog box appears. If you have not close...
	c. To recall the transient analysis settings you previously stored, click Defaults... in the Time...
	d. Select amp_tr in the Tags list. This is the name of the file you saved previously.
	e. In the set up for tranalysis dialog box, click Apply.
	f. In the Time-Domain Transient Analysis dialog box, click the Input/Output tab.
	g. In the Plot File and Data File fields, add the string “vary_” in front of the existing “tr” st...
	h. If you do not need to view pin flow data for this vary operation, limit the data to across var...
	i. In the Time-Domain Transient Analysis dialog box, click Accept.
	j. In the Looping Commands dialog box, choose the AddAnalysis�>�Within�Loop(s)�>�Small Signal AC ...
	k. Click acanalysis. The Small-Signal Frequency Analysis dialog box appears. If you have not clos...
	l. In the Basic tab verify the following settings.
	m. Click the Input/Output tab.
	n. In the Plot File and Data File fields, add the string “vary_” in front of the existing “ac” st...
	o. In the Small-Signal Frequency Analysis dialog box, click Accept.

	6. Execute the parameter sweep by clicking the OK button in the Looping Commands dialog box.
	7. Exit the SaberSketch application (File > Exit). You can choose to save the design upon exiting.


	Displaying the Parameter Sweep Results
	1. Bring up the SaberScope window.
	2. From the SaberScope icon bar, click the Clear Graph icon to remove previous waveforms.
	3. If it is open, close the single_amp.ac Plot File window.
	4. From the Signal Manager, click the Open Plot Files... button. The Open Plot Files dialog box i...
	5. Make sure that Plot Files is selected in the Files of Type field.
	6. From the Open Plot Files dialog box, click on single_amp.vary_ac.ai_pl, then shift-click on si...
	7. Click Open.
	8. From the single_amp.vary_ac Plot File window, plot aout. The graph shows a multi-member wavefo...
	9. Delete the Phase(deg):f(Hz) waveform from the Graph.
	10. From the single_amp.vary_tr Plot File window, plot the aout and in signals on the same X/Y ax...
	a. In the single_amp.vary_tr Plot File window, select both the aout and in signals. (<Control>-cl...
	b. (3-button mouse system) Move the mouse cursor to the Graph window and click the middle-mouse b...
	a. Click the Plot button.
	b. In the Graph window, select both the new aout and in signals.
	c. Move the cursor to the middle of the Graph, and click-and-hold the right mouse button to displ...
	d. In the Graph menu, select the following choice: Selected Signals > Stack Region > Analog 0.


	11. To help manage the displayed data, do the following:
	a. Select the dB(V):f(Hz) aout signal.
	b. Choose the (popup) Signal Menu > Members... menu item. A Members Attributes dialog box is disp...
	c. Click on the Hide All button. The results of the small-signal analysis are now hidden from the...

	12. You can now observe the multi-member (V):t(s) aout signal as follows:
	a. Select the (V):t(s) aout signal.
	b. Choose the (popup) Signal Menu > Members... menu item. The Members Attributes dialog box displ...
	c. Click the Hide All button. The waveforms disappear.
	d. Click the Loop Highlight button. The graph loops through each waveform until you click the Loo...
	e. Experiment with the Member Attributes dialog box until you are comfortable with the various fe...

	13. Delete the (V):t(s) aout and in signals from the Graph window. The Member Attributes dialog b...
	14. In the Member Attributes dialog box, click the Show All Members button.
	15. Close the Member Attributes dialog box.


	Measuring a Multi-Member Waveform
	1. Fill out the Measurement dialog box as shown in the following figure and described as follows:
	a. In the Measurement dialog box, the Measurement field, select Levels > Maximum.
	b. In the Signals field, verify that aout is selected (it is the only signal in the list.)
	c. Be sure that Create New Waveform on Active Graph is selected. (Using the down-arrow next to th...
	d. Be sure that Levels vs. r.re is selected.
	e. Apply the measurement to the entire waveform.

	2. Click Apply.
	3. Delete the un-needed waveform for aout.
	4. To help analyze the new graph, display the Point Marker using the Measurement Tool as follows:
	a. In the Measurement dialog box, the Measurement field, choose the General > Point Marker menu i...
	b. Using the default values for the rest of the fields, click Apply. A marker appears on the Max(...

	5. Move the mouse cursor to the Point Marker. Left-click, hold, and pan the Point Marker until th...
	6. To get a feel for the graphing options available, do the following:
	a. Select the Max(dB(aout)) signal name on the graph.
	b. With the mouse, right-click and hold in the graph area and choose the popup Graph Menu > Selec...
	c. With Max(dB(aout)) signal selected, again, right-click in the graph area and choose the Select...

	7. Close SaberScope by choosing the File > Exit menu choice.


	Conclusion
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