New Page 1

进入教程

2004.06.12 多啦A梦制作


如何输入LICENSE NUMBER？

答：首先点击protel99菜单栏左边的箭头，选择secuity,分别选择PCB、 SCH 、Route 点击un-lock,按Add后填入密码。
1. Schematic 99 SE

1)QQMD-YU4D-EJ6M-HTZ9
2)4RFU-HC4K-JF27-4KB8
3)38DX-UP84-LTC3-NFF3
4)QVV2-5DVJ-CTBW-A7MM
5)8C6R-9ZA4-6JC5-VDY9
6)KHEZ-T3PH-2FE4-2NDP
7)3VQA-MBB9-XPYV-2HCR
8)Z5RT-2NTG-9ZRZ-J4BJ
9)L93D-QFL8-K2DZ-3YQD
10)45G6-75W2-GJ2C-2K53 		2. PCB 99 SE

1)5VN5-WAM9-GBYS-2MQF
2)9A9P-8L5S-69N8-FL68
3)BXJ3-JY8B-X27C-LB34
4)4BH2-LKR7-JUTP-8WJ4
5)6GYR-Q4G5-84PK-EE56
6)M6L7-B7CQ-Y6AL-3TQX
7)WT3X-UC49-NYR9-FK7C
8)AL8F-TZVP-KT86-928B
9)66MS-QN8M-SYBC-LL9M
10)W43U-EBH3-9EP8-X6NG
 3. Route 99 SE

1)959L-B44H-TFXU-49Q4
2)HB2D-SAPQ-699C-YVHP
3)PUAL-GECX-A8J5-CDYS
4)HCJ9-D22J-GUF9-FHG8 ****
5)5WV7-ZFDT-R5KB-YABB ****
6)DLHY-MWR8-E4PG-BETN
7)Q4EY-YAJP-9EDS-MCF2
8)D8A2-9UWJ-P7TP-4R38 ****
9)HH8P-5PJB-9YX6-2UTV
10)F749-G4T8-WX3T-J5VU
（全文完） 回首页


在PCB文件中加上漂亮的汉字

在PCB文件上面加上汉字一直都是很多网友比较感兴趣的事情。PROTEL早期的版本加汉字比较困难,99SE改变了了这一点。不但可以方便的加上汉字,加上照片也没有问题,加照片的方法稍后再讲，下面先来看看加汉字的具体方法：

第一步：安装好PROTEL99SE，运行主菜单下的“放置>汉字”

第二步：在弹出的菜单中进行相应的设置：1设置要输入的汉字，2设置汉字所在的层，3设置字体和字号大，4小选择文字为空心的还是实心的效果，5设置好以后确定，这样系统就已经记下了你的设置，以备随时调用。

第三步：此时再次运行主菜单下的“放置>汉字”，把鼠标停在要加汉字的地方几秒，就会出现你刚才设置好的汉字的虚影，此时点击鼠标左键会将汉字定位，点击右键则会取消此次操作。

到这里，设置的方法大至已经讲完，希望大家都能轻松的把自己的PCB作品加上漂亮的汉字。让在PCB上面不再只是高手的密技，下面是二个实际效果，一个是虚线的效果，一个是实线的效果。只是一些效果演示，层是乱设置的，只为说明原理，望各位兄台不要见怪：

多啦A梦收集制作

QQ：20973471


PROTEL99SE教程前言
很多网友渴望自己设计电路原理图（SCH）、电路板（PCB），同时希望从原始SCH到PCB自动布线、再到成品PCB电路板的设计周期可以缩短到1天以内！是不是不可能呢？当然不是，因为现在的EDA软件已经达到了几乎无所不能的地步！由于电子很着重实践，可以说，不曾亲自设计过PCB电路板的电子工程师，几乎是不可想象的。
很多电子爱好者都有过学习PROTEL的经历，本人也是一样，摸索的学习，耐心的体会，充分的体会什么是成功之母。不希望大家把不必要的时间浪费在学习PROTEL的初期操作上，在这里做这个教程是为了给渴望快速了解和操作PROTEL的初学者们一个走捷径的机会，教程大家都可以看到，可以省走很多不必要的弯路及快速建立信心，网络的魅力之一就在于学习的效率很高。由于本人的水平很有限，所以教程做的比较浅，就是教大家：1.画画简单的原理图（SCH）2.学会创建SCH零件 2.把原理图转换成电路板（PCB） 3.对PCB进行自动布线 4.学会创建PCB零件库 5.学会一些常用的PCB高级技巧。鉴于此，如果您这方面已经是水平很高的专业人士，无需看此教程。 同时也愿这些简单的图片教程可以使大家在今后的电子电路设计之路上所向披靡。
关于教程涉及软件版本：此教程采用的样板软件是PROTEL99SE汉化版，99SE是PROTEL家族中目前最稳定的版本，功能强大。采用了*.DDB数据库格式保存文件，所有同一工程相关的SCH、PCB等文件都可以在同一*.DDB数据库中并存，非常科学，利于集体开发和文件的有效管理。还有一个优点就是自动布线引擎很强大。在双面板的前提下，可以在很短的时间内自动布通任何的超复杂线路！
关于软件的语言：采用的是主菜单汉化版，有少量的深层对话框是英文的，重要的细节部分都在教程中作了中文注释，希望大家不要对少量的英文抱有恐惧的心理，敢于胜利是学习的一个前提。再就是不要太急于求成，有一颗平常心可以避免欲速则不达的问题。我可以向大家保证，等大家学会了自动布线，就会对设计PCB信心百倍。
关于教程本身的资源：由于本人精力很有限，所以难免有些疏忽和错误，望大家指出和理解。如果有需要转载的网友请在转载教程的同时注明教程的出处即可。但愿它可以为大家提高掌握PROTEL的效率，更希望它能从此改变大家的一生！明天将会更加辉煌！
进入正题啦！！！从此将告别厚着脸皮问别人要PCB文件的日子
 | 图片教程的第1天: 学会自己画简单的SCH文件
 | 第1课:新建一个*.DDB,新建一个SCH文件,并且添加画SCH要用到的零件库>>
 | 第2课:利用添加好的零件库,进行画第一个可以自动布线的原理图>>
 | 课后补充：SCH中一些必须要避免的错误!
 | 图片教程的第2天: 学会从SCH到PCB的转变,并且进行自动布线
 | 第一课：建立一个PCB文件，并且添加自动布线所必需的封装库
 | 第二课：把前面的SCH文件变成PCB板
 | 第三课: 对PCB进行自动布线
 | 图片教程的第3天: 学会自己做SCH零件。说明:SCH零件库用来画图和自动布线
 | 第一课：做一个SCH里面常要用到的电阻零件
 | 图片教程的第4天: 学会自己做PCB零件封装
 | 第一课：做一个属于自己的PCB零件封装
 | 课后补充：PCB中一些必须要避免的错误!
 | 布线方面的高级设置:自动布线和手动布线方面的高级设置问题
 | 图片教程的第5天: 一些高级的常用技巧
 | 一、SCH中的一些常用技巧
 | SCH的一些高级设置和常用技巧
 | 二、PCB的一些高级设置和常用技巧
 | 在PCB中,如何校验和查看PCB单个的网络连接情况
 | 在PCB中给PCB补泪滴的具体操作
 | 在PCB中给PCB做覆铜的具体操作
 | 在PCB中如何打印出中空的焊盘(这个功能对于热转印制板比较有用)
 | 在PCB中如何找到我们要找的封装
 | 如何在PCB文件中加上漂亮的汉字
 | 附件： PROTEL99SE 安装 License
 | 5天（每天2小时），你就可以搞定PROTEL99SE的常规操作。


多少次艰苦的开始，它一样爱过去！

1.万事开头难，从建立一个 *.DDB 文件开始

2.定义新建*.DDB的选项.GIF

3.所有新建的文件一般放置在主文件夹中

4.进入并新建*.SCH

5.新建一个*.SCH文件（注意看一下那些中文的文字注释）

6.添加新的零件库.GIF

此时请添加我给大家提供的 点击下载常用SCH零件>> 下载后请用WINRAR解压软件进行解压
7.下面这个就是具体的添加方法了
8.做好这些我们就可以开始进行画一个漂亮的SCH格式的原理图了>>


开始画原理图啦!
首先要先设置一下，去掉讨厌的网格显示
在这里我们利用先前添加好的SCH零件库做一个简单的SCH格式原理图，然后进行自动布线

1.如何调出SCH零件进行并且进行属性设置

2.如何正确的设置SCH零件的属性
3.一个必须学会的操作，那就是网络标号的使用，SCH可不是单纯的画图板
4.电源地的设置，这可是整个电气系统的半边天了
5.连线工具，和网络标号的和网络标号左右一样，更直观一些，属于使用频率很高的工具

6.到这里我们就已经画好一个简单的电子电路原理图了，它具备了电源、负载、电气连接关系，三个最基本的要素，下面我们来看看如何把它快速的变成PCB电路板！>>


1.在Documents目录下新建一个*.PCB文件，这样做的目的是要让*.SCH和*.PCB在同一目录下

2.添加自动布线要用到的封装库

3.添加封装库

4.这是添加好后的效果
5.一定要把尺寸单位转换一下,英制实在是不爽
到这里准备工作就做好了,进入SCH到PCB的转变>>


1.先看看SCH中都有什么零件
2.就是这个选项了,一个革命性的强大功能
3.注意看一下中文注释
4.如果遇到这个问题,说明SCH的里面还存在小的问题,注意看中文注释
5.这是成功导入后的显示方面的一些技巧
6.一些常用的技巧,补充一点,如要旋转元件的话,只要用鼠标按住元件然后按压键盘“空格键”即可
7.画一个PCB的外型框
8.做一个自己要的外型框，然后把PCB零件封装移动到里面去
到了这里，我们就可以进入自动布线的操作了>>


终于到自动布线啦!
1.可以先看看尺寸是不是合适
2.对元件进行一下布局,就是用鼠标拖动元件而已,键盘的“空格键”负责翻转元件
3.自动布线之前要校验一下，看看是不是有错误！
4.可以开始自动布线了
5.这是自动布线之前的最后一步
6.自动布线完成了，到这里你已经完成了对PROTEL99SE的一次快速穿越！

下一步我们来看看SCh零件库中零件是如何创建出来的，用系统自带的零件库就是二个字“不爽”

学会自己做SCH零件才能玩的随心所欲

学会自己做PCB封装我们才能纵横四海


做SCH零件了，很关键的一步，自力更生才可能走得更远！
1.先来打开SCH文件，选中教学提供的那个SCH零件库，然后选编辑，进入SCH零件编辑器
2.在这个现有的库中新建一个SCH零件
3.先以做一个SCH电阻零件为例子说明一下，请注意看图中所有的中文注释！
4.要注意SCH零件的管脚的电气连接有效点是有讲究的！仔细看一下下面这个图，注意看中文注释！
5.用这个方法可以给零件库中的零件改名字
6.最后是保存你的所有劳动成果，要提取的你的新零件需要重新启动PROTEL99SE
到这里，我们已经学会了如何来做SCH零件了，下面我们再来看看如何做一个PCB封装>>


1.打开在前几课已经做过的PCB，选择那个我给大家提供的封装库，然后按着图选择编辑按纽就进入了PCB封装编辑器

2.先把制式转换一下，改为公制
3.新建一个PCB封装
2.
4.之后会出现这个对话框，是一个傻瓜精灵，选择取消，因为我们要做一个完全属于自己的封装
5.注意：在做之前一定要把封装的起始位置定位成绝对中心，否者做好后的封装无法正常调用！
6.如果对默认的封装名不满意，就需要改一个自己喜欢的
7.这个是用来设置网格的标准，属于是个人喜好问题
8.这个就是执行上一步后的对话框
X

9.可以开始做封装了，注意哪些中文注释，核心问题就是焊盘的名称，但愿你还记得做SCH零件的重点>>
10.用这个功能可以知道我们做的封装的尺寸是不是精确的
恭喜恭喜! 到这里， 你已经学会了PROTEL的基本操作，剩下的是一些的特殊技巧和高级设置了>>


前面我们走马观花的对SCH做了一些操作，这回我们来看看SCH中的一些高级设置和操作技巧
1.看看如何对SCH的操作环境做一下合理的设置：
2.这是对一些单方向3脚零件的反转技巧操作
3.PROTEL本身也带有非常丰富的元件库，现在我们来看看如何来自动搜索出这些零件
5.关闭PROTEL99SE时的技巧，如果你的电脑配置一般，分步的关闭可以避免死机和丢失你的成果
关键操作是鼠标右键>>Close
6.这是科学管理文件的典范,如果你的内存不是非常大,注意不要打开太多的并行任务

7.文件做好后你会发现DDB的文件个头很大,同时你可能最需要里面的部分文件,如何做呢?那就是先导出然后再用压缩软件压缩!


1.这是一个很有用的功能,请注意看那些白色的线!
2.变白的方法


仔细看这里,我们将学会做给PCB补泪滴的具体操作


这里我们可以知道给PCB做覆铜是多么的简单


让我们打印出中空的焊盘,这是一个关于热转印支PCB板的操作


在PCB中如何找到我们要找的封装


这里简单介绍一下自动布线和手动布线方面的设置问题
1.如何进入PCB的这个布线规则选项:
2.电气安全距离的设置
3.导线宽度的设置
4.学会了设置图层就可以做单面板以及多层板,而不只是双面板
5.布线中线段拐角方式的设置
6.布线类型的选择
7.一些其他的设置
8.最后再学学如何清除错误标志