
ii

1．常规操作.......................................................................................................................................................16
1.1 ...............................................................................................................................................17

2．FILE 下拉菜单..............................................................................................................................................17
2.1 New..........................................................................................................................................................17
2.2 Open ........................................................................................................................................................17
2.3 Close........................................................................................................................................................18
2.4 Save .........................................................................................................................................................18
2.5 Save As....................................................................................................................................................18
2.6 Save All ...................................................................................................................................................18
2.7 Configuration ........................................................................................................................................18
2.8 Print.........................................................................................................................................................18
2.9 Print Window .........................................................................................................................................18
2.10 Export ...................................................................................................................................................18
2.11 Printer ...................................................................................................................................................18
2.12 Most Recently Accessed Files ...........................................................................................................19
2.13 Exit ........................................................................................................................................................19

3. EDIT 下拉菜单 ...............................................................................................................................................19
3.1 SaberGuide ..............................................................................................................................19
3.2 Undo, Redo.............................................................................................................................................19
3.3 Cut Copy Paste Delete.............................................................................................................20
3.4 Find/Select .............................................................................................................................................20
3.5 Application Preferences.......................................................................................................................21
3.6 Schematic Preferences .........................................................................................................................21

4．VIEW 下拉菜单% .......................................................................................................................................24
5．DESIGN 下拉菜单% ....................................................................................................................................25
6．SCHEMATIC下拉菜单% .............................................................................................................................25
7．SYMBOL 下拉菜单% ..................................................................................................................................26
8．PROBE 下拉菜单% ......................................................................................................................................26
9．TOOLS下拉菜单% ......................................................................................................................................26
10．WINDOW 下拉菜单% ...............................................................................................................................26
11．HELP 下拉菜单% ......................................................................................................................................27

 SABERSKETCH EDITOR ......................................................................................................28

1. 常规操作% ....................................................................................................................................................28
1.1 ..............................................................................................................................28
1.2 ..............................................................................................................................28
1.3 ..........................................................................................................................29
1.4 ...........................................................................................................................................29
1.5 ....................................................................................................................................................29
1.6 ....................................................................................................................................................30
1.7 ...........................................................................................................................................30

2．SYMBOL EDITOR 窗口% ............................................................................................................................30
2.1 Sybol Editor ................................................................................................................31
2.2  Schematic .................................................................................................................35

 SABERSCOPE .................................................................................................................41

1．常规操作% ..................................................................................................................................................41
1.1 ...............................................................................................................................................42

2．FILE 下拉菜单% ..........................................................................................................................................42
2.1 New .....................................................................................................................................................42
2.2 Open ...................................................................................................................................................42
2.3 Close........................................................................................................................................................42
2.4 Save .........................................................................................................................................................43
2.5 Configuration ........................................................................................................................................43
2.6 Print ...................................................................................................................................................43
2.7 Export ................................................................................................................................................43



iii

2.8 Printer ................................................................................................................................................43
2.9 Exit .....................................................................................................................................................43

3. EDIT 下拉菜单 ...............................................................................................................................................44
3.1 Cut Copy Paste ..........................................................................................................................44
3.2 Application Preferences ..................................................................................................................44
3.3 Graph Preferences ...........................................................................................................................44

4．GRAPH 下拉菜单% .....................................................................................................................................48
4.1 Signal Attributes....................................................................................................................................49
4.2 Axis Attributes........................................................................................................................................51
4.3 Members ............................................................................................................................................53
4.4 Measure Results ...............................................................................................................................54
4.5 Selected Axes ....................................................................................................................................55
4.6 Selected Signals ...............................................................................................................................57
4.7 Selected Graphics .................................................................................................................................59
4.8 Font ....................................................................................................................................................59
4.9 Color map .........................................................................................................................................59
4.10 Legend .............................................................................................................................................59
4.11 Match Aspect Ratio.............................................................................................................................60
4.12 Clear Graph ...................................................................................................................................60

5. TOOLS下拉菜单% ........................................................................................................................................60
6. WINDOW 下拉菜单% ...................................................................................................................................60
7. HELP 下拉菜单% ..........................................................................................................................................60

....................................................................................................................................................61

1．常规操作.......................................................................................................................................................61
1.1 ...........................................................................................................................................61
1.2 ........................................................................................................................................................61
1.3 ........................................................................................................................................................62

2．TRACE 图形区域% .....................................................................................................................................63
2.1 Trace .....................................................................................................................................63

3．模拟图形区域% ..........................................................................................................................................64
3.1 Graph ....................................................................................................................................64
3.2 Axis ...................................................................................................................................65
3.3 Signal ................................................................................................................................65
3.4 Measure ............................................................................................................................66
3.5 AimDraw ..........................................................................................................................67



I

SaberDesigner

快速参考包括以下主要内容：

 SaberDesigner 图标栏图标

 SaberDesigner 工具栏图标
 鼠标应用

1. SaberDesigner

下列表格列出了所有的 SaberDesigner 图标栏图标，并介绍了从何处找寻

有关功能信息。

XY 图形
在工作面(SaberScope)打开一个新的空白的 XY
图形。

打开文件

打开一个文件。

保存
保存当前窗口。

打印当前

窗口

打印当前窗口的硬拷贝。有关打印的详细内容，

请参阅在线 SaberBook中的 Printing(在SaberBook
的索引中敲 Printing)。

剪切
复制到剪切板，如果可能，删除原来的内容。

复制
复制到剪切板，并保留原来的内容。

粘贴
从剪切板粘贴到当前窗口。

放大
提高放大率，显示更具体的细节。

缩放成窗口

大小

显示窗口内的所有目标。

缩小
降低放大率，显示的细节少，但内容多。

层叠
窗口放置成一个叠一个（沿对角线），从工作面

的左上角排列到工作面的右下角。

瓦状 瓦状放置窗口，从而窗口不会交迭。

清除图表
从图形窗口中清除所有的信号、轴、字符和图形，

而不保存信息(SaberScope)。

切换网格 在当前窗口切换网格的可视与否。
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建立总线
采集多个数据信号，并将其综合成一条数据总线

(SaberScope)。

分散总线
将总线分散为离散的数据信号(SaberScope)。

At X测量法 对选定信号实行 At X 测量法。详细内容参阅在

线 SaberBook 的测量法(或在 SaberBook 索引键

入 at x)。

At Y测量法 对选定信号实行 Threshold (At Y 测量法)。详细

内容 参阅在 线 SaberBook 的测 量法 ( 或 在
SaberBook 索引键入 at y)。

交叉检查
显示 SaberSketch 中与 SaberScope 内选定信号有

关的导线或节点。要显示该图标，SaberScope 必

须从 SaberSketch打开。

建立导线
在两部件之间建立导线连接。详细内容参阅第五

章的“建立基本原理图” （SaberSketch）。

线束
建立线束。详细内容参阅第五章的“线束弹出式

菜单” （SaberSketch）。

属性编辑器
打开属性编辑器对话框。详细内容参阅在线

SaberBook 的属性编辑器(在 SaberBook 索引键入
property)。

波形检查 检查线路并显示波形。详细内容参阅在线

SaberBook 的检 查 ( 在 SaberBook 索引 键入

probing)。

Saber 显示/隐藏 切换显示 SaberGuide图标栏(SaberSketch)。

操作点
打开操作点分析表格。该表格允许计算系统的操

作点。参阅 SaberBook在线资料的在线SaberGuide
仿真参考(SaberGuide)。

频率响应
打开小信号频率分析表格。该表格允许进行系统

的小信号 AC 分析，以找到 AC 响应。参阅

SaberBook 在线资料的在线 SaberGuide 仿真参考

(SaberGuide)。

DC 转换
打开 DC 转换分析表格。该表格允许进行操作点

分析，以计算用户定义范围内每个点的操作点。

参阅 SaberBook 在线资料的在线 SaberGuide 仿

真参考(SaberGuide)。

瞬态分析
打开时间域瞬态分析表格。该表格允许进行设计
的瞬态分析，以找到时间域响应。参阅 SaberBook
在 线 资 料 的 在 线 SaberGuide 仿 真 参 考

(SaberGuide)。

极零点分析
打开极零点分析表格。该表格允许确定系统的极

点和/或零点。参阅 SaberBook 在线资料的在线

SaberGuide仿真参考(SaberGuide)。
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变参
打开参数扫描表格，该表格允许在用户定义范围

内扫描元件参数值，并对每个扫描的值进行一个

或多个分析。参阅 SaberBook 在线资料的在线

SaberGuide仿真参考(SaberGuide)。

Monte Carlo 打开 Monte Carlo 分析表格。该表格允许统计环

境执行一组 Saber 命令，具有对命令执行一系列
Monte Carlo 法的效果。参阅 SaberBook 在线资

料的在线 SaberGuide仿真参考(SaberGuide)。

灵敏度
打开灵敏度分析表格。该表格允许设置参数和干

扰以进行灵敏度分析，并选择要执行的分析类

型。参阅 SaberBook 在线资料的在线 SaberGuide
仿真参考(SaberGuide)。

列表/更改
打开列表/更改设计表格。该表格允许暂时更改(但
不删除)模板中描述当前程序块的任何单元或参

数值。参阅 SaberBook在线资料的在线SaberGuide
仿真参考(SaberGuide)。

最终绘图文件
从最新分析将绘图文件装载入 SaberScope
(SaberGuide)。

更新检查
从最新分析将绘图文件装载入 Probe 窗口

(SaberSketch)。

中断仿真
暂时停止当前的仿真(SaberGuide)。

仿真脚本
打开 SaberGuide 脚本窗口。参阅 SaberBook 在

线 资 料 的 在 线 SaberGuide 仿 真 参 考

(SaberGuide)。

忙指示器
Saber 仿真器工作时旋转。

设计工具
打开 SaberSketch 设计工具。该工具显示一个

设计层中的所有原理图。详细内容参阅在线

SaberBook 中的设计工具(在 SaberBook 索引中
键入 design tool)。

元件库
打开 SaberSketch 元件库。该工具允许浏览元

件库、选择元件并将其放置在原理图中。详细

内容参阅在线 SaberBook 中的 SaberLink(在
SaberBook 索引中键入 saberlink)。

SaberLink-
MATLAB

工具

打开 Saberlink-MATLAB 工具，该工具是 Saber
Designer 应用与 MATLAB 应用的接口，详见

Saber Link（在 Saber Book 索引中键入 Saber
Link）。
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信号管理器
打开 SaberScope 信号管理器。该工具允许浏

览绘图文件，并将其作为图形显示。详细内容

参阅在线 SaberBook 中的信号管理器 (在
SaberBook 索引中键入 signal)。

报告工具

打开 SaberGuide 报告工具。该工具允许编辑

Saber 仿真文件或任何 ASCII 文本。还与 Saber
仿真器连接，因此新的报告在报告窗口生成和

显示。参阅 SaberBook 在线资料的在线

SaberGuide仿真参考(SaberGuide)。

测量工具
打开 SaberScope 测量工具。该工具执行测量

操作，用来显示波形的一个或多个“性能测

试¡。详细内容参阅在线 SaberBook 测量 (在
SaberBook 索引中键入 measure)。

宏记录器

打开 SaberDesigner 宏记录器工具。该工具记

录系列动作，允许编辑这些动作，并将其作为

原本返回。详细内容参阅在线 SaberBook 绘图
工具(在 SaberBook 索引中键入 macro)。

AimDraw

工具

打开 SaberDesigner AimDraw 工具。该工具允

许在 SaberSketch 建立符号，在 SaberDesigner
窗口建立通用图形目标和文本。详细内容参阅

在线 SaberBook 绘图工具(在 SaberBook 索引
中键入 draw)。

计算器
打开 SaberScope 计算器。该工具允许以 Aim
语言表示、波形和数字形式执行数学和逻辑操

作。详细内容参阅在线 SaberBook 之计算器(在
SaberBook 索引中键入 calculator)。

命令行工具
打开命令行工具。该工具允许进入 Aim 命令，

写入文本，并保存为文件。还可以查看

SaberDesigner Log 。 详 细 内 容 参 阅 在 线

SaberBook 命令行工具(在 SaberBook 索引中键

入 command line)。

2.

左键单击 选择一个目标

按下 Shift 键并单击左键 选择多个目标

按下左键不释放并拖动 移动一个目标

左键双击 1． 打开文件和目录

2． 带出 Attributes 表格

中键单击(两键鼠标则同时按下左右键) 粘贴一个目标
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按下中键不释放并拖动 (两键鼠标则同

时按下左右键)
扫过一个窗口

按下右键不释放 带出一个弹出式菜单

3. SaberSketch SaberScope

一个窗口内的每个事物都是一个目标。

将鼠标移到一个目标处并高亮显示(其缺省颜色是变红)。
在目标单击左键，其显示稍有不同。大多数目标的显示是逆向视频。

AimDraw图形目标和原理图导线，则显示选择手柄。

按下鼠标左键不释放并拖动，可移动大多数目标。

在目标上按下鼠标右键，显示一个可用来选择不同动作的弹出式菜单。
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SaberDesigner应用参考

1.

有关 Analogy SaberDesigner 应用程序的主要信息都可以在在线 SaberBook
找到。要进入 SaberBook，在任何 SaberDesigner 应用程序中选择 Help>SaberBook
菜单项。

在本 SaberDesigner 参考手册中，可以找到有关 Analogy SaberDesigner 软

件应用和选项的信息。

SaberDesigner 参考的第一部分介绍 SaberDesigner应用程序参考，包括：

 SaberDesigner 下拉菜单

 常用 SaberDesigner 窗口操作

 SaberSketch设计编辑器窗口
 SaberScope 图形窗口

SaberDesigner 参考的第二部分介绍以 AIM 定制 SaberDesigner。

2.

2.1 Analogy

 Installing Analogy Products 指示如何安装 Analogy产品。UNIX 平台和

Windows NT平台有单独的操作手册。

 Getting Started With Saber Designer 对如何使用 SaberDesigner 集成工具

作出了基本指示。

 Analyzing Design Using Saber Designer介绍了线路设计和 Saber 仿真操
作。

 Customizing SaberDesigner Using AIM解释了如何在 SaberDesigner 环境

下使用 AIM 脚本语言。

 Tcl/Tk 的创建者 John K. Ousterhout 所著的 Tcl and the TK Toolkit，解释

了如何使用 Tcl/Tk 脚本语言。

2.2

 Brent Welch所著的 Practical Programming in Tcl and Tk，介绍了如何使
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用 Tcl/Tk 脚本语言。该书 Analogy 公司不提供。

 Eric F. Johnson所著的 Graphical Applications with Tcl and Tk，介绍了怎
样以 Tcl/Tk 脚本语言创建交叉平台图形应用程序。

3

本手册使用了如下约定：

关键字 关键字是以左侧字体显示的保留字(例如，常规名、程序名、
网表输入、节点名、参数、命令名、文件名、属性名等)
命令行中以斜体显示的项表示其位置必须应用具体的文

本。

*req * 术语*req*表示对于给定项，必须给定一个值。

菜单项、模板名和关键术语以黑体显示。
强调文本以斜体显示。

[ ] 斜方括号内的文本表示可选词条。

单击 快速按下并释放鼠标键一次。

按下不释放 按下鼠标键不释放。

双击 快速按下并释放鼠标键两次。
以下约定用在本手册中表示从子菜单中选择一个菜单。举例如下：

Results > Modify Plot Set > Remove All Probes
该例中，要选定 Remove All Probes 菜单项，首先从顶级菜单中选择项

Results，然后从子菜单选择 Modify Plot Set ，最后从二级子菜单选择Remove All
Probes

4

1996 年 10 月 首次出版，同时还有 Saber 仿真器 4.1 版。
1996 年 12 月 再次出版，同时还有 Saber 仿真器 4.1.1 版。

1997 年 7 月 三次出版，同时还有 Saber 仿真器 4.2 版。

1998 年 3 月 四次出版，同时还有 Saber 仿真器 4.3 版。
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 SaberDesigner

本章主要包括以下内容：

 SaberDesigner
 SaberSketch
 SaberGuide
 Saber Simulator
 SaberScope
 SaberLink
 调用 SaberDesigner 应用程序

 工作面概观

1 SaberDesigner

SaberDesigner 集成工具是一组应用于综合环境中的工具，方便线路设计和
测试。SaberDesigner 包括 SaberSketch Design Editor、SaberGuide 仿真环境、Saber
仿真器、SaberLink 分析接口和 SaberScope 波形分析器。

SaberDesigner 版本可应用于 UNIX 环境或 Windows NT环境。

SaberDesigner 是和 Analogy Incorporated Macro (AIM)脚本语言一起创建

的。AIM 是 John K. Ousterhout 开发的 Tcl/TK 脚本语言的超级设置。有关 Tcl/TK
的信息可在 John K. Ousterhout 的书 Tcl and the TK Toolkit 中找到。有关 AIM 的

信息可在 SaberDesigner 帮助的下拉菜单中找到。

2 SaberSketch

SaberSketch用于创建和编辑设计。这些设计可以是混合信号（模拟或数字）
或综合技术，结合了电子、电气、机械、液力和光学技术。如果一个装置能以

数学描述，则可以纳入设计。

3 SaberGuide

SaberGuide 是 Saber 仿真器的控制环境。由 SaberGuide 帮助进行设计分析，

使 Saber 仿真器更迅速简洁。

4 Saber

Saber 仿真器是一个功能很强的模拟和混合信号仿真器，允许进行电气和

非电气设计以及这些设计与总体设计的集成。
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有关 Saber 仿真器操作的细节，请参阅 Analyzing Designs Using
SaberDesigner, Getting Started With SaberDesigner，以及 SaberGuide Simulation
Reference。

5 SaberScope

SaberScope 应用于显示和控制 Saber 仿真器线路分析的结果。SaberScope
可以用来以图表记录数据、并对这些图表进行测量和计算，保存结果并以单色
或彩色打印结果的复印件。

6 SaberLink

SaberLink 允许访问 MATLAB，以及文件在 SaberDesigner 应用程序和

MATLAB程序运行结果之间转换。SaberLink 在 UNIX环境下操作。

7 UNIX SaberDesigner

要同时调用 SaberSketch和 SaberGuide， 在命令提示行键入 sketch。
要同时调用 SaberGuide 和 SaberScope， 在命令提示行键入 saber。这种结

合提供完全互动仿真以及波形视图和分析。

只调用 SaberScope 而不调用 SaberGuide，在命令提示行键入 scope。只调

用 SaberScope 用来对现有绘图文件作后处理。

只调用 SaberGuide 而不调用 SaberScope，在命令提示行键入 guide。只调

用 SaberGuide用来进行仿真而不进行波形分析。

关于上述命令有许多调用选项。参阅在线资料的 Help > SaberBook >
Reference > SaberDesigner Reference > System Commands。

8 Windows NT SaberDesigner

SaberDesigner 应用程序从 SaberDesigner Program Group 调用。

 要同时调用 SaberSketch和 SaberGuide，双击 SaberSketch图标。

 要同时调用 SaberGuide 和 SaberScope，双击 Saber图标。
 只调用 SaberScope 而不调用 SaberGuide，双击 SaberScope 图标。

 要调用 SaberBook，而不打开任何 SaberDesigner 应用程序，双击

SaberBook 图标。

 要打开 Aim Help Browser，而不打开任何 SaberDesigner 应用程序，双

击 Aim Help 图标。
 要打开 Aim Tutorial，而不打开任何 SaberDesigner应用程序，双击 Aim

Tutorial图标。

 要打开 SaberDesigner License Tool，双击 SaberDesigner License Tool图
标。
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9

SaberDesigner 应用程序工作面由所有图标、菜单、工具和显示窗口构成。

SaberScope 和 SaberGuide 工作面支持图标、菜单、工具和图形窗口。

图 1 SaberScope 及 SaberGuide 工作平面
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SaberSketch和 SaberGuide工作面支持图标、菜单、工具和编辑窗口。

图 2 aberSketch和 SaberGuide 工作平面
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本章包括下列主要内容：

 常规操作

 文件下拉菜单
 编辑下拉菜单

 工具菜单

 窗口菜单

 帮助菜单

1

下拉菜单栏在工作面顶端之间运行。

Analyses, Extract 和 Results 菜单只有在 SaberGuide 操作中才有。Graph 菜

单只在 SaberScope 操作中有。Design, Schematic, Symbol 和 Probe 菜单只在

SaberSketch操作中有。View菜单在 SaberSketch和 SaberGuide 中运行。File, Edit,
Tools, Window和 Help 菜单在所有 SaberDesigner 应用程序中都可运行。

打开下拉菜单的步骤如下：

1． 将鼠标光标放在菜单名上，高亮显示菜单名。

2． 以鼠标左键单击高亮显示的菜单名，打开菜单。

在下拉菜单调用某一项的步骤如下：

1． 将鼠标光标放在该项上，高亮显示该项。
2． 单击鼠标左键，调用该项。

包括级联菜单的下拉菜单项在该项的右侧有一个箭头。

要显示级联菜单，将光标移到带箭头的项。

要发现下拉菜单项的功能，将光标移到该项，SaberDesigner 工作面下的帮

助域将显示有关该项的简短说明。

1.1

可以打开一个下拉菜单，将其移到屏幕的其他部位，并在使用完之前一直
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保持显示。

1． 将鼠标移到菜单名，高亮显示该菜单名。
2． 在高亮显示的菜单上按下鼠标中键不动。

3． 将显示的下拉菜单移到预定的位置。

4． 释放鼠标键，放置菜单。

从撕离菜单回到常规控制的步骤如下：

1． 将鼠标光标移到相应的菜单名，在下拉菜单栏高亮显示菜单名。

2． 单击鼠标左键。

2 File

File 下拉菜单允许打开现有文件，将工作保存为新文件，创建新窗口，保

存配置设置，打开打印对话框以及退出 SaberDesigner。
每个 SaberDesigner 的应用程序对 File 菜单的处理稍有区别。有关 File 菜

单的详细信息，参阅各个应用程序章节。

2.1 Open File

Open File 对话框的功能在所有 SaberDesigner 应用程序中大体相同，只是

在对话框的标题以及可进入的文件上稍有区别。

Open File 对话框包括 Directories 表格、File Name 表格和 List Files of Type
域。
2.1.1 Directories

Directories 域允许在所有目录级中浏览。如果一目录包含的文件与 List Files
of Type 域中的文件类型相匹配，这些文件将在可滚动的 File Name 表中显示。

 要移到下一个较低级的目录以及显示子目录，双击目录名，或单击目
录，然后单击 OK 键。

 要移到下一个较高级的目录，双击双句点(..)，或单击双句点 然后单

击 OK 键。
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 还可以在 File Name 域中直接键入目录的路径名。要清除 File Name 域，

键入^u (同时按下 Control 和 u键)。
2.1.2 File Name

File Name 滚动域显示当前打开目录中与 List Files of Type 域中的文件类型

相匹配的文件。有时可一次打开多个文件。打开文件有几种方式。

 双击文件名。

 单击文件名，并单击 OK 键。
2.1.3 List Files of Type

List Files of Type 域允许只显示特定的文件类型，或显示某个目录中的所有

文件。

 单击 List Files of Types 域中的下指箭头可看到（文件）选项。

2.2 Save

File > Save 项保存当前显示窗口。该项对每个 SaberDesigner 应用程序的处

理稍有不同。

2.3 New

File > New 项打开一个新的窗口。该项对每个 SaberDesigner应用程序的处

理稍有不同。

2.4 Configuration

File > Configuration项允许立即或在现有 SaberDesigner 保存工作面配置。
2.4.1 Save

File > Configuration > Save 项保存当前工作面配置。

2.4.2 Clear
File > Configuration > Clear 项清除任何在当前 SaberDesigner会话中保存的

配置。下一次调用 SaberDesigner 时的配置为缺省设置。

2.4.3 Save on Exit
File > Configuration > Save on Exit 项保存在退出 SaberDesigner 时当前工作

面配置。

2.5 Print

选择 Print 打开 SaberDesigner Print 对话框。有关打印设置的详细信息，参

阅在线 SaberBook Printing ( Help > SaberBook)，以及 Installing Analogy Products。
 要打印当前图形，以鼠标左键单击 Print 对话框中的 OK 键。

2.6 Export

在 SaberDesigner 的 Windows NT版本中，Export > Enhanced Metafile 项将

当前窗口保存为 Windows Metafile 文件格式。
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2.7 Exit

File > Exit 项关闭 SaberDesigner 返回到原来应用层，不保存任何信息。

在 SaberSketch中会提示保存任何的修改。

如果要保存信息，在退出前应选择 File＞Save。
如果要保存配置，应选择 File > Configuration > Save 项。

如果在每次退出 SaberDesigner 时都要保存配置，使用 File > Configuration >
Save on Exit 项，或 Edit > Application Preference > Save Configuration on Exit > Yes
项。

3 Edit

Edit 下拉菜单允许执行编辑操作，定制工作面外观，以及定制 SaberDesigner
窗口的外观和操作。

Edit 菜单对每个 SaberDesigner 应用程序稍有不同。本章介绍了所有

SaberDesigner 应用程序公用的项。

3.1 Application Preferences

Edit > Application Preferences 对话框允许定制工作面的颜色和定制工作面

的文本。

3.1.1
要应用新的选择，使用 Apply 键。新的选择将立即应用到工作面。这种修

改只用于当前部分，除非应用 Save 键。

要将修改保存为下一个 SaberDesigner 部分的优先选择，单击 Save 键。可
以退出、返回然后得到新的优先选择。

Defaults 键将优先选择设置为原始的缺省选择。

Reset 键将工作面返回到当前部分打开时的设置，或者应用 Apply 键时的

最终设置。

Close 键关闭对话框，返回到工作面。
Save Configuration on Exit 键可以选择退出时保存配置。

3.1.2
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颜色可以在 Foreground、Active Foreground、Background 和Active Background
中修改。

Foreground 包括下拉菜单文本以及所有菜单和对话框中键和域的文本。

Active Foreground 包括高亮显示的下拉菜单文本以及高亮显示的所有菜单

和对话框中键和域的文本。

Background 包括工作面以及在所有菜单和对话框上显示的文本和键的表

面。

Active Background 包括高亮显示文本周围的高亮部分。

改变颜色

 要改变颜色，单击包含彩色方块的 Foreground、Active Foreground、
Background 和 Active Background 键。将显示一个 Color Editor对话框。

有关编辑颜色的详细信息，参阅在线 SaberBook Draw tool (Help >
SaberBook)。

选择完颜色后，单击 Color Editor 对话框中的 OK 键。从而选择颜色，返

回 Application Preference 对话框。可以将修改应用于工作面，或按常规操作所

介绍的保存。

3.1.3
要在工作面修改文本风格，单击 ABC 123 键。将显示 Font Selection 对话

框。

 有关选择字体的详细信息，参阅在线 SaberBook Draw tool (Help >
SaberBook)。

选择完字体后，在 Font Selection对话框中单击 OK 键。从而选择字体，返

回 Application Preference 对话框。可以将修改应用于工作面，或按常规操作所

介绍的保存。

3.1.4
Date Format 项全面改变 SaberDesigner 中的日期显示。
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 要修改日期显示，单击 Edit 键。将显示 Edit Text Variables对话框。

Definition域显示当前日期显示格式。

Predefined 键打开一组预定的日期显示。

Building Blocks 滚动序列允许建立自己的日期显示。

要将某项放置在 Definition域，在该项上单击左键。

3.1.5
图形优先选择由相应的对话框或键进行。这些选择必须应用到图形窗口。

4. Tools

Tools 下拉菜单允许进入 SaberDesigner Tools，其图标位于屏幕下方。有关

每个工具的功能，参阅“工具”一章。

5. Window

Windows 下拉菜单允许对工作面的多个窗口进行管理。

工作面的所有窗口列在 Windows 下拉菜单的底部。

 要打开一个图标化的窗口，或将一个窗口放在一叠窗口的最前面，以鼠

标左键单击序列中的窗口名。

Window > Cascade 窗口选项将窗口放置在工作面的对角线方向，即从工作

面的左上角排到工作面的右下角。

Window > Tile 窗口选项放置的窗口不会重叠。

Window > Arrange Icons 选项将多个图标整齐地排列在工作面的底部。
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6. Help

Help 下拉菜单对各种 SaberDesigner 属性提供帮助。

SaberBook 打开其 Contents 窗口。从这个窗口可以看到 Analogy在线资料。

AIM Help Browser 为 AIM 语言和 Tcl/Tk 脚本语言提供参考信息。
 按下 Subjects Available In的任何按钮，可以浏览信息。

 要找寻特定项，单击 Find Topic 按钮。显示 Aim Help Browser 对话框。

 在 Search For 域中键入该项名的全部或部分，在键盘上按 Return键。

 按 Close 按钮退出 AIM Help Browser。
AIM Tutorial为 AIM 语言的操作提供课程。
User Group Info 对加入 Saber 用户群和 ASSURE(Analogy Saber Simulator

Users Resource)提供在线信息。

About SaberSketch显示 SaberSketch版本和版权。

About SaberScope 显示 SaberScope 版本和版权。

About SaberGuide 显示 SaberGuide 版本和版权。

About SaberBook 显示 SaberBook 版本和版权。
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本章包括下列主要内容：

 常规操作

 窗口菜单

1.

设计分析的数据在窗口转换为图形，原理图和符号在窗口显示。

1.1

工作面一次可显示多个窗口。图形窗口自动从 0 开始计数。窗口的定位有

三种方法。
* 使用图标栏中的 Cascade 或 Tile 图标。

* 使用窗口上方的 Name 栏。

 将光标放在窗口的 Name 栏。

 按下鼠标左键不释放，并拖动窗口。

 释放鼠标左键，放置窗口。
* 使用 Window菜单，将窗口放在一叠窗口的底部。

1.2

调整窗口的大小可以使窗口内容相应扩大或缩小。调整窗口有三种方法。

* 使用窗口右上角的 Max/Min 按钮。

 以鼠标左键单击 Max/Min 按钮，以使窗口最大化。
 再次单击 Max/Min 按钮，将窗口还原为原来的大小。

* 使用 Window菜单扩大或还原窗口大小。

* 移动窗口边界，改变窗口大小。

 将光标放在窗口边沿。光标从箭头变为指向矩杠或一个角铁符的箭

头。
 按下并保持鼠标左键，改变窗口大小。

 释放左键，设定新的大小。

1.3

为方便快速查找以及避免工作面的混乱，窗口可以缩小为图标。从窗口缩

小为图标有两种方法。
* 使用窗口右上角的图标按钮。

 单击图标按钮使窗口图标化。
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 双击图标，将窗口还原为原来的大小。

* 使用 Window菜单的 Minimize 命令。
 双击图标，将窗口还原为原来大小。

图标可以移到工作面的任何地方。

 将光标放在图标上。

 按下鼠标左键不释放并移动图标。

 释放鼠标左键，放置图标。

2 Window

窗口左上角的矩形按钮可以打开 Windows 菜单。不能使用的命令变灰显

示。

 单击鼠标左键打开 Window菜单。
窗口以 Max/Min 按钮最大化后，Restore 将窗口还原为原来大小。

Minimize 将窗口缩小为图标。

Maximize 将窗口扩大到最大工作面。

Lower 将窗口放置在一叠窗口的下面。

Close 将窗口从工作面移开，不保存。窗口破坏，所有工作丢失。
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SaberSketch

本章包括下列主要内容：

 常规操作

 File 菜单
 Edit 菜单

 View菜单

 Design菜单

 Schematic 菜单

 Symbol菜单

 Probe 菜单

1

下拉菜单栏在工作面的上部运行。

Analyses、Extract 和 Results 菜单只是在 SaberGuide 操作中有。Design、
Schematic、Symbol和 Probe 菜单只在 SaberSketch操作中有。File、Edit、View、

Tools、Window和 Help 菜单在 SaberGuide 和 SaberSketch中运行。

打开下拉菜单的步骤如下：

1． 将鼠标光标放在菜单名上，高亮显示菜单名。

2． 鼠标单击高亮显示的菜单名，打开菜单。

调用下拉菜单中的项，其步骤如下：

1． 将鼠标光标放在该项，高亮显示。

2． 单击鼠标按钮，调用该项。

包含级联菜单的下拉菜单项在右侧有一个箭头。
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 要显示级联菜单，将光标放在有箭头的一项。

 要发现某个下拉菜单项的功能，将鼠标光标放在该项。在 SaberDesigner
工作面底部的 Help 域将出现一个简短的注释。

1.1

可以选择打开下拉菜单，将其移到屏幕的其他部位，使其一直显示，直到

已经用完。使用撕离选项的步骤如下：

1． 将光标放在菜单名上，高亮显示菜单名。
2． 在高亮菜单上按下鼠标中键不动。

3． 将显示的下拉菜单移到想要的地方。

4． 释放鼠标按钮，放置菜单。

从撕离菜单返回到常规控制的步骤如下：

1． 将光标放在菜单名上，高亮显示下拉菜单中的菜单名。

2． 单击鼠标左键。

2 File

File 下拉菜单允许打开现有文件，将工作保存到新的文件，打开打印对话

框，以及退出 SaberSketch。

2.1 New

File > New 项创建一个新的设计或符号。这些术语的定义参阅第五章：

¡ SaberSketch Editor 窗口”。

2.2 Open

File > Open项打开一个现有的设计或符号。有关使用 Open Files 对话框的

详细信息参阅第二章的“打开 Open File 对话框”。
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2.3 Close

File > Close 项关闭工作面的活动窗口，或工作面的所有窗口。

2.4 Save

File > Save 项将当前窗口保存为当前文件路径和文件名。

2.5 Save As

File > Save As 项将当前窗口保存为选定的文件路径和文件名。

2.6 Save All

File > Save All 项使用当前文件路径和文件名保存当前显示的所有窗口。

2.7 Configuration

File > Configuration 项允许立即或在现有的 SaberDesigner 保存工作面设

置。详细信息参阅第二章的¡ Configuration”。

2.8 Print

File > Print 项打开 SaberDesigner 的 Print 对话框。该菜单项允许打印一个

窗口的整个内容，包括现在不在视图内的图形。有关设置打印的详细信息，参

阅在线 SaberBook 的 Printing (Help > SaberBook)以及 Installing Analogy
Products。

 要打印当前设计，鼠标左键单击 OK 按钮。

2.9 Print Window

File > Print Window 项打开 SaberDesigner Print 对话框。该菜单项允许打印

窗口的可视内容。

2.10 Export

在 SaberDesigner 的 Windows NT版本，Export > Enhanced Metafile 项将活

动窗口保存为 Windows Metafile 格式的文件。

2.11 Printer

在 SaberDesigner 的 UNIX 版本中，File > Printer项允许建立新的打印机配

置，从打印机清单中去掉一个打印机，或修改打印机的属性。有关设置打印机

的详细信息，参阅在线 SaberBook 的 Printing (Help > SaberBook)以及 Installing
Analogy Products。
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2.12 Most Recently Accessed Files

File 下拉菜单的底部，Exit 项上面，显示在 SaberSketch 工作面最近打开的

5 个窗口。

 单击鼠标左键，打开一个窗口。如果是一个已经打开的 Schematic 窗口，

则另外打开窗口的复制版本，并放在一叠窗口的顶层。SaberSketch 不

建立复制的 Symbol窗口。

2.13 Exit

File > Exit 项关闭 SaberDesigner 并返回到原始位置。SaberSketch提示保存

工作。

3. Edit

Edit 下拉菜单允许执行编辑操作，定制工作面外观、编辑器窗口的外观和

操作、以及 SaberGuide 表格的外观和操作。

3.1 SaberGuide

Edit > List/Alter Parameters 项打开 List/Alter Design 表格。有关填写该表格

的详细信息，参阅 Help > SaberBook 在线帮助(在 SaberBook 索引中键入 alter)，
或 Analyzing Designs Using SaberDesigner。

Edit > Saber/Netlister Preferences 项打开 Simulation/Netlisting Preferences 表
格。有关填写表格的详细信息，单击表格中的 Help 按钮。

3.2 Undo, Redo

Edit > Undo 项返回到任何刚完成的原理图或符号数据库操作。该项不在常
规窗口或 UI 操作系统中操作。为一级撤销。

Edit > Redo 项返回到选择 Undo 前的状态。为一级重复。
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3.3 Cut Copy Paste Delete

Cut、Copy、Paste 和 Delete 项对一个或多个数据库目标进行操作。因此，

如果打开了多个包含相同数据库目标的窗口，执行上述任何动作将影响每一个

包含数据库目标的窗口。

例如，如果打开多个包含一原理图的窗口，然后删除一条导线，该导线会

在每个窗口删除。

Edit > Cut 项切除选定的目标，并将其放到剪切板。

Edit > Copy 项将选定的目标放到剪切板。

Edit > Paste 项将剪切板的内容放到当前窗口。

Edit > Delete 项将当前选定内容从窗口删除。

3.4 Find/Select

Edit > Find/Select 项打开 Find/Select 对话框。该对话框在活动窗口找寻目

标。一旦找到目标，可以在编辑器窗口选择，以执行 SaberSketch操作。

3.4.1 Search Criteria
对话框中的 Search Criteria 部分允许以 Search Type 域和 Filter 域缩小查找

的选项。
Find 按钮根据 Search Criteria 中制定的选择开始查找过程。

Select 按钮选择在 Find/Select 滚动列表中高亮显示的 SaberSketch 窗口的所

有对象。

Deselect 按钮取消选择在 Find/Select 滚动列表中高亮显示的 SaberSketch 窗

口的所有对象。
Close 按钮关闭 Find/Select 对话框。

Search Type 域允许选择一项特定的查找，或在编辑器窗口对所有目标进行

查找。可以规定查找 Symbols、Properties、Wires、Graphics、Probes 或 All。找

到的目标将在对话框右侧的滚动列表里显示。

如果选择 Property，会出现 Property Name 域和 Show Value 按钮。特定的
属性名输入到 Property Name 域。Show Value 按钮在编辑器窗口切换属性值的显
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示与否。选择 Yes 打开显示，选择 No 关闭显示。

如果选择 Graphics，则是显现另一个域 Graphics Type。按下该域右侧的下
指箭头。将列出所有的可供搜索的图形目标。

在 Filter 域中可输入要查找的目标的名字或部件名，可用校准的通配符。

相匹配的目标将在对话框右侧的滚动列表显示。

3.4.2
找到的目标在对话框右侧的滚动列表显示。

 将鼠标光标放在列表中的某个目标上，高亮显示 SaberSketch 窗口中的

目标。

 将鼠标光标放在某个目标，单击鼠标左键高亮显示目标。

 对列表中高亮显示的目标按下 Select 按钮，在编辑器窗口选择目标，

以进行 SaberSketch操作。
 对列表中高亮显示的目标按下 Deselect 按钮，在编辑器窗口取消选择

目标，并将目标返回其正常状态。

3.5 Application Preferences

Edit > Application Preferences 对话框允许定制工作面的颜色和定制工作面

的文本。使用该对话框的详细信息参阅第二章的¡ Application Preferences”。

3.6 Schematic Preferences

Edit > Schematic Preferences 表格允许打开或关闭 DesignStar Help 屏幕、修

改扫视速度、修改区域选择标准、切换 AimDraw 自动重复功能、选择符号的图
形设置、修改连接选项以及定制 SaberSketch窗口中目标的颜色。

3.6.1
要应用新的优先选择，使用 Apply 按钮。新的优先选择将立即应用到工作

面。除非使用 Save 按钮，这种修改只对当前部分有效。

Close 按钮关闭对话框，并返回到工作面。
要将修改保存为 SaberDesigner 以后部分的有效选择，单击 Save 按钮。现

在，可以退出、返回并保留新的优先选择。

Defaults 按钮将优先选择设置为原始的缺省选择。

Reset 按钮返回工作面，回到当前部分打开的地方，或上一次应用 Apply
按钮的设置。
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3.6.2 Grid
Grid 表格允许修改 Symbol和 Schematic 编辑器窗口网格操作。

Color 域显示 SaberSketch窗口网格的颜色。

有两种方法在该域中修改颜色。

 键入需要的颜色名，单击 Apply按钮。

 单击 Rainbow按钮调出 Color Editor 窗口。有关编辑颜色的详细信息，

参阅在线 SaberBook Draw tool (Help > SaberBook)。
 Style 按钮允许修改网格的图形类型。

Grid Spacing 滑块允许确定网格的间距。

Snap Spacing 滑块允许确定俘获间距。

Display Grid 按钮切换网格的显示。

Apply to All 按钮允许将网格选择应用到所有 Schematics 和所有 Symbols 或
所有 Schematics 和 Symbols 中。

3.6.3 Symbol
Symbol 表格允许选择与符号相应的图形类型。可以选择 Default 或

European。
3.6.4 Wire

Wire 表格允许在 Schematic 窗口中修改导线。

Default Color 域显示导线颜色。
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在此有二种改变颜色的方法。

 键入想要的颜色，单击 Apply按钮。
 单击 Rainbow按钮，调出 Color Editor 窗口。有关编辑颜色的详细信息，

参阅在线 SaberBook Draw tool (Help > SaberBook)。
 Free End Circled 按钮切换未连接导线末端圆圈的显示。

Highlight Wire Name 按钮切换鼠标光标位于某条导线时的导线名的显示。

Prompt for Wire Name 按钮切换导线名选项。

 要想在每次创建一条新导线时提示输入导线名，按 Yes 按钮。

 要想给每条创建的导线指定电脑生成的名字，按 No 按钮。

Autoconnect with Move 按钮允许修改二个端口或二条导线的自动连接。%

 单击 Yes 按钮，打开自动接特性。

 单击 No 按钮，关闭自动连接特性。此时只得手动连接了。
 Highlight 按钮允许只高亮显示一条导线或与一节点连接的所有导线。

 Solder Dot 按钮允许将节点上的点显示为椭圆或矩形。%

3.6.5 Display
Display表格允许修改符号和原理图编辑器窗口的操作。

 Panning Speed 滑块允许调节扫示 SaberSketch 窗口的速度，有关扫视的详

细信息，请参阅第五章的¡ Panning¡。%

 Show DesignStar Message 按钮切换选择 File＞Open＞Design 项时显示的

Opening DesignStar Files 屏幕，选择 Yes 打开屏幕，选择 No 关闭屏幕。%
 Area Select 按钮允许以两种不同方式选择一个窗口中的几组目标。%

 通常，要选择几组目标，在键盘上按 Shift 键，同时按住鼠标左键不释

放并拖动，在想要选择的目标周围创建一个框。%

 如果想选择完全包括在框内或与框相接触的目标，按 Overlapping按钮。

 如果想选择完全被框包容的目标，而不选择与框相接触的目标，按

Enclosed 按钮。

 Selected Color 域显示 SaberSketch窗口中选定项的颜色。%

 Highlighted Color 域显示 SaberSketch窗口中高亮显示项的颜色。%

有两种方法改变这些域中的颜色。%

 键入想要的颜色名，单击 Apply按钮。%
 单击 Rainbow按钮，引出 Color Editor 窗口。有关编辑颜色的详细信息，

参阅在线 SaberBook 的 Draw tool（Help＞SaberBook）。%
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Drawing Tool Auto Repeat 按钮允许在每次图形操作后切换 AimDraw 工具的

重新设置。
 按 No 按钮，在每次图形操作后重新设置 AimDraw工具。%

 按 Yes 按钮，AimDraw 工具重复图形操作，不再重新设置。

4 View

View 下拉菜单允许在 SaberSketch 窗口周围航行，切换窗口网格，以及切
换 SaberGuide图标栏的显示。%

 Zoom to Fit 显示整个设计。%

 Zoom In提高放大倍数，显示更具体的细节。%

 Zoom Out 减少放大倍数，显示较少细节，但更多设计内容。%

Pan Left 允许查看当前显示设计左边看不见的设计部分。该命令只在水平

方向操作。

Pan Right 允许查看当前显示设计右边看不见的设计部分。该命令只在水平

方向操作。
Pan Up 允许查看当前显示设计上面看不见的设计部分。该命令只在垂向操

作。

 Pan Down允许查看当前显示设计下面看不见的设计部分。该命令只在垂向

操作。%

 Grid 切换窗口网格的显示。%
 Redraw刷新活动窗口。%

 Show Guide Icon Bar 切换工作面顶端的 SaberGuide 图标栏。%

 Show Netlister Transcript 切换 Netlister Transcript 窗口的显示。
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5 Design

Design 下拉菜单允许选择一个原理图作为当前设计，产生网络表和仿真当

前设计，并反标注操作点值。

 Use 项允许选择一个完整的功能原理图作为当前设计。当前设计可以产生

网络表和进行仿真。%

 Netlist design name 项允许手工对某设计产生网络表，而不启动仿真。必要

时，每次执行仿真通常都会出现网络表。
 Simulate design name 项允许产生必要的网络表，并对设计进行仿真。

 Back Annotate 项允许显示原理图中节点的ＤＣ操作点值。为了进行反标注，

必须具有设计名.ba 文件。每当设计产生网络表时，会产生一个设计名.ba 文件。

 Place Values 项显示原理图中相关节点的操作点值。

 Show/Hide Values 切换操作点值的显示。
 Delete Values 删除操作点值的显示。

 Automatic Font 项对显示的操作点值应用缺省字体、风格和尺寸。%

 Specified Font 项打开 Font Selection对话框，允许对显示的操作点值应用定

制字体、格式和尺寸。详细信息参阅下一章的“选择字体¡，使用 Font Selection
对话框部分。

6 Schematic

Schematic 下拉菜单可在活动原理图窗口中出现。

 Schematic 下拉菜单允许修改选择项的显示、获得和布置元件、创建导线、

创建线束、创建层次符号、处理原理图表、重新参照参考标号、插入文件信息
以及打开 Symbol Properties 对话框。

大部分 Schematic 下拉菜单项与 Schematic Editor 弹出菜单项一样。有关
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Rotate、Flip、Get Part、Create、Multi-Sheet、Re-reference、Annotate Info 和 Symbol
Properties 的详细信息，请参阅下一章的¡ Schematic Editor弹出菜单”。
 Schematic＞Back 目标将选定的目标移到一叠目标的后面。

 Schematic＞Front 目标将选定的目标移到一叠目标的前面。

7 Symbol

Symbol下拉菜单可在活动符号窗口中出现。

 Symbol 下拉菜单允许修改选定项的显示、修改符号原点、创建端口、创建

层次符号的原理图、修改符号视图、添加反标注，以及打开 Symbol Properties
对话框。%

 Symbol下拉菜单项的大部分与 Symbol Editor弹出菜单项一样。有关 Rotate、
Flip、Scale、Origin、Graphics、Port、Create Hierarchical Schematic、Symbol View、
Annotate Info 和 Symbol Properties 的详细信息，参阅下一章的¡ Symbol Editor
弹出菜单¡。%
 Symbol＞Back 目标将选定目标移到一叠窗口的后面。%

 Symbol＞Front 目标将选定目标移到一叠窗口的前面。

8 Probe

有关 Probe 下拉菜单和测试，参阅在线 SaberBook 的 Probing(Help＞
SaberBook)。

9 Tools

 Tools 下拉菜单允许访问屏幕下方的以图标形式显示的 Saber Designer
Tools。每个工具的功能详细信息，参阅 Tool章节。

10 Window

 Window下拉菜单允许在工作面上管理多个窗口。有关该下拉菜单的详细信

息，参阅第二章的¡ Window下拉菜单¡。
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11 Help

 Help 下拉菜单对不同的 SaberDesigner 属性提供帮助。有关使用 Help 菜单

的详细信息，参阅第二章的¡ Help 下拉菜单”。
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 SaberSketch Editor

本章包括下列主要内容：%

 常规操作%

 符号编辑器窗口%

 原理图编辑器窗口

1.

 SaberSketch Editor 窗口由 Symbol Editor 窗口和 Schematic Editor窗口构成，

符号和原理图在这些窗口中创建、显示和操作。

 Symbols 是原理图的构件。可以选择现有的符号，创建定制符号，将其放

置在 Parts Gallery中，或修改现有符号。
 Schematics 是设计的构件。一个原理图由通过导线连接的元器件构成。可

以是顶级线路，或仅仅是一个完整的功能性线路的一部分。原理图可以包含以

层次方式与其相连接的子原理图。原理图可以查看几个图表（象一个书面原理

图）。布置在原理图内的元件和导线由 SaberSketch自动指定参考标号。%

Design 是完全功能性的线路。设计可以包括多个层次原理图，或一个原理
图。可以在设计上运行一次 Saber 仿真，以检查其是否按预定期望工作，在

SaberSketch中进行测试，以及在 SaberScope 中进行更具体的测试和分析。

1.1

在窗口放置元件，为元件指定属性，将元件连接起来，从而创建原理图。

建立原理图的基本步骤如下：%
１. 从 Parts Gallery选择元件，或创建元件。有关 Parts Gallery的详细信息，

参阅在线 SaberBook 的 Parts Gallery (Help＞SaberBook)。有关在 Symbol窗口创

建元件的详细信息，参阅后面的¡ Symbol Editor 窗口”。

２. 在窗口布置元件，并将其移动大致的最终位置。SaberSketch 自动生成

参考标号。
３. 为元件指定必要的元件属性。有关指定属性的详细信息，参阅在线

SaberBook 的 Property Editor(Help＞SaberBook)。
４. 连接元件。可以移动元件直至端口相互接触，或用导线连接端口。不

同元件导线的颜色不同。可以用 Wire 弹出式菜单修改导线颜色。有关该菜单的

详细信息，参阅后面的¡ Wire 弹出菜单”。

1.2

可以创建一个包括了复杂原理图的功能块符号。这些原理图可以包含通向

其他层次间子原理图的其他功能块。%
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新的功能块符号可以象任何其他元件一样放置入原理图。

1.2.1
在 Symbol Editor 窗口中，Symbol Editor＞Create＞Hierarchical Schematic 弹

出式菜单允许创建一个原理图块，以表示符号的功能性。%

原理图窗口以与刚才操作的符号同样的名字打开，符号的端口转换为原理

图中的层次连接符。可以创建新的原理图，使用层次连接符作为输入、输出，

这就允许进行自顶向下的设计。

1.2.2
在 Schematic Editor 窗口，Schematic Editor＞Create＞Hierarchical Symbol弹

出式菜单允许创建一个符号来表示原理图模块的功能。为了转换为符号，原理

图模块必须具有层次连接符作为输入和输出。层次连接符从 Parts Gallery选择。

 Symbol 窗口用与刚才操作的原理图同样的名字打开。原理图的层次连接符
和所有相同的连接符属性显示为端口。可以使用符号端口作为输入和输出创建

新的符号。

1.2.3
在 Property Editor 对话框中，在 Primitive Value 域中键入空值，可以为同名

的层次符号指定原理图。
大多数符号的原始值是锁住的，不能编辑。Value 域输入与特定的模板有关。

如果是创建自己的符号，则可创建一个可以编辑的原始值。有关 Property Editor
对话框的详细信息，参阅在线 SaberBook 的 Property Editor(Help＞SaberBook)。

一种为符号指定原理图的方法执行步骤如下：%

１. 在 Schematic editor 窗口创建原理图，并存为想要的名。%

２. 在 Symbol editor 窗口创建符号，并存为与原理图相同的名。%

３. 打开 Property Editor对话框，使用Options＞Add Property对话框。在Name
域键入原始值，在 Value 域键入空值，按 Apply 按钮。%

４. 退出 Property Editor 对话框。

1.3

在工作面显示原理图或符号，参阅前一章的¡ File 下拉菜单¡。

1.4

 将鼠标光标放在预定目标上，选择单个目标，单击鼠标左键。%

有几种方法在 SaberSketch窗口中选择多个目标。%

 要选择一组目标，在键盘上按 Shift 键，同时按住并拖动鼠标左键，在
想要选择的目标周围建一个框。释放鼠标左键，选择一组目标。%

 要选择多个单独的目标，在键盘上按 Shift 键，然后逐个单击想要选择

的目标。单击已选择的目标，取消选择。

1.5

有几种方法可以在 SaberSketch缩放，但所有的方法都要用到缩放栈。缩放

栈记忆上一次缩放的比例。拉近或拉远窗口时，SaberSketch 使用缩放栈，直到
到达栈的末端。到达栈的末端后，按缺省增量执行缩放。
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1.5.1
拉近某一区域，增加放大倍数，以显示更具体的细节。有几种方法可以拉

近。

 使用下拉菜单栏的 View＞Zoom In项拉近窗口的中央部分。

 单击图标栏中的 Zoom In图标拉近窗口的中央部分。

 将鼠标光标放在想要拉近部分的一角。按住鼠标左键，并移动鼠标，

在想要放大的区域周围创建一个方框。释放鼠标键以拉近。

1.5.2
拉远某一区域，缩小放大倍数，显示更少细节，但更多内容。有几种方法

拉远。

 使用下拉菜单中的 View＞Zoom Out 项，拉远窗口的中央部分。

 单击图标栏中的 Zoom Out 图表，拉远窗口的中央部分。
1.5.3

缩放成窗口大小显示窗口中的所有目标。有几种方法可以缩放成窗口大小。

 使用下拉菜单栏中的 View＞Zoom to Fit 项。

 单击图标栏中的 Zoom to Fit 图标。

1.6

扫视允许查看当前窗口视图看不见的图像部分。%

 使用下拉菜单栏中的 View＞Pan Right/Left/Up/Down项，拉远窗口的中

央部分。

 将鼠标光标放在编辑器窗口内的任一地方。按压鼠标中键，左/右/上/下
移动鼠标进行扫视。释放鼠标键以停止扫视。

 使用键盘上的箭头键。

 使用窗口上的滚动条。

1.7

在 Symbol 和 Schematic 窗口中有弹出菜单。

 高亮显示目标然后按压鼠标右键以打开弹出菜单。

 将鼠标光标放在某项上并释放鼠标按钮，以激活弹出菜单中的该项。
有关每个窗口弹出菜单的详细信息，参阅随后的¡ Symbol Editor 窗口弹出

菜单”和¡ Schematic 窗口弹出菜单¡。

2 Symbol Editor

符号是原理图窗口中布置元件的图形表示。符号的属性叙述其代表元件的

特性。

SaberSketch符号元件可由扩展名.ai-sym 区分。

Symbol 窗口是编辑现有符号或创建新符号的地方。Symbol 窗口在窗口上方

标记。Symbol 窗口中的弹出菜单提供编辑/创建符号的工具。有关弹出菜单使

用的详细信息，参阅随后的¡ Symbol Editor 窗口弹出菜单¡。%
可以打开一个新的符号窗口创建新的符号，或打开现有的符号窗口编辑现
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有符号。%

 使用 File＞New＞Symbol下拉菜单项创建新符号。
有几种方法打开 Symbol窗口编辑现有符号。%

 使用 File＞Open＞Symbol下拉菜单项。%

 在 Schematic 窗口高亮显示符号，使用 Symbol＞Enter Sym Editor 弹出

菜单项。

 使用 File＞New＞Symbol 下拉菜单项打开新的符号窗口。然后在窗口布

置来自 Parts Gallery的符号。

2.1 Sybol Editor

 Symbol窗口有下列弹出菜单。
 Symbol Editor
 Port
 Origin
 AimDraw

2.1.1 Symbol Editor
 打开 Symbol Editor 弹出菜单，在 Symbol窗口中将鼠标光标放在任何空

白处。然后按压鼠标右键。%

 Symbol Editor＞Undo 项撤消刚完成的任何动作。%

 Symbol Editor＞Redo 项回到选择 Undo 前的状态。%

 Symbol Editor＞Cut 项删除选定的目标并将其移到剪切板。%

 Symbol Editor＞Copy项将选定的目标复制到剪切板上。%

 Symbol Editor＞Paste 项将剪切板上的内容粘贴到现用 Symbol 窗口。%

 Symbol Editor＞Delete 项从 Symbol窗口取消当前选定项。%

 Symbol Editor＞Rotate 项允许将选定目标进行 90°、180°或 270°旋转。
 Symbol Editor＞Flip 项允许用 Up-Down 项在水平面反射选定目标，或用

Left-Right 项在垂向面反射图像。%

 Symbol Editor＞Scale 项允许修改选定图形目标的尺寸。%

 打开 Symbol Editor 弹出菜单，单击 Scale 项。%

 键入标度，单击 OK 按钮。缺省值是 1.0。如果想要图形加大，键入一
个比 1.0 大的值。要想图形缩小，键入比 1.0 小的值。允许小数值。

 Symbol Editor＞Origin 项和 Origin 弹出菜单操作相同。有关详细信息参阅

随后的¡ Origin 弹出菜单¡。%

 Symbol Editor＞Create＞Graphics 项打开 AimDraw 工具。有关 AimDraw 操

作的详细信息，参阅在线 SaberBook 的 Draw tool (Help＞SaberBook)。
 Symbol Editor＞Create＞Port 项允许在 Symbol窗口布置一个 Analog、Input、
Output 或 BiDirectional 端口。%

 Symbol Editor＞Create＞Hierarchical Schematic 项允许创建一个原理图块来

表示符号的功能性。Schematic 窗口以刚才工作过的符号名打开，显示从符号引

出的端口，也具有相同的特性。

 Symbol Editor＞Symbol View 项打开 Edit View 格式。该格式允许修改、创

建或删除与符号相关联的图形类型。可以选择 Default 或 European。
执行 Apply按钮保存修改。

 Close 按钮退出 Edit View格式。
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 Modify键允许选择一个不同的视图，修改视图名，以及编辑视图描述。

 View Name 域显示在滚动视图列表中高亮显示的视图名。
 修改视图后，删除显示名，键入新名字并按 Apply 按钮。在滚动视图列

表中高亮显示名也会改变。

 Description域允许修改视图描述。

 修改视图描述，删除希望修改的显示的描述相对应的元件，键入新的描

述，按 Apply按钮。

Create 键允许给视图表添加新的视图。

 要给视图列表添加新的视图，在 View Name 域中键入名字，按 Apply
按钮。

 要给新视图名添加描述，在 Description域中键入描述，按 Apply 按钮。

Delete 键允许从视图表中删除视图。
 要从视图表删除视图，高亮显示滚动视图中的视图名，按 Apply按钮。

Symbol Editor＞Annotate Info 项打开 Text Variables 对话框。该对话框允许

在 Symbol窗口插入符号文件信息显示。

 要在 Symbol窗口插入文件信息，在想要显示的域附近按 Insert 按钮。

文件最后修改时， Last Modified 按钮插入日期。
 Filename 按钮插入文件名。

 Sheet Number 为原理图的页数插入一个变量。有利于在原理图边界自动更

新 X 域 X 页。

 Sheet Count Field 插入一个原理图总页数变量。有利于在原理图边界自动更

新 X 域 X 页。

Symbol Editor＞Symbol Properties 项打开 Property Editor对话框。该对话框

允许修改与符号相关的属性。有关 Property Editor 对话框的详细内容，参阅在

线 SaberBook 的 Property Editor (Help＞SaberBook)。
2.1.2 Port

 要打开 Port 弹出菜单，将鼠标光标放在一端口上。然后按压鼠标右键。
Port＞Change Type 菜单项修改端口类型。选择 Analog、Input、Output 或

BiDirectional。
 Port＞Back 项将端口移到一叠目标的后面。

 Port＞Front 项将端口移到一叠目标的前面。

 Port＞Delete 项从 Symbol窗口删除端口。
 Port＞Attributes 项打开 Port Attributes 对话框。

Port Attributes 对话框%
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Name 域显示与端口相关的名字。

 要修改名字，删除旧名并键入新名。
Type 域显示端口类型。%

 要修改端口类型，单击下指箭头。然后单击 Input、Output、Analog 或

BiDirectional。
Color 域显示选定端口的颜色。有两种方法在该域中修改颜色。%

 键入想要的颜色，单击ＯＫ按钮。%

 单击 Rainbow按钮引出 Color Editor 对话框。有关编辑颜色的详细信息，

参阅在线 SaberBook 的 Draw tool (Help＞SaberBook)。%

 Font 域显示选定端口的文本字体。有两种方法修改该域中的字体。%

 键入想要的字体名后，单击ＯＫ按钮。%

 单击ＡＢＣ按钮带出 Font Selection 对话框。选择字体有关信息参阅在
线 SaberBook 的 Draw tool (Help＞SaberBook)。%

 Anchor Field 允许修改端口标签的布置。%

 Display Name 按钮切换 Symbol 窗口 Name 域中名字的显示。%

 Invisible Port 按钮切换原理图窗口中端口的可视与否。%

 Apply 按钮将修改应用到端口。%
 Close 按钮应用任何作出的修改，并退出 Ports Attributes 对话框。%

 Reset 按钮将域退回到上次保存的设置。

2.1.3 Origin
原点是原理图中符号布置的“锚¡。符号布置在某一特定位置时，是布置在

原点上。符号图形布置在与原点相关之处。%

原点十字标的缺省位置在符号的中央。如果移动原点，符号对称于原点布

置。

例如，如果将原点十字标移到符号图形左侧，符号将放置在原理图窗口原

点的右侧。

 要移动原点十字标，将鼠标光标放在十字标上，然后按下并拖动鼠标，

将十字标移到新的位置。
 原点十字标位于预期位置时释放鼠标按钮。原点跳到最近的校准点。%

Origin 弹出菜单允许自动定位或隐藏原点十字标。%

 要打开 Origin 弹出菜单，将鼠标光标放在原点十字标上。然后按压鼠标

右键。

Origin＞Center 项将原点放在符号图形中央。%
 Origin＞Center Ｘ项将原点放在符号端口Ｘ轴的中央。%

 Origin＞Center Ｙ项将原点放在符号端口Ｙ轴的中央。%

 Origin＞（０，０）项将原点放在坐标（０，０）。%

 Origin＞Hide 项隐藏在原点十字标。原点仍然决定原理图窗口中符号的位

置。
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2.1.4 AimDraw
 要打开 AimDraw 弹出菜单，将鼠标光标放在某图形上。然后按压鼠标

右键。

AimDraw 弹出菜单允许编辑窗口图形。可以修改选定图形目标的属性，旋

转、翻转，将其放在一叠图形前面或后面、或删除。%
 AimDraw＞Attributes 项打开 AimDraw Attributes 对话框。对话框允许修改

选定图形目标的属性，如颜色、线宽、填充、字体等。每个图形目标的 Attributes
对话框稍有不同。详细信息参阅在线 SaberBook 的 Draw tool (Help ＞

SaberBook)。
 AimDraw＞Rotate 项允许９０°、１８０°或２７０°旋转某图形目标。
 AimDraw＞Flip 项允许选择 Up-Down项水平向反射图形目标，或选择 Left-
Right 项垂向反射图像。%

 AimDraw＞Back 项将图形降到一叠目标底部。%

 AimDraw＞Front 项将图形提到一叠目标顶部。%

 AimDraw＞Delete 项永久删除 AimDraw弹出菜单操作的图形。
2.1.5 Property
 Property Menu＞Symbol Properties 项打开 Property Editor 对话框。有关对话

框的详细信息参阅在线 SaberBook 的 Property Editor (Help＞SaberBook)。
2.1.6 Schematic Editor

原理图包括构成电路的元件及其连接导线。原理图可以是单个顶级原理图
或层次原理图的一部分。%

有关创建层次原理图的详细信息，参阅本章的¡ 创建层次原理图¡。%

设计是一个完整的功能性原理图，可以产生网络表和进行仿真。任何时候

都只能有一个现用设计。

 要使某原理图成为现用设计，选择 Design＞Use 下拉菜单项。%
SaberSketch原理图文件可由扩展名.ai_sch区分。%

 DesignStar 原理图可在 SaberSketch 中打开。保存 DesignStar 原理图时，将

保存为 SaberSketch 原理图，但原始的 DesignStar 原理图不会被 SaberSketch 格

式覆盖。%

在 Schematic 窗口中可以编辑现有原理图，创建新原理图以及通过测试分
析仿真。原理图性质上可以是分层的。大的原理图可以分布在几张纸上（和书

面文件类似），以提高清晰度。图形窗口在窗口顶部标记。Schematic 窗口的弹

出菜单提供编辑 /创建原理图的工具。有关使用弹出菜单的详细信息，参阅随后

的"Schematic 窗口弹出菜单¡。%

可以打开一个新的原理图窗口、创建新的原理图，或打开现有的原理图窗

口编辑现有的原理图。%

 使用 File＞New＞Design 下拉菜单项创建新的原理图。%

有几种方法打开 Schematic 窗口编辑现有原理图。%



35

 使用 File＞Open＞Design 下拉菜单项。%

 高亮显示 Schematic 窗口的层次元件，使用 Symbol＞Open Hierarchy 弹
出菜单项。

2.2  Schematic

 Schematic 窗口有下列弹出菜单。%
 Schematic Editor
 Symbol
 Wire
 Bundle
 AimDraw
 Probe

2.2.1 Schematic Editor
 打开 Schematic Editor 弹出菜单，将鼠标光标放在 Schematic 窗口中的任

何空白处。然后按压鼠标右键。

 Schematic Editor＞Undo 项回到上一次的编辑操作。%
 Schematic Editor＞Redo 项回到选择 Undo 前执行的编辑。%

 Schematic Editor＞Cut 项删除选定目标，并将其移到剪切板上。%

 Schematic Editor＞Copy项将选定目标复制到剪切板上。%

 Schematic Editor＞Paste项将剪切板的内容粘贴到活动窗口。%

 Schematic Editor＞Delete项将当前选定项从窗口删除。%

 Schematic Editor＞Rotate项允许 90°、180°或 270¡ 旋转选定目标。%

 Schematic Editor＞Flip 项允许通过 Up-Down 项在水平面反射图形目标，或

通过 Left-Right 项在垂向反射图形目标。%

 Schematic Editor＞Get Part项允许从 Parts Gallery或Get and place Symbol By
Name 对话框获得元件。%

 打开 Parts Gallery选择 Parts Gallery 项。有关 Parts Gallery 操作的详细

信息，参阅在线 SaberBook 的 Parts Gallery (Help＞SaberBook)。
 打开 Get and Place Symbol By Name 对话框选择 Symbol项。%

Get and Place Symbol By Name 对话框允许通过名字找到符号，将其放在原

理图上，而且如果必要，还可以添加到 Parts Gallery。

 Symbol域允许键入符号名，放置在窗口里。%

如果不知道符号名，单击 Browse 按钮打开 Select Symbol 对话框。使用对

话框的详细信息，参阅第二章的“打开 File 对话框¡。%

 Add to Parts Gallery按钮允许将 Symbol域中选定的元件添加到 Parts Gallery
的 users 目录。
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 Place 按钮将 Symbol域中选定的元件放置到窗口中。%

 Close 按钮关闭对话框，返回到工作面。%
 Parts Gallery按钮打开 Parts Gallery工具。%

 Schematic Editor＞Create＞Wire 项允许创建新的导线。鼠标光标转变为十

字标，用来定位新导线。有关布线的详细信息，参阅随后的¡ Wire弹出菜单”。

 Schematic Editor＞Create＞Bundle 项允许创建一束导线。线束的详细信息

参阅随后的¡ Bundle 弹出菜单¡。%

 Schematic Editor＞Create＞Hierarchical Symbol项允许创建一个符号来表示

原理框图的功能性。Symbol 窗口的打开，其名字与刚操作过的原理图同名。显

示原理图的层次端口以及所有相同的属性。%

 Schematic Editor＞Multi-Sheet 项允许将一个原理图分布在多个图纸上（与

书面文件相同），以方便组织。%
 Add 项打开一个新的按顺序排列的 Schematic editor 窗口。%

 Display 项打开 Schematic Sheets 对话框。该对话框显示所有与现用原理图

相关的图纸。可以从列表中选择图纸，并在 SaberSketch工作面上显示。

 Rename 项允许重命名现有图纸。%

 Delete 项删除现用图纸。删除前图纸必须是空白的。%
 Schematic Editor＞Re-Reference 项重新指定原理图的参考标号。布置元件

和布线时 SaberSketch自动生成参考标号。%

 Schematic Editor＞Annotate Info 项打开 Text Variables对话框。该对话框允

许将原理图文件信息的显示插入 Schematic 窗口。%

 将文件信息插入 Schematic 窗口，在想要显示的域附近按 Insert 按钮。

Last Modified 按钮插入上次修改文件的日期。%

 Filename 按钮插入文件名。%

 Sheet Number 按钮插入正在查阅图纸的页数。%

 Sheet Count 按钮插入正在查阅图纸的总页数。%

 Schematic Editor＞Symbol Properties 项打开 Property Editor对话框。该对话
框允许修改

与选定符号相关的属性。有关 Property Editor 对话框的详细信息，参阅在线

SaberBook 的 Property Editor（Help＞SaberBook）。
2.2.2 Symbol

 要打开 Symbol 弹出菜单，将鼠标光标放在某元件符号上。然后按压鼠
标右键。

Symbol＞Symbol Properties 项打开 Property Editor 对话框。该对话框允许修

改与符号相关的属性。有关详细信息参阅在线 SaberBook 的 Property Editor (Help
＞SaberBook)。%

 Symbol＞Open Hierarchy 项允许打开另一个包括层次元件的下层原理图的

Schematic 窗口。创建层次原理图的详细信息，参阅前面的“创建层次原理图”。

 Symbol＞View Template 项打开 Viewing Template 窗口，允许查看该符号的

基本模板。模板不能在该窗口中进行编辑。有关该窗口的详细操作，参阅在线

SaberBook 的 Parts Gallery＞Buttons＞Template button。
 Symbol＞Symbol Editor项允许打开新的 Symbol窗口编辑该符号。

 Symbol＞Rotate 项允许 90°、180°或 270°旋转符号。

 Symbol＞Flip 项允许通过 Up-Down 项在水平面反射符号图形，或通过
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Left-Right 项在垂向反射图形。

 Symbol＞Back 项将符号移到一叠目标的后面。
 Symbol＞Front 项将符号移到一叠目标的前面。

 Symbol＞Symbol View 项打开 Views 滚动列表。该列表允许选择与符号相

关的图像类型。可选择 Default 或 European。%

 Symbol＞Delete 项从 Schematic 删除某项。

2.2.3 Wire
导线是元件之间的连接。不同元件其所有导线的颜色也不同，这些颜色可

以在该弹出菜单修改。所有导线都有名字加以区分。%

导线由名字进行连接。原理图一侧的某条导线与原理图另一侧的同名导线

认为是同一条导线。

 要打开 Wire 弹出菜单，将鼠标光标放在某导线上，然后按压鼠标右键。
导线具有一自由端时，可用 Rewire 和 Create Wire 项激活另一个 Wire 弹出

菜单。

 要打开另一个 Wire 弹出菜单，按压鼠标右键。

Delete Segment 项删除导线的上一段。

 Done 项终止导线末端，不与节点或端点相连。
 Cancel项取消布线操作。

 Wire＞Rewire 项允许在某一端切断导线，将其与另一节点连接。

 要移动导线，单击一端点，移动导线终端。

 要修改导线方向，单击鼠标左键。

 要将导线末端连接到一个节点或端口，单击鼠标左键。

 要中断导线末端而不进行连接，双击鼠标左键。

 要取消布线操作，在键盘上按 Escape 键，或按鼠标右键带出另一个 Wire
弹出菜单，然后选择 Cancel 项。

 Wire＞Create Wire 项创建一条新的导线，一端连接到选定导线，一端可自

由连接到另一点。移动并连接导线，参阅 Wire＞Rewire 项。%
 Wire＞Probe 项在 Schematic 编辑器窗口创建新的探头，与 Wire 弹出菜单

激活处的导线相连。%

 Wire＞Plot in Scope 项打开 SaberScope Waveform Analyzer，并从该导线绘

制信号。%

 Last Probe Plotfile 项打开 SaberScope，绘制装入作试验的上一次绘图文件。
 Last Simulation项打开 SaberScope，绘制最近一次 Saber 仿真的上次绘制文

件。%

 Select File 项打开 Select Plotfiles对话框。该对话框允许选择一个绘图文件，

在 SaberScope 中绘图。一旦选择了一个绘图文件，SaberScope 就启动了，绘图

文件完成。%

 Wire＞Delete 项从 Schematic 窗口删除导线。%

 Wire＞Attributes 项打开 Wire Attributes 对话框。
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Wire Attributes对话框%

Wire Attributes对话框允许修改现有导线的显示属性。

 Selected Wires 滚动栏显示所有选定导线。%
 Apply to 域允许选择该对话框中进行了操作的导线。%

 要查看选择选项，单击下指箭头。

Single Wire 项将修改应用到某一条选定导线。%

 Selected Wires 项将修改应用到所有选定的导线。%

 All Wires 项将修改应用到原理图中的所有导线。%

 Name 域显示滚动栏中现用导线名。可以在该域中编辑导线名。%

 Display Name 按钮在原理图窗口切换导线名的显示。%

 Name Rotation按钮允许垂向或横向显示导线名。%

 Free End Circled 按钮切换导线端圆圈的显示，该导线没有连接，也未在某

端点完结。
 Color 域显示选定导线的颜色。有两种方法在该域中修改颜色。%

 键入需要的颜色名，单击ＯＫ按钮。%

 单击 Rainbow 按钮，带出 Color Editor 对话框。有关编辑颜色的详细信

息，参阅在线 SaberBook 的 Draw tool (Help＞SaberBook)。%

 Style 按钮允许修改描述导线行的风格。%
Ends 按钮允许在导线末端加箭头。%
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Edit Arrow Head Attributes按钮打开 Arrow Attributes for Wires 对话框。使用

滚动条设置箭头端的基数、长度和宽度。Close 按钮关闭对话框，保留新的设置。
Reset 按钮将域返回到上一次保存的设置。%

 Apply 按钮将修改应用到导线。%

 Close 按钮应用任何所作的修改，并退出 Wire Attributes 对话框。%

 Reset 按钮将域退回到上一次保存的设置。

2.2.4 Bundle
线束是成组的导线，可能相连或不相连。线束显示为一根的粗的图形直线。

线束和导线的处理相同。导线末端可从线束的任何部分伸出。使用线束可缓解

原理图拥挤。%

 单击图标栏的 Bundle 图标创建线束。%

使用 Bundle 弹出式菜单修改线束属性，查看线束中的导线，将导线添加到

线束，并从线束删除导线。

 打开 Bundle 弹出式菜单，将鼠标光标放在线束。按压鼠标右键。

Bundle＞Delete 项从线束删除导线。

 Bundle＞Create Wire 项将导线添加到线束。如果线束有多个导线，则显示

Wires In a Bundle 对话框。
Wires In a Bundle 对话框%

Wires In a Bundle 对话框允许在线束中创建一条新导线，或在线束中连接现

有导线。%

滚动栏显示线束中的所有导线，以及创建一条新导线的选项。%

 要创建新的导线，从滚动栏中选择〈new〉项，单击ＯＫ按钮。

 要连接一条现有导线，从滚动栏中选择导线名，单击ＯＫ按钮。

这些导线可以象未成束的导线一样布线和连接。有关布线的详细信息，参

阅前面的¡ Wire 弹出菜单¡。%

 Cancel按钮关闭对话框而不创建任何导线。%

 Bundle＞Attributes 项打开 Bundle Attributes 对话框。

Bundle Attributes 对话框%
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Bundle Attributes 对话框允许查看线束中所有导线，并修改线束属性的显

示。

 Wire In this Bundle 滚动栏显示线束中所有的导线名。将鼠标光标放在栏中
的一条导线名上将高亮显示原理图中的导线。%

 Color 域显示选定线束的颜色。有两种方法修改域中的颜色。

 键入想要的颜色名，单击ＯＫ键。%

 单击 Rainbow按钮带出 Color Editor 对话框。有关编辑颜色的详细信息，

参阅在线 SaberBook 的 Draw tool (Help＞SaberBook)。
Style 按钮允许修改描述线束行的风格。%

 Ends 按钮允许在线束末端加上箭头。%

 Edit Arrow Head Attributes 按钮打开 Arrow Attributes for Bundles 对话框。有

关该对话框操作的详细信息见上文。%

 Apply 按钮将修改应用到线束。%
 Close 按钮应用所做的任何修改，并退出 Bundle Attributes 对话框。%

 Reset 按钮将域返回到上一次保存的设置。

2.2.5 AimDraw
 要打开 AimDraw 弹出菜单，将鼠标光标放在一图形目标上，然后按压

鼠标右键。有关该菜单的详细信息，参阅上文的¡ AimDraw 弹出菜单”。
2.2.6 Probe

要打开 Probe 弹出菜单，将鼠标光标放在一个探头上。然后按压鼠标右键。

有关该弹出菜单的详细情况，参阅在线 SaberBook 的 Probing (Help ＞

SaberBook)。
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SaberScope

本章包括下列主要内容：%

 常规操作%

 File 下拉菜单%

 Edit 下拉菜单%

 Graph下拉菜单%

 Tools 菜单%

 Window菜单%

 Help 菜单%

1

下拉菜单栏在工作面顶部运行。%

 SaberScope 可在与 SaberGuide 同样的工作面操作。此时，两种 SaberDesigner
的应用程序将共用下拉菜单栏，并共用一些下拉菜单。

 Analyses、Extract 和 Results 菜单只在 SaberGuide 中运行。Graph 菜单只在

SaberScope 运行。File、Edit、Tools、Window 和 Help 菜单可在 SaberGuide 和
SaberScope 运行。

打开下拉菜单的步骤如下：

1． 将鼠标光标放在菜单名上，高亮显示菜单名。%

2． 在高亮显示名上单击鼠标左键，打开菜单。

在下拉菜单中栏中激活某一项的步骤如下：

1． 将光标放在项上，高亮显示该项。

2． 单击鼠标左键，激活该项。

包含级联菜单中的下拉菜单项在项的右侧有一个箭头。

 要显示级联菜单，将光标移到带箭头的项上。

 要找出下拉菜单项的功能，将光标放在该项上。有关该项的简短说明将

出现在 Saber Designer 工作面底部的 Help 域。
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1.1

可以打开下拉菜单，将其移到屏幕的另一部分，并一直显示到使用完毕。

 1．将光标放在菜单上，高亮显示菜单名。

 2. 在高亮显示的菜单上按压鼠标中键。%

 3．将显示的下拉菜单移到预期的位置。

 4. 释放鼠标键放置菜单。%

将撕离菜单返回到正常控制的步骤如下：%

１. 将鼠标光标放在菜单名上，高亮显示下拉菜单栏中的菜单名。%

２. 单击鼠标左键。

2 File

 File 下拉菜单允许打开现有文件，将工作保存为新文件，创建新窗口，保

存配置设置。打开打印对话框以及退出 SaberDesigner。

2.1 New

 File＞New 项打开新的图形窗口，格式化为Ｘ¡ Ｙ轴图形。

2.2 Open

 File＞Open项打开现有的绘图、图形或外形文件。有关使用 Open File 对话

框的详细信息，参阅第二章的“打开 File 对话框¡。%

绘图文件包含 Saber 仿真器分析的数据显示。%

图形文件包含图形窗口显示的所有信息，包括显示的信号和以绘图工具或

测量工具所作的任何附加内容。%

外形文件包括除显示信号外文件窗口显示的所有信息。任何绘图工具或测

量工作所作的附加内容都包括在 Outline 文件中。

2.3 Close

 File＞Close 项关闭当前设计，或现用的 Graph 窗口。
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2.4 Save

 File＞Save 项将当前显示的图形窗口保存为图形文件或外形文件。

 File＞Save＞Graph项将当前显示的图形窗口保存为图形文件。

 File＞Save＞Outline 项将当前显示的文件窗口保存为外形文件。

2.5 Configuration

 File＞Configuration 项允许立即或退出 SaberDesigner 时保存工作面配置。

有关该项的详细信息参阅第二章的¡ 配置¡。

2.6 Print

选择 Print 打开 SaberDesigner 打印对话框。有关设置打印的详细信息，参
阅在线 SaberBook（Help＞SaberBook）打印以及安装 Analogy产品。%

 要打印当前图形，以鼠标左键单击ＯＫ键。

2.7 Export

 SaberDesigner 的 Windows NT版本中，Export＞Enhanced Metafile 项将现用
窗口保存为 Windows Metafile 格式的文件。

2.8 Printer

在 SaberDesigner 的ＵＮＩX 版本中，File＞Printer 项允许创建新的打印机

配置，从打印机序列中取消某打印机，或修改打印机的属性。有关设置打印的

详细信息，参阅在线 SaberBook 的 Printing (Help＞SaberBook) 以及安装 Analogy
产品。

2.9 Exit

 File＞Exit 项关闭 SaberDesigner，返回到外壳，不保存任何信息。%
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如果想保存图形信息，必须在退出前选择 File＞Save 项，或 Edit＞Application
Preference＞Save Configuration on Exit＞Yes项，或选择File＞Configuration＞Save
on Exit 项。

3. Edit

 Edit 下拉菜单允许执行编辑操作，定制工作面的外观、图形窗口的外观和

操作，以及 SaberGuide 格式的外观和操作。

3.1 Cut Copy Paste

 Cut 项删除选定目标，并将其移到剪贴板。%

 Copy 项将现用图形窗口中的选定目标复制到剪贴板。%

 Paste 项将剪贴板上的内容粘贴到现用的图形窗口。

3.2 Application Preferences

 Edit＞Application Preferences 对话框允许定制工作面的颜色和文本。有关该

对话框的详细信息，参阅第二章的¡ Application Preferences¡。

3.3 Graph Preferences

 Edit＞Graph Preferences 对话框允许定制所有的图形窗口。可以修改颜色、

文本、布局和操作。

3.3.1
图形优先权由其相应的对话框或按钮选择。这些选择必须应用到图形窗口。

要应用新的优先权，单击 Apply 按钮。新的优先权将被立即应用到所有图

形窗口。除非使用 Save 按钮，该修改只应用于当前 SaberScope 对话。%

要在 SaberScope 对话之间保存修改，单击 Save 按钮。现在，可以退出

SaberScope、返回，并保留新的优先权。%

 Defaults 按钮将优先权设置为原始的 SaberScope 缺省选择。%

 Reset 按钮将工作面返回到当前对话打开时的设置，或上一次应用 Apply 按

钮时的设置。

 Close 按钮关闭对话框，返回工作面。
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3.3.2

图形颜色%

颜色可以在 Foreground、Highlight、Background 1、Background 2和 Signals
中修改。

Foreground 包括所有显示的文本、图形外形、网格和符号。%

 Highlight 包括以鼠标光标选择的显示为反向视频的文本和信号。%

 Background 1 是所有图形区域的背景。%

 Background 2 是图形窗口余下部分的背景。

修改颜色%
要修改颜色，单击包含着方块的 Foreground、Highlight、Background 1、

Background 2 或 Signal Color按钮。将显示一个 Color Editor 对话框。%

 有关编辑颜色的详细信息，参阅在线 SaberBook 的 Draw tool (Help＞
SaberBook）。

选择颜色后，在 Color Editor 对话框中单击ＯＫ按钮。从而选择颜色，并返

回到 Graph Preferences＞Graph对话框。%

如前文¡ 常规操作¡ 所述，将修改应用到工作面。

图形字体%

要修改图形窗口文本的风格，单击 ABC 123 按钮。显示 Font Selection对话

框。

 有关选择字体的详细信息，参阅在线 SaberBook 的 Draw tool（Help＞
SaberBook）。

选择好字体时，单击 Font Selection 对话框中的ＯＫ按钮。从而选择字体，

并返回到 Graph Preferences 对话框。如前“常规操作”所述，将修改应用到工

作面。
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3.3.3

信号是图形中显示的信息。每次添加另一信号时，以不同的颜色显示。如

果屏幕颜色映射到 Mono，信号显示为大量加下划线的行。这些划线行不能定制。

%

 Add 按钮允许添加更多 Signal Color 域。%

 Delete 按钮删除上一次的 Signal Color 域。

修改颜色%

要修改信号颜色，单击包含颜色方块的按钮。将显示 Color Editor对话框。

 有关编辑颜色的详细信息，参阅在线 SaberBook 的 Draw tool（Help＞
SaberBook）。

选定颜色后，在 Color Editor 对话框中单击ＯＫ按钮。从而选择颜色，并返

回 Graph Preferences＞Signal对话框。%

如前“常规操作”所述，将修改应用到工作面。

3.3.4

字符定位%

字符是出现在图形附近的文本，包括坐标轴标签和显示的信号名。

字符可配置成在图形右边、底部、左边或上部出现，或配置成悬浮字符。

选择 Float 按钮，使字符在其自身的窗口浮出。该窗口可移到图形窗口内的

任何地方。

 要移动字符窗口，在字符窗口按压鼠标左键。%

 将窗口拖到新的位置，释放鼠标键。

如前“常规操作”所述，将修改应用到工作面。

网格缺省显示
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背景网格可配置成或隐或现。%

如前¡ 常规操作¡ 所述，将修改应用到工作面。
显示优化%

 Signal Highlight On域控制信号的高亮显示。%

选择 Waveform and legend 按钮，允许将鼠标光标放在图形区域中显示的信

号上，或字符中的信号名上，以高亮显示信号。鼠标回应不及 Legend only 选项

迅速。%

选择 Legend only 按钮，允许将鼠标光标放在字符里的信号名上，以高亮显

示信号。鼠标回应比 Waveform and legend 选项迅速。%

 Signal Draw Feedback every域设置 Redraw Status 窗口显示的频繁度。Redraw
Status 窗口前数据点的缺省数显示为 1000。数据点越多，Redraw Status 窗口更

新显示越少，窗口重新绘制就越快。%
如前¡ 常规操作¡ 所述，将修改应用到工作面。

Redraw Status 窗口%

 Redraw Status 窗口指示重新绘制图形窗口需要的时间。重新绘制分两步。

 Transform Signal 显示从数据到图形的转换。任何时候单击 Interrupt 按钮都

可以暂停图形的重新绘制。只显示单击 Interrupt 按钮前处理信号的百分比。

Draw Lines 部分显示写入图形窗口的图形数据的百分比。单击 Interrupt 按

钮可在任何时候暂停图形的重新绘制。只显示单击 Interrupt 按钮前处理信号的

百分比。

3.3.5
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ＸＹ图形特性%

允许通过下列域对ＸＹ型图形定制特性。%
 Digital Trace Height 域修改绘图区域中数字信号的高度。%

 Analog Trace Height 域修改绘图区域中模拟信号的高度。%

 Bus Display Default 按钮修改绘图区域中显示值的基本数（基数）。有关数

字总线显示的详细信息，参阅下文。%

 Trace Snap 按钮允许打开或关闭数字标号的绘制切换开关。打开时，数字

标号切换到最近的状态修改。关闭时，数字标号可放置在数字图形的任一处。

如果新的信号未粘贴在现有图形区域内，Analog Paste 按钮选择新信号放置

在图形窗口中的位置。%

 选择 New Region，新的信号可放置在单独的新的图形区域。

 选择 Trace Region，新的信号可放置在绘制图形区域。
 选择 Bottom Region，新的信号可放置在首个图形区域窗口底部的图形

中。

如前“常规操作”所述，应用修改。

4 Graph

 Graph下拉菜单允许对与图形有关的图形和目标进行操作。

 Graph＞Annotate Info 项带出 Text Variables 对话框。Text Variables 对话框允

许在图形窗口查看信息，以及将信息插入图形窗口。信息包括当前日期、创建

日期以及当前图形窗口的作者。%

单击与想要插入文本相联的 Insert 按钮，在图形窗口插入信息。一旦文本

放置入图形窗口，可移动到图形窗口的任何点，并以 Draw Tool编辑。%

 Graph＞Zoom In 项增加放大倍数，以显示更具体的细节。图形窗口中所有

显示的图形区域都会受影响。%

 Graph＞Zoom Out 项减小放大倍数，显示的细节较少，但图形信息较多。
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图形窗口中所有显示的图形区域都会受影响。

4.1 Signal Attributes

 Graph＞Signal Attributes 对话框允许选择图形窗口中显示的任何信号、修改

信号颜色、修改线型、给信号添加符号、修改符号宽度、填充信号下的区域、

操作栈区域、修改信号位置以及修改信号标签。%

 Signal域允许选择图形窗口中显示的任何信号。

 要显示图形窗口中所有的信号，以鼠标左键单击 Signal域右侧的下指箭

头。

Color 域允许修改选定信号的颜色。
 要修改颜色，单击任一颜色按钮。

Style 域允许修改信号线的外形。显示了几种线型。选择 None,信号线会消

失。如果信号也由符号来表示，符号也将显示。

Symbol 域允许添加符号以显示信号线。显示了几种符号类型。选择 None，
符号会消失。如果信号也由线来表示，线也将显示。
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 Symbol Width域允许修改显示符号的大小。

Bar 域允许以某种图形填充曲线下的区域。显示了几种格栅图形。图形与

符号同种颜色。

Stack Region 域允许将 Signal Attributes 对话框中当前选定的信号移入或移
出不同的图形区域。%

 Digital将选定的模拟或数字信号移入单个数字/绘制图形区域。

 New 将选定的模拟或数字信号移入图形窗口中位于所有其它模拟图形

区域之上的新的模拟图形区域。

 n（n 是图形区域的标识号），将选定的模拟或数字信号移入标识为 n 的

模拟图形区域。

4.1.1 View
View域允许修改选定信号的显示。%

左手侧的域修改选定信号的Ｙ轴（垂向轴）绘图。

 Real(x)使用信号的 X 实值作为图形区域的Ｙ轴。例如，如果 X 轴以 Hertz
表示，Ｙ轴也以 Hertz表示。

 dB(x)绘制以分贝为单位的Ｘ轴值。
 Real(y)绘制 Y 轴的实值。

 dB(y)绘制以分贝为单位的 Y 轴值。

 Mag(y)绘制 Y 轴值的大小。

 Imag(y）绘制假想方式的Ｙ轴。

 Phase(y)deg绘制相位方式的以度为单位的Ｙ轴。
 Phase(y)rad 绘制相位方式的以弧度为单位的Ｙ轴。

 CPhase(y)deg绘制连续相位方式的以度为单位的Ｙ轴。

 CPhase(y)rad 绘制连续相位方式的以弧度为单位的Ｙ轴。

右侧域修改基于不同的Ｘ轴和Ｙ轴参数的选定信号和Ｘ轴（水平向轴）绘

图。%

 Real(x)绘制 X 轴的实值。%

 dB(x)绘制以分贝为单位的 X 轴值。%

 Real(y)使用信号的Ｙ值作为图形区域的 X 轴。例如，如果 Y 轴以伏特

表示，X 轴也以伏特表示。%

 dB(y)以 Y 轴方式和分贝单位绘制 X 轴。例如，如果 Y 轴以伏特表示，
Ｘ轴也以伏特和分贝表示。%
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 Mag(y)绘制 Y 轴值的大小。%

Imag(Y)以假想 Y 轴方式绘制 Y 轴。例如，如果 Y 轴以伏特表示，Ｘ轴也
以假想的伏特来表示。

 Phase(y)deg以相位方式，以度为单位绘制 X 轴。

 Phase(y)rad 以相位方式，以弧度为单位绘制 X 轴。

 CPhase(y)deg以连续相位方式，以度为单位绘制 X 轴。

 CPhase(y)rad 以连续相位方式，以弧度为单位绘制 Y 轴。

Real YvsK 以实方式绘制信号，Y 轴垂向，X 轴水平向。

 Real YvsK 以实方式绘制信号，X 轴垂向，Y 轴水平向。

ＡＣ信号有按钮将显示转变为 Nyquist 绘制、Bode dB绘制（垂向标度以分

贝表示）、Bode Phase 绘制（垂向标度以度表示）、或 Nichols 绘制。
4.1.2 Label
 Label域允许修改信号名。

 在 Label域键入信号名。

 单击 Apply按钮，在图形窗口中显示新名字。
Close 按钮关闭对话框，返回工作面。

4.2 Axis Attributes

 Graph＞Axis Attributes 对话框允许选择轴、缩放、扫视、将标度改为线性

或对数、修改网格增量、切换轴网格以及编辑轴标签。
4.2.1 Axis
 Axis 域允许选择图形窗口中显示的任何轴。

 要显示图形窗口中所有的轴，以鼠标左键单击 Axis 域左侧的下指箭头。
4.2.2 Range
 Range 域允许沿与 Axis 域有关的轴进行缩放和扫视。在 Zoom From/To 域

中显示视图范围。整个可能的视图范围在 Slider 栏下显示。

Zoom In按钮允许提高放大倍数，以显示更具体的细节。
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 Zoom to Fit 按钮允许显示最多的数据点，以显示信号的整个范围。

 Zoom Out 按钮允许减少放大倍数，以显示更少细节但更多的图形信息。

 Zoom From/To 域显示选定轴视图的当前范围，允许为想要显示的范围输入

值。

 要修改视图范围，在 From/To 域中键入值，单击 Apply 按钮。

Slider 允许扫视选定轴。

 按压鼠标左键，左右移动滑动块。可显示的范围显示在滑动块下面。显

示的范围在 From/To 域中动态示出。

 当 From/To 域中显示想要内容时释放鼠标键。

4.2.3
 Linear按钮以线性增量显示选定轴。Log按钮以对数增量显示选定轴标度。

4.2.4 Grid Increment
 Grid Increment 域允许修改轴标度的分辨率。

 例如，要显示.５增量，在 Grid Increment 域中键入.５，单击 Apply 按

钮显示新的增量。如果显示了轴网格，轴网格将会修改，以反映新的标
度分辨率。

4.2.5 Number of Tick Subdivisions
 Number of Tick Subdivisions 域允许修改网格增量之间的层数。

 键入想要显示的层数，单击 Apply按钮。

4.2.6
 Show 按钮打开活动图形窗口的轴网格。Hide 按钮关闭轴网格。%
4.2.7 Axis Label

Axis Label域允许修改轴的标号。标度的实际单位不修改。

 在 Axis Label域中键入信号名。

 单击 Apply按钮，以在图形窗口中显示新名字。

Close 按钮退出对话框，并返回工作面。
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4.3 Members

Graph＞Members 对话框允许控制由多个成员构成的信号的显示，如由 Vary
或 Monte Carlo 数据分析产生的成员。可以显示所有的或单个的成员、隐藏所有

或单个成员。显示所有成员标签或单个成员标签、循环显示所有信号成员、逐
个高亮显示每个成员。

4.3.1
标号单显示与信号每个成员有关的标号。每个标号对应一个对话框右侧的

清晰度指示符。

4.3.2
每个清晰度指示符示出成员的显示状态。每个指示符对应于左侧 Label List

中的成员标号。
 要修改清晰度指示符的状态，单击鼠标左键。

 全黑的清晰度指示符表示信号标号或信号成员都没显示。

 半黑半绿的清晰度指示符表示显示了信号成员，但没显示标号。

 全绿的清晰度指示符表示同时显示了信号标号和成员。
4.3.3 Signal
 Signal域允许选择图形窗口显示的任何信号。

 要显示图形窗口中所有信号，以鼠标左键单击 Signal 域右侧的下指箭

头。
可以选择图形窗口中的任何信号，但 Members 对话框不会显示不由多个成

员构成的信号的任何数据。

4.3.4
 Show All Members 按钮显示 Signal域中给出信号的所有成员。不显示标号。

 Show All Labels 按钮显示图形窗口中所有的成员和标号。为方便查看，这

些标号的位置都可以重新布置。

 要移动标号，在想要移动的标号上按压鼠标左键，并移动标号。
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 释放鼠标键，放置标号。

Hide All 按钮从视图消除图形窗口中的所有成员。单个成员可以使用 Status
List 中的清晰度指示符来显示，全部成员可以使用 Show All Members 按钮显示。

 Loop Highlight 按钮按序高亮显示信号的每个成员。即便所有成员都隐藏起

来了，该按钮仍然有效。

 要开始或停止扫视，单击 Loop Highlight 按钮。

Label Orientation按钮从上到下或从左到右堆积成员标号。

 Close 按钮关闭 Member Attributes 对话框。

4.4 Measure Results

 Graph＞Measure Results 对话框允许选择信号、删除测量结果、隐藏测量结

果或显示所有测量结果。

4.4.1
测量表显示对某个信号有效的所有测量结果。选定测量的测量值在状态表

里显示。

4.4.2
状态表显示与测量表中选定测量有关的一组测量值。每个值有一个清晰度

指示符号与其相连。

清晰度指示符给出测量值的显示状态。

 要修改清晰度指示符的状态，单击鼠标左键。

全黑的清晰度指示符表示没有显示测量值。

全绿的清晰度指示符表示显示了测量值。
4.4.3 Signal
 Signal域允许选择图形窗口中显示的任何信号。%

 要显示图形窗口中所有信号，以鼠标左键单击 Signal 域右侧的下指箭

头。%

虽然可以选择图形窗口中的任何信号，Measure Results 对话框不会显示
Measure Tool没测量过信号的任何数据。%

 Delete Measurement 按钮永久删除选定测量结果。%

 Delete All 按钮永久删除选定信号的所有测量结果。%

 Show All Values 按钮显示选定测量的所有值。%
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 Hide All Values 按钮隐藏选定测量所有值的显示。鼠标光标经过状态表中的

清晰度指示符，信号上会出现高亮显示的测量值。%
 Close 按钮关闭 Measure Results 对话框。

4.5 Selected Axes

 Graph＞Selected Axes 级联菜单操作选定的一个或多个轴。

 要选择一个轴，将鼠标光标放在轴网格、轴网格附近的轴名字或字符中

的轴名字上，单击鼠标左键。
有下列项：Range、Scale、Grids、Sliders 和 Lock。
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Range
Zoom to Fit 显示最大量的数据点，以示出信号的整个范围。

Zoom In增加放大倍数以显示更具体的细节。

Zoom Out 缩小放大倍数以显示较少细节，但更多图形信息。

Pan Right 允许查看当前显示图形右侧看不见的数据部分。通常

只对 X 轴操作。

Pan Left 允许查看当前显示图形左侧看不见的数据部分。通常只

对 X 轴操作。

Pan Up 允许查看当前显示图形上面看不见的数据部分。通常只

对 Y 轴操作。
Pan Down 允许查看当前显示图形下面看不见的数据部分。通常

只对 Y 轴操作。
Scale

Linear 设置轴显示线性刻度。

Log设置轴显示对数刻度。

Grids
Show打开图形区域的轴网格。

Hide 关闭图形区域的轴网络。

Sliders 可以选择使用滑动块，以沿图形的 X 轴扫视。

Show打开滑动块。

Hide 关闭滑动块。

4.5.1 Lock

如果信号和轴单位相同，Accept new signals 允许将信号添加到轴。例如，

一个微伏大小的信号与同一图形区域内伏特大小的信号标度相同。
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即便信号和轴单位相同，Lock out new signals 也不允许将信号添加到同一

轴上。例如，一个微伏大小的信号与同一图形区域的伏特大小的信号，其标度
不同。

4.6 Selected Signals

 Graph＞Selected Signals 级联菜单对选定的一个或多个图形信号操作。%

 要选择一个信号，将鼠标光标放在信号或字符中的信号名上，然后单击

鼠标左键。

有下列项：Stack Region、Color、Style、Symbol、Symbol Width、View、Trace
Height、Digital Display、Create Bus 和 Delete Signals。
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Stack Region Stack Region允许将选定信号移入和移出不同图形区域。

Digital Trace 将选定的模拟或数字信号移入数字/绘制图形区

域。

New Analog 将选定的模拟或数字信号移入新的模拟图形区

域。

Analog n(n 是图形的识别号)将选定的模拟或数字信号移标号

为 n的模拟图形区域。
Color Color 允许选择一种信号颜色。

Style Style 选择几种线型。选择 None 信号线消失。如果信号也由
符号表示，则符号仍然显示。

Symbol Symbol 显示几种符号类型。选择 None 符号消失。如果信号
也由线表示，则线仍然显示。

Symbol Width Symbol Width允许修改显示符号的大小。

View View允许修改选定信号的显示。

Horizontal Value 域修改基于不同 X 轴和 Y 轴参数的选定信
号的 X 轴(水平向轴)绘制。有关 Horizontal Value 菜单选项的

详细信息，参阅本章前面内容。

Vertical Value 域修改选定图形区域的 Y 轴(垂向轴)绘制。有

关的 Vertical Value 菜单选项的详细信息，参阅本章前面内容。

其它所有 View选项，参阅上文。
Trace Height Trace Height 菜单对数字 /绘制图形区域中显示的数字或模拟

信号有效。Trace Height 菜单允许修改选定信号的高度。

Digital Display Digital Display 菜单允许将逻辑信息显示为数值方式的总线，
如二进制、八进制、十进制、十六进，或显示为模拟分级波

形。
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Create Bus Create Bus 项从绘制图形区域提取多个数字信号，并将其组

合为一条数字总线。
Delete Signals Delete Signals 项删除图形窗口中选定的一个或多个信号。如

果删除的信号是图形区域中唯一的信号，则整个图形区域被

删除。

4.7 Selected Graphics

Delete
 Graph＞Selected Graphics＞Delete 项删除图形窗口中选定的任何绘制图形，

可按以下步骤删除一个图形：

１. 要删除一个图形，用光标高亮显示，并单击鼠标左键选择。按下 Shift
键可选择多个图形。%

２. 单击 Graph＞Selected Graphics＞Delete 项。

4.8 Font

 Graph Menu＞Font 对话框允许修改图形字体。%

 有关选择字体的详细内容，参阅在线 SaberBook 的 Draw tool（Help＞
SaberBook）。

 要应用任何修改，单击 Font Selection对话框中的ＯＫ按钮。

4.9 Color map

 Graph Menu＞Color Map 项允许将图形窗口彩色原理图修改为 Map1，Map
２和 Mono 方式。Map1 和 Map２是彩色显示和彩色打印机的彩色印射。Mono
是单色显示和黑色墨粉打印机的黑白显示。

所有颜色印射可在 Edit＞Graph Preferences 对话框中修改。

4.10 Legend

 Graph＞Legend 项允许修改图形区域中字符的位置。字符是图形附近的文

字，包括轴标志和显示的信号名。%

字符可设置成出现在图形的右侧、底部、左侧或顶部，或设置成悬浮。%

选择 Float 选项，将字符在自身窗口内上浮。该窗口可移到图形窗口内的任
何地方。

 要移动字符窗口，在字符窗口处按下鼠标左键。

 将窗口拖到新的地方，释放鼠标键。

选择 None 选项，从图形窗口消除字符。可使用任何其它 Graph＞Legend 项

重新显示字符。
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4.11 Match Aspect Ratio

Graph Menu＞Match Aspect Ratio 项修改图形窗口的尺寸。打印复制件时可

用来调配纸张的高宽比。

·要修改图形窗口尺寸以调节高宽比，在相应的域键入高度和/或宽度值，

单击ＯＫ钮。

4.12 Clear Graph

Graph Menu＞Clear Graph 项从图形窗口清除所有信号、轴和字符，不保存
信息。

5. Tools

 Tools 下拉菜单允许进入屏幕底部以图标形式出现的 SaberDesigner Tools。
有关每个工具功能的详细信息，参阅单独的 Tool章节。

6. Window

 Window下拉菜单允许在工作面管理多个图形窗口。有关该下拉菜单的详细

信息，参阅前面的¡ Window下拉菜单¡。

7. Help

 Help 下拉菜单对不同的 SaberDesigner 属性提供帮助。有关使用 Help 菜单

的详细信息，参阅前面的¡ Help 下拉菜单”。
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本章包括下列主要内容：

 常规操作

 绘制图形区%

 模拟图形区域

1

 SaberScope 图形是来源于 Saber 分析或其它出处数据的显示。图形数据可

以是相对时间、频率或其它数据绘制的信号、统计数字等。

图形窗口中支持两种基本的图形区域：Trace 图形区域和 Analog图形区域。

1.1

要在工作面显示图形，参阅在线 SaberBook 的 Signal Manager(Help＞
SaberBook)。

1.2

1.2.1
拉近图形区域，提高放大倍数，显示更具体的细节。有几种方法拉近图形。
 使用下拉菜单栏中的 Graph＞Zoom In项，拉近图形中央部分。

 单击图标栏中的 Zoom In图标，拉近图标中央部分。

 使用 Graph弹出菜单中的 Zoom In项，拉近图形中央部分。

 将鼠标光标放在想要拉近的区域的一角。按压鼠标左键，并移动鼠标，

在希望放大的区域周围创建一个方框。释放鼠标按钮拉近。

 将鼠标光标放在想要拉近范围中某一端的Ｘ轴或 Y 轴。按压鼠标左键，

将光标放在想要拉近范围的一端。释放鼠标按钮拉近选定轴。

 将鼠标光标放在某一轴上或字符中的轴名上。按压鼠标右键。显示 Axis
菜单。将鼠标光标移到 Range＞Zoom In项，释放鼠标按钮。

 将鼠标光标放在某一轴上或字符中的轴名上。按压鼠标右键。显示 Axis
菜单。将光标移到 Attributes＞Zoom In图标上，释放鼠标按钮。

1.2.2
拉远一个图形降低放大倍数，显示更少细节但更多图形信息。有几种方法

拉远图形。

 使用下拉菜单栏中的 Graph＞Zoom Out 项，拉远图形中心。
 单击图标栏中的 Zoom Out 图标，拉远图形中心。

 使用 Graph弹出菜单中的 Zoom Out 项，拉远图形中心。

 将鼠标光标放在某一轴或字符中的轴名上。按压鼠标右键。显示 Axis
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菜单。将鼠标光标移到 Range＞Zoom Out 项，释放鼠标按钮。

 将光标放在某一轴或字符中的轴名上。按压鼠标右键。显示 Axis 菜单。
将光标移到 Attributes＞Zoom Out 图标，释放鼠标按钮。

1.2.3
缩放成窗口大小显示最多数据点，给出信号的整个范围。有几种方法缩放

成窗口大小。

 使用下拉菜单栏中的 Graph＞Zoom to Fit 项。

 单击图标栏中的 Zoom to Fit。
 使用 Graph弹出菜单中的 Zoom to Fit 项。

 将光标放在某一轴或字符中的轴名上。按压鼠标右键。显示 Axis 菜单。

将光标移到 Range＞Zoom to Fit 项，释放鼠标按钮。

 将光标放在某一轴或字符中的轴名上。按压鼠标右键。显示 Axis 菜单。
将光标移到 Attributes＞Zoom to Fit 图标，释放鼠标按钮。

1.3

1.3.1
扫视允许查看在当前图形上看不见的数据部分。有几种方法扫视。

 左键单击Ｘ或Ｙ轴。使用下拉菜单栏中的 Graph＞Selected Axes＞Range
＞Pan Right/Left/Up/Down项。

 将光标放在Ｘ或Ｙ轴上。按压鼠标中键并移动光标。随着光标的移动扫

视轴。释放按钮，信号将切换到新的轴坐标。

 将光标放在图形区域内。按压鼠标中键，移动鼠标，轴刻度随之移动，

释放鼠标按钮，波形将切换到新的轴坐标。
 左键单击Ｘ或Ｙ轴。使用Graph弹出菜单中的Selected Axes＞Range＞Pan

Right/Left/Up/Down项。

 将光标放在某一轴或字符中的轴名上。按压鼠标右键。显示 Axis 菜单。

将光标放在 Range＞Pan Right/Left/Up/Down项，释放鼠标按钮。

 将光标放在某一轴或字符中的轴名上。按压鼠标右键。显示 Axis 菜单。
将光标放在 Attributes＞Pan Right/Left/Up/Down项，释放鼠标按钮。

 在Ｘ轴标度上按压鼠标右键。显示 Axis 菜单。将光标移到 Attributes 项。

使用 Range 域中的滚动条扫视视图。

滚动条

可以使用滚动条沿图形的Ｘ轴扫视。有几种方法显示滚动条。%

 左键单击Ｘ轴。使用下拉菜单栏中的 Graph＞selected Axes＞Sliders＞
Show项。

 左键单击Ｘ轴。使用 Graph弹出菜单中的 Selected Axes＞Sliders＞Show
项。

 在Ｘ轴标度上按压鼠标右键。显示 Axis 菜单。将光标移到 Display Range
Slider 项，释放鼠标按钮。

 以 Slider(s)＞Hide 项从图形移动滚动条。

1.3.2
图形窗口中有几个弹出菜单。

 要打开一个弹出菜单，高亮显示一个信号、轴、字符、标号、图形或量
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度。然后按压鼠标右键。

 要激活弹出菜单中的某一项，将光标放在该项上，释放鼠标按钮。

2 Trace

Trace 图形区域是显示数字信号的主要区域。模拟信号也可以放置在 Trace
图形区域。

Marker 域显示数字信号上某一点的逻辑状态，或者 Trace 图形区域中某模

拟信号的值。点由 Trace 标号选择。

 要放置一个 Trace 标号，以光标高亮显示一个新的标号符号，按压鼠标

左键，将标号拖到想要的地方。

 释放鼠标按钮放置标号。Marker 域中显示位置的逻辑状态。

Trace 图形使用和 Analog图形区域中同样的弹出菜单，另外加上 Trace 菜单。

Trace 菜单只在 Trace 图形区域中操作。

2.1 Trace

 要打开 Trace 弹出菜单，将光标放在 Marker 域或 Trace 标号上，然后按

压鼠标右键。

Trace 弹出菜单允许显示特定 Trace 标号的逻辑级，使特定 Trace 标号相关

的轴居中，以及打开或关闭标号与绘制切换的性能。%

 Trace＞Display项引出一列有效的 Trace 标号。从该列中选择一个 Trace 标

号将显示数字信号的逻辑状态，以及 Trace 图形区域中位于 Trace 标号处的模拟
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信号的数值。Marker 域中显示逻辑状态。%

 Trace＞Center 项引出一列有效的 Trace 标号。从该列中选择一个 Trace 标号
将扫视相应的轴，使 Marker 位于 Trace 图形区域的中央。%

 Trace＞Delete 项引出一列有效的 Trace 标号。从该列中选择一个 Trace 标号

将从 Trace 图形区域中删除该标号。%

 Trace＞Snap to Trace 项允许从 Trace 标号切换到数字信号的离散事件。

3

模拟图形区域是显示模拟信号的主要区域。数字信号也可以放置在模拟图

形区域内。垂向标度是图形的Ｙ轴。垂向标度的标记直接在标度附近显示，也

在图形旁的字符中显示。

水平向标度是图形的Ｘ轴。水平向标度的标记直接在标度附近显示，也在
图形旁的的字符中显示。%

字符包括按一定秩序排列的垂向和水平标度的标记。%

Trace 弹出菜单不在模拟图形区域中操作。

3.1 Graph

 要打开 Graph 弹出菜单，将光标放在图形窗口的空白部分，不高亮显示
任何目标。然后按压鼠标右键。

 要激活 Graph 弹出菜单中的某项，将光标放在想要打开的项上，释放鼠

标按钮。

Graph弹出菜单允许定制和操作图形窗口，以增强显示信息的表示。

 Graph弹出菜单中的项和 Graph下拉菜单一样。Graph 菜单的详细信息见前
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一章。

3.2 Axis

·要打开 Axis 弹出菜单，将光标放在轴或轴名上，然后按压鼠标右键。

 Axis 弹出菜单允许操纵图形的水平向和垂向轴标度。%

 Axis＞Attributes 对话框允许选择一条轴，进行缩放、扫视，将标度修改为

线性或对数。修改网格增量、切换轴网格，以及编辑轴标记。详细信息见上一

章。%

 Axis＞Range 菜单允许进行缩放和扫视。详细信息，参阅上一章。%

 Axis＞Scale 菜单允许以线性或对数增量显示轴标度。%

 Axis＞Display Grid 按钮打开或关闭选定轴的轴网格。%

 Axis＞Display range slider 按钮显示或隐藏Ｙ轴的滑动块。滑动块的操作见

上一章。%

 Axis＞Look out new signals 按钮的详细信息见上一章。

3.3 Signal

·要打开 Signal 弹出菜单，将光标放在信号或信号名上，然后按压鼠标右

键。

 Signal弹出菜单允许操作图形中信号的显示。%
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 Signal＞Attributes 对话框允许选择图形窗口中显示的任何信号，修改信号

颜色，修改线型，给信号添加符号，修改符号宽度，填充信号下的区域，操作
层叠区域，修改信号视点，以及修改信号标记。详细信息见上一章。%

 Signal＞Members 对话框允许控制由诸如 Vary或 Monte Carlo 数据分析产生

的多个成员构成的信号的显示。可以显示所有成员或单个成员、隐藏所有成员

或单个成员、显示所有成员标记或单个成员标记，依次高亮显示整个范围中的

成员。详细信息见上一章。

 Signal＞Measure Results 对话框允许选择信号，删除测量，隐藏测量显示或

显示所有测量结果。详细信息见上一章。%

 Signal＞Annotate Info 项引出 Text Variables 对话框。Text Variables 对话框允

许查看显示信号的信息，并将该信息插入图形窗口。可获得的信息包括创建日

期、设计名、文件名、绘制类型、路径名、仿真程序名、仿真程序释放以及选
定信号标题。%

 要显示图形窗口中所有的信号，以鼠标左键单击 Signal域中左侧的下指

箭头。

 要将信息插入图形窗口，单击与要插入文本相关的 Insert 按钮。一旦文

本放置入图形窗口，则可以移到图形窗口的任一点，并以 Draw Tool 编
辑。

 Signal＞Stack Region、Color、Style、Symbol、Symbol Width、View、Trace Height
和 Digital Display项和在 Graph菜单中的操作相同。这些菜单项的详细信息见上

一章。%

 Signal＞Burst Bus 项将总线扩展成离散的数字信号。%

 Signal＞Front 项将选定信号放在一堆层叠信号的前面显示。%

 Signal＞Delete Signal 项删除高亮显示的信号。如果删除的信号是图形区域

中唯一的信号，则所有图形区域被删除。

3.4 Measure

 要打开 Measure 弹出菜单，将光标放在测量标志上，然后按压鼠标右键。

Measure 弹出菜单允许打开 Measure Results 对话框，隐藏测量值，将某测量

标记放在一叠标记的底部，以及给信号添加标志。%

 Measure＞Measure Results 对话框允许选择信号、删除测量、隐藏测量显示，
或显示所有测量结果。详细信息见上一章。%

 Measure＞Hide Measurement 项关闭 Measure 弹出菜单正在运行的测量的测

量值。可以使用 Measure Results 对话框重新显示该值。%

 Measure＞Back 项将测量标记放在一叠标记后面显示。%

 Measure＞Front 项将测量标记放在一叠标记前面显示。%

 Measure＞Add Marker项可以给信号添加三种不同的测量标号。%

 Point Marker 复制现有的锚点和标记。
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 Horizontal Level 标号产生一条水平线，与信号锚点的垂向（Ｙ轴值）相

交。
 Vertical Level标号产生一条垂线，与信号锚点的水平向（Ｘ轴）值相交。

3.5 AimDraw

 要打开 AimDraw 弹出菜单，将光标放在绘制图形上，然后按压鼠标右

键。

AimDraw 弹出菜单允许在图形窗口编辑图形。可以修改某选定图形目标的

属性、进行旋转、镜象处理图像、将其放在一叠图形的后面、放在一叠图形的

前面，或删除。

 AimDraw＞Attributes 对话框允许修改选定图形目标的性能，如颜色、线宽、

填充、字体等。每个图形目标都有一个稍有区别的 Attributes 对话框。详细信息
参阅在线 SaberBook 的 Draw tool (Help＞SaberBook)。
 AimDraw＞Rotate 项允许 90、180 或 270 度旋转一选定图形目标。

 AimDraw＞Mirror 项允许选择Ｘ项水平向或选择Ｙ向垂向地镜象处理选定

图形目标的图像。

 AimDraw＞Back 项将选定图形降到一叠图形的底部。%

 AimDraw＞Front 项将选定图形升到一叠图形的顶部。%

 AimDraw＞Delete 项永外删除 AimDraw弹出菜单正在操作的图形。


