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Introduction

Introduction

The TwoChannelBuck EVM project provides a straightforward method of learning about digital
power with Texas Instruments’ F28xxx series digital signal controllers (DSC). In this document
you will find lab procedures that explore the EVM’s features inside Code Composer Studio. The
first lab introduces the software framework and will run the TwoChannelBuck board in an open
loop configuration. The next lab shows how the framework can close the loop and teaches how
the TI 28xxx DSC can be used to provide sequencing and a soft start-up. Finally, the last lab
shows how the control loop is designed and will allow you to tune the transient response via P, I,
D parameters.

The TwoChannelBuck EVM project features:

e 10 Amp SyncBuck DC/DC power stages (no heat-sink required) with built-in MOSFET
drivers

e Active load for transient response testing (switching timing controlled by ECAP periph-

eral)

Voltage input and output measurements via ADC

Temperature measurement for each channel monitored by ADC

Current measurement for each channel monitored by ADC

Over-Current protection and fault flag detection via GPIO

Closed loop digital control with voltage feedback using F28xxx on-chip ePWM and ADC

Optional ePWM signals looped back as ADC inputs provides a simple low cost scope to

view waveforms in CCS

8 x LED indicators are great for diagnostics and fault status

e UART communications header available for Host control

e Host GUI provides a friendly way to control / demo the application, based on open source
C# freeware (installed with this package)

o Hardware Developer’s package includes Schematics, Bill of materials, Gerber files,...etc
(installed with this package)

The TwoChannelBuck project is built within the Texas Instruments’ F28xxx System Framework
and is configurable to run on any F28xxx target DSC. The project contains C source files which
handle the initialization and background tasks, and a time-critical ISR code written in assembly
using library modules. Further information on what the System Framework is and how it works
can be found in the SystemFrameworkOverview guide.

For all information on hardware and software setup, please read QSG-TwoChannelBuck noted
in the references below.

Caution

During experimentation the power resistors (Load1 — see Hardware overview) may become very
HOT if Ch-1 output voltage is left running for extended time (avoid if possible). Please DO NOT
TOUCH, allow the resistors to cool down first.
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Lab 1: PWM Generation / Open-Loop Control

Lab 1: PWM Generation / Open-Loop Control
» Objective

The objective of this lab exercise is to demonstrate the topics discussed in this module and control
the buck output voltage using simple PWM duty cycle adjustments without feedback. Since this
implementation is open-loop and therefore has no requirement for high speed feedback, the ADC
will be used to measure various values for instrumentation purposes only. These values will be
displayed using CCS. The PWM duty cycle will be adjusted using watch windows. In this lab,
you will:

¢ Control Buck output voltage using simple PWM duty cycle adjustment without feedback

e Use CCS watch window features to conveniently adjust PWM duty cycle

» Project Overview

Lab exercises 1, 2, and 3 all use the TwoChannelBuck project. It makes use of the “C-
background/ASM-ISR” framework. Futher information on the framework can be found in the
SystemFrameworkOverview guide. In these lab exercises EPWMs 1 and 2 are used to drive
buck stages Channel 1 and Channel 2, respectively.

The key framework files used in this project are:

TwoChannel Buck- Mai n. ¢ — this file is used to initialize, run, and manage the application.
This is the “brains” behind the application.

TwoChannel Buck- Devl nit _F28xxX. ¢ — this file is responsible for a one time
initialization and configuration of the device, and includes functions such as setting up the clocks,
PLL, GPIO, etc. This file is specific to a family of devices (ex. F280x, F2833x, etc).

TwoChannel Buck- | SR. asm- this file contains all time critical “control type” code. This file
has an initialization section that is executed one time by the C-callable assembly subroutine

_I SR I ni t. The file also contains the _| SR_Run routine which executes at the same rate as
the PWM timebase which is used to trigger it.

TwoChannel Buck- Set t i ngs. h — this file is used to set global definitions for the project (ie.
build options). Note that it is linked to both TwoChannel Buck- Mai n. ¢ and
TwoChannel Buck- | SR. asm

4 TMS320C2000™ Systems Applications Collateral



Lab 1: PWM Generation / Open-Loop Control

The Power Library functions (modules) are “called” from this framework. Library modules may
have both a C and an assembly component. In this lab exercise, the following C and
corresponding assembly modules are used:

C configuration function ASM initialization macro ASM Run time macro
BuckSi ngl e_CNF() BuckSingle_ DRV_INIT n | BuckSi ngl e_DRV n
ADC_CascSeqCNF() none none

The TwoChannelBuck EVM consists of two identical buck power stages. The input bus voltage
for both stages is 9V. Shown below is a diagram of the Power EVM and some key features.

Main Pwr (SW1) Load 2 Load 1 Active Load
9V In =——p
DC Bus DMM
(SW2)
Emulator
JI;‘I’EVZTI VI/V2
P €= Sclect
(SW3)
Boot Jumpers Buck 2 Buck 1 Comms
9V In DC power supply from plug pack (12V supply may be used as well)
Main Pwr SW1 - Master power switch for entire EVM
DC Bus SW2 - Power switch for Vin to buck stages only. When off the F2808 DIMM
controller card will still operate (next to the DC bus switch is a resettable fuse)
Buck 1, 2 Buck power stage modules with temperature/current measurement and over
current protection
Load 1 Buck converter output for Channel 1 is tied to two 2Q resistors in parallel. If
desired, load 1 can be desoldered and a terminal block as in Channel 2 can be
reinstalled.
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Lab 1: PWM Generation / Open-Loop Control

Load 2 Load terminals and/or buck converter output - next to each terminal block is a
light bulb or “visual” load (these draw approx 250 mA hot)

Active Load Software controlled switched load (connected to output of buck 1 only)

DMM Digital Multi-Meter (has a range of 0~20V, with resolution of 10 mV and is

used to measure output voltage of buck conterters)

V1/V2 Select

SW3 - selects the display of the DMM between output voltage of buck 1 and 2

Comms Serial communications UART (connects to an optional GUI, not used in lab
exercises)
Emulator Sets the voltage sent to power the emulator. No jumper means no power will be

Power Jumper

sent to an emulator, a jumper at “5V”” will power the emulator with 5V, and a
jumper at “3V3” will power the emulator with 3.3V.

Boot Jumpers

Controls how the F280x will boot.
e Ifno jumpers are placed the target will boot from flash.
e Ifajumper is placed at “34”, the target will boot from the SCI
e Ifajumper is placed at “29” and “34”, the target will boot from RAM

The key signal connections between the F2808 Digital Signal Controller and the 2 buck stages are
listed in the table below. For reference a portion of the schematic is also given.

Signal Name Description Connection to target
DSC
EPWM-1A PWM Duty control signal for buck stage 1 GPIO-00
EPWM-2A PWM Duty control signal for buck stage 2 GPIO-02
VoutFB-1 Voltage feedback for buck stage 1 ADC-B0
VoutFB-2 Voltage feedback for buck stage 2 ADC-A0
Tout-1 Current monitor / measurement buck stage 1 ADC-B1
Iout-2 Current monitor / measurement buck stage 2 ADC-Al
Temp-1 Temperature monitor / measurement buck stage 1 ADC-B2
Temp-2 Temperature monitor / measurement buck stage 2 ADC-A2
Ifault-1 Over-Current flag, digital output from buck stage 1 GPIO-12
Ifault-2 Over-Current flag, digital output from buck stage 2 GPIO-13
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Lab 1: PWM Generation / Open-Loop Control
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Lab 1: PWM Generation / Open-Loop Control

> Lab Exercise Overview

The software in Lab1 has been configured to independently adjust the duty cycle of EPWM-1A
and EPWM-2A. “Net” variable names Dut y[ 1] and Dut y[ 2] have been declared and
“connected” to the inputs of BuckSi ngl e_DRV macro. Using the watch window Duty[1] and
Duty[2] can be directly adjusted. Below is the system diagram for Labl.

B-uCk E Vin Bucke-1 Voutl
Single [y . N n
DRV | M
Duty[l] —» In H — EPWM-1A DRV
w
T
Buck g = -
Single |
DRV | M ks
. uck-.
Duty[2] -» In H — EPWM-2A Vin Vout2
w

Watch Window i

DRV
Gui_Vout[1]

Gui_Vout[2] B Voutl

3 Vout2

Gui_Tdeg]1] Gui Templ

Scaling Temp2
(B Tasks)

Casc
Seq
CNF

Gui_Tdeg[2] Toutl
Tout2

Vin

ST 0OU>»

Gui_Iout[1]

i

Gui_lout[2]

In the TwoChannelBuck project the assembly ISR _| SR_Run routine is triggered by EPWMI.
This is where the BuckSi ngl e_DRV macros are executed. Therefore, the PWM update rate is
equal to the PWM frequency. Since this system is running open-loop, there is not a requirement
for high speed feedback. As a result, the ADC function ADC_CascSeqCNF( ) is called in the C
background code during initialization, and the ADC measured values are only used for
instrumentation purposes. The update rate can be much slower with no need to be synchronized to
the PWM or ISR. The ADC values are read directly from the ADC result registers

(AdcM rror. ADCRESULTN) by the background C code.

A task state-machine has been implemented as part of the background code. Tasks are arranged in
groups (Al, A2, A3...,B1,B2,B3..., Cl1, C2, C3...). Each group is executed according to 3
CPU timers which are configured with periods of 1 ms, 5 ms, and 7.5 ms respectively. Within
each group (e.g. “B”) each task is run in a “round-robin” manner. For example, group B executes
every 5 ms and there are 3 tasks in group B. Therefore, each “B task” will execute once every 15
ms.

In this lab, “A tasks” are used to provide channel enabling, soft start and sequencing for the
EVM. In the code the function SerialHostComms() is used to allow an external GUI to edit the
project’s variables. This GUI is not used for these labs, however more information on its use can
be found in the QSG-TwoChannelBuck-GUI guide.

System dashboard measurements are conveniently done by group “B tasks” (i.e. Bl — voltage
measurement, B2 — temperature measurement, and B3 — current measurement). These tasks
convert user inputs/outputs (designated by the Gui_ prefix) from/to a Q format variable and put it
into a Q15 format that the framework uses. This is in order for the user to use real units (ie V/ms,
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Lab 1: PWM Generation / Open-Loop Control

amps) while still saving precision. The details of each conversion are found in the excel
spreadsheet TwoChannelBuck-Calculations.

In this project “C tasks” are used for slow-tasks such as coefficient update, active load control,
and LED control.

> Procedure

Open a CCS Project

1. Turn on the power (SW1) to the 2-channel buck EVM. Open Code Composer Studio and
maximize it to fill your screen.

2. Open the project TwoChannel Buck. pj t by clicking:
Proj ect > pen...

and look in C: \ TI _F28xxx_SysSW TwoChannel Buck\ .

3. This project can be configured to create code for multiple target controlCARDs and can
be ran in either flash or RAM. For the labs we will run the F280x in RAM. In the project
window, right-click on TwoChannelBuck.pjt and select “Configurations...”. In the new
window select F280x_RAM, click “Set Active” and then click “Done”.

4. Code Composer Studio can automatically load the output file after a successful build. On
the menu bar click: Opti on - Cust om ze..and select the
“Program Proj ect/Cl O tab, check“Load Program After Build”.

Also, Code Composer Studio can automatically connect to the target when started. Select
the “ Debug Properti es” tab, check“ Connect to the target at
startup”, then click OK.

Device Initialization, Main, and ISR Files

5. Open and inspect TwoChannel Buck- Devl ni t . ¢ by double clicking on the filename
in the project window. Confirm that GPIO00 and GPIO02 are configured to be PWM
outputs.

6. Open TwoChannel Buck- Set ti ngs. h. For this lab we will use incremental build
option 1. Please edit the file so that INCR_BUILD is defined as 1

(i.e. #define 1 NCR_BU LD 1)
then save the file by clicking:

File - Save
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Lab 1: PWM Generation / Open-Loop Control

Not e: This should be the only change nade to source files for

this | ab.

Open and inspect TwoChannel Buck- Mai n. c. Notice the code enabled when
INCR_BUILD is 1. This section of code is shown here for convenience. Additional
comments have been added in italics. Note that the run-time macros are executed at the
PWM rate of 400 kHz.

[ R e I R
#if (INCRBU LD == 1) // Open loop - Channels 1,2

R e e
#defi ne prd 250 /1 Period count = 400 KHz @ 100 MHz
#def i ne NumAct vCh 2 /1 Nunmber of Active Channel s

/1 "Raw' (R) ADC neasurenent nane defines

#defi ne Vout Rl  AdcM rror. ADCRESULTO //

#def i ne Vout R2  AdcM rror. ADCRESULT1 //

#def i ne loutRL AdcM rror. ADCRESULT2 [/

#defi ne loutR2 AdcMrror. ADCRESULT3 //

#defi ne TdegR1  AdcM rror. ADCRESULT4 //

#defi ne TdegR2  AdcM rror. ADCRESULTS //

#def i ne Vi nR AdcM rror. ADCRESULT6 [/

The ChSel array is used as input by function ADC_CascSeqCNF. These values will be used by “B” tasks for dashboard
calculations, and shown in the Watchwindow.
/1 Channel Selection for Cascaded Sequencer

ChSel [0] = 8; /1 BO - Voutl

ChSel [1] = 0; /1 A0 - Vout2
ChSel[2] = 9; /1 Bl - loutl

ChSel [3] = 1, /1 Al - lout2

ChSel [4] = 10; /1 B2 - Tenperature-1
ChSel [5] = 2; /1l A2 - Tenperature-2
ChSel [ 6] = 11; /1 B3 - Vin

The 3 configuration functions below are part of the Power Library.

BuckSi ngl e_CNF(1, prd, 1, 0); /1 ePWML, Period=prd, Master, Phase=Don't Care
BuckSi ngl e_CNF(2, prd, 0, 0); /1 ePWWR, Period=prd, Slave, Phase=0
ADC_CascSeqCNF(ChSel, 2, 7, 1); // ACQPS=2, #Conv=7, Mde=Continuous (1)
EPwmLRegs. CMPB = 2; /'l 1SR trigger point

ISR Init(); /1 ASM ISR init

Duty[1] and Duty/[2] variables will directly control the buck duty cycle. The WatchWindow will be used to quickly change
these values.

Duty[ 1] = 0xO;

Duty[2] = 0xO;

/1 Lib Mdule connection to "nets"

A
/'l BuckSi ngl e_DRV connecti ons

Buck_Inl = &Duty[1];

Buck_In2 = &Duty[2];

#endif // (1NCRBU LD == 1)

10
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Lab 1: PWM Generation / Open-Loop Control

8. Open and inspect TwoChannel Buck- 1 SR. asm Notice the _| SR I ni t and
_I' SR_Run sections. This is where the PWM driver macro instantiation is done for
initialization and run-time, respectively. The code is shown below for convenience. In
Lab1, incremental build option IB1 is used.
if(INCRBULD = 1) ; Init tine

BuckSi ngl e_DRV_INIT 1 ; EPWMLA
BuckSingle_ DRV_INT 2 ; EPWWMRA
.endi f
Jif(INCRBULD = 1) ; Run tine
BuckSi ngl e_DRV 1 ; EPWMLA
BuckSi ngl e_DRV 2 ; EPWWMRA

.endif

9. Close the inspected files if desired.

Build and Load the Project

10. Click the “ Rebui | d Al | ” button and watch the tools run in the build window. The
output file should automatically load.

11. Under Debug on the menu bar click “ Reset CPU’,“Restart”, and then “ Go
Mai n” . You should now be at the start of Mai n() .

Setup Watch Window
12. Open the watch window to view the variables used in the project.
Click: Vi ew - Watch W ndow on the menu bar.

Click the “Watch 1” tab at the bottom of the watch window. In the empty box in the
"Name" column, type the symbol names from the following screen capture and be sure to
modify the “Radix” as needed.

[z Watch Window =Jots
M ame Walue | Fiadix ]
& Gui_Yin 0.0 | gwalue(10]
& Gui_Wout[1] 0.0 | gqwalue(12)
& Gui_Yout[2] 0.0 | gralue(12]
@ Gui_lout1] (X1 | gwalue(d)
& Gui_lout[2] [IN1] | gwalue(3)
& Gui_Tdeq(1] 25.0000 | qwalue(B)
& Gui_Tdeg(2] 25.0000 | qwalue(B)
@ Duty1] 0o | gralue(15]
& Dun2) [IR1] | gralue(15]
W
o Watch Locals 37 Watch 1
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The following table gives a description for the variable names:

Variable Description

Gui _Vi n | Voltage input measurement (i.e. DC bus) to each buck power stage

Gui _Vout | Voltage output of each channel, 3 element array, zeroth element not used

Gui _l out | Current output of each channel, 3 element array, zeroth element not used

CGui _Tdeg | Temperature of each power module, 3 element array, zeroth element not

used

Duty[ 1] | Duty cycle input to BuckSi ngl e_DRV 1

Duty[ 2] | Duty cycle input to BuckSi ngl e_DRV 2

Save the Workspace

L.

Save the current workspace by naming it Lab1. wks and clicking:
File > Wrkspace > Save Wrkspace As...

and saving in C: \ Tl _28xxx_SysSW TwoChannel Buck\

Run the Code — TwoChannelBuck

13.

14.

15.

16.

17.

Enable real-time mode by selecting:

Debug > Real -tinme Mde

A message box may appear. If so, select YES to enable debug events. This will set bit 1
(DGBM bit) of status register 1 (ST1) to a “0”. The DGBM is the debug enable mask bit.
When the DGBM bit is set to “0”, memory and register values can be passed to the host
processor for updating the debugger windows.

Check to see if the windows are set to continuously refresh. Click:
View > Real -tinme Refresh Options...

and check “ d obal Conti nuous Refresh”.

Run the code by using the <F5> key, or using the Run button on the vertical toolbar, or
using Debug - Run on the menu bar.

Note that in the watch window all values should be ~ zero, except for temperature, which
should be approximately equal to room temperature of 25° C.

12
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Lab 1: PWM Generation / Open-Loop Control

18. Turn on the 9-volt DC bus (SW2) on the 2-channel buck EVM and observe variable
Qui _Vi n in the watch-window. It should now be approximately 9V.

19. Increase the value of Duty[1] to approximately 0.11. Power stage buck 1 module output
voltage should be approximately 1V on the DMM. Be sure that SW3 on the EVM is
positioned to select Chl. With two 2Q2 load resistors placed in parallel the equivalent
resistance across terminal 1 is 1Q. The open-loop voltage for Channel 1 is approximately

given by:
Voltage | Value of
Duty[1]
v 0.11
2V 0.22
3V 0.33

20. Try the same adjustment on Duty[2]. Be sure SW3 on the EVM is positioned to select
Ch2. Note that Channel 2 buck is lightly loaded with a lamp (2~3Q) and hence a slightly
lower Duty[2] value will give the same output voltage as in the Chl case. This is
expected since we are running the controller in an open loop.

21. Of general interest — during duty/voltage adjustments observe the various watch window
variables such as voltage, current and temperature. Gui_Vout should reflect
approximately the same value as the DMM display. The current measurement is not very
precise as it is designed to measure a range up to 15A. Hence at low current levels
accuracy will be quite poor. Temperature should track quite well and the channel
supplying the most power will show an observable temperature increase.

22. Turn off the 9-volt DC bus (SW2) on the 2-channel buck EVM. (Do not turn off the
main power SW1I).

23. Fully halt the DSP in real-time mode. First, halt the processor by using Shift <F5>, or
using the Hal t button on the vertical toolbar, or by using Debug - Hal t . Then click
Debug > Real -ti ne Mbde and uncheck the “ Real -ti me node” to take the
DSP out of real-time mode.

24. Do Not Close Code Composer Studio or it will be necessary to setup the project again
for the next lab exercise!

End of Exercise
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Lab 2: Closed-Loop Control
» Objective

The objective of this lab exercise is to demonstrate the topics discussed in this module and
regulate the output voltage of a buck power stage using closed-loop feedback control realized in
the form of a software coded loop. Soft-start and shut-down management will be explored using
the CCS watch window. ADC management for high-speed feedback and slow instrumentation
will be utilized. In this lab you will:

e Regulate buck outputs using Voltage Mode Control (VMC) with closed-loop feedback

o Use soft-start and sequencing fuctions to ensure an “orderly” voltage ramp-up/down

e Adjust the soft-start profile and target voltage using the CCS watch window

» Project Overview

The following Power Library modules will be used in this lab exercise. (Note: these are the same
library modules used in Lab1 exercise with the addition of more library modules).

C configure function ASM initialization macro ASM Run time macro

BuckSi ngl e CNF() BuckSi ngl eHR DRV_INI T n | BuckSi ngl eHR DRV n

ADC _Dual SeqCNF() ADC NchDRV_INIT n ADC_NchDRV n
None Control Law 2P2Z INIT n Control Law 2P2Z n
None Dat aLogTST_INIT n Dat aLogTST n

Below is a description and notes for the Power Library modules used in this lab exercise.

BuckSi ngl eHR_DRV | This is the high resolution PWM version of BuckSingle used in Lab2.
The C configure function (BuckSi ngl e _CNF) is applicable for both
high-resolution and non-high-resolution versions of macro.

ADC_NchDRV Reads 1 N ADC result registers every PWM cycle and stores to N
consecutive memory locations accessible by C. In Lab2, N=1 (i.e. a
single voltage is measured as feedback).

Control Law 2P2Z | This is a 2™ order compensator realized from an IIR filter structure.
The 5 coefficients needed for this function are declared in the C
background loop as an array of longs. This function is independent of
any peripherals and therefore does not require a CNF function call.

14 TMS320C2000™ Systems Applications Collateral



Lab 2: Closed-Loop Control

Dat aLogTST Data logging function with time-stamp trigger input. Although not
needed in the application itself, it provides a convenient way to
visualize the output voltage in a CCS graph window. In Lab3 the data
logger will be useful in displaying an output voltage transient.

> Lab Exercise Overview

The software in Lab2 has been configured to provide closed-loop voltage control for Channel 1
and Channel 2 of the buck EVM. Additionally, datalogging of the Channel 1 output voltage can
be displayed in a CCS graph window. Below is the system diagram for Channel 1 in Lab2.

SStartSEQ
O Buck | E
m Single \7\/ Vinl Voutl
CNTL HR |wm o—
» Delay 2P2Z DRV |
Slope Out > Vref[1] » Ref Uout > Duty[1}—>| Ia W EPWM1A RV
‘—y Target FB I
Voltage — —
Controlfer ADC [A) - -
NCH c Single P S
Gui Scaling DRV ingle Power Stage
(B Tasks) "
Voutl <« rslt0 W «— ADC-BO

Watch Window
6raph Window

Gui_Vset[1] Datalog

Gui_Sl pl1] -

Buffer

“: Gui_OnDelay[1]

il

Gui_OffDelay[1]

Note that the system diagram for Channel 2 would look exactly the same except for two key
changes:

e The index of all arrayed variables will be 2 instead of 1

e Channel 2 is not configured in software to have a datalogger and therefore it can not
display a transient graph

The closed-loop consists of only three modules — ADC_NchDRV, Cont r ol Law_2P2Z, and
BuckSi ngl eHR_DRV. When the code is runing these modules execute as in-line code (no
decision making) within the | SR_Run routine which is triggered at the PWM rate. To ensure
proper operation, Vref is kept at zero until a request is received to enable the output voltage. It is
important for a power supply to have a proper start-up and shut-down routine. This is managed by
the soft-start and sequencing code which executes in the main background C code
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Lab 2: Closed-Loop Control

TwoChannel Buck- Mai n. c. This code ensures that Vref can never have a step change, as
direct modification of Vref is not allowed. Vref can only be adjusted indirectly via a target value
request. This value will be reached at a given slew-rate. The slew-rate is programmable with
delay-on and delay-off time parameters which are useful for staggered sequencing of multiple
voltage rails.

In Lab2, the target voltage, slew-rate and delay-on/off parameters are conveniently modified via a
watch window. The soft-start and sequencing code is “scaleable” and can manage multiple
voltage rails, for example 2, 3...10 or more Vrefs. The interface to this code is via several integer
arrays and integer flags. The array index “n” is used to designate the channel number (i.e. n=1 for
channel 1, n=2 for channel 2...etc.) Although in C an index of n=0 is valid, it is not used here.

Below is a summary of the arrays and their usage.

Qui _Vset[n] Desired output target voltage in Q12 format

Enables (allows) voltage output to reach target value
e.g. Channel Enabl e[ 1] =1, turn channel 1 “on”
e.g. Channel Enabl e[ 1] =0, turn channel 1 “off”

Channel Enabl e[ n]

) Step size or rate at which the target voltage is ramped to. Displayed in
Gui _Sl ewSt ep[ n] Q13 with units of V/ms

. Delay time to turn on from the “global” start command (St ar t Up=1)
Gui _OnDel ay[ n] Displayed in QO format with units of ms.

Delay time to turn off from the “global” stop command (St ar t Up=0)

Qui _O'f Del ay[ n] Displayed in QO format with units of ms.

Global turn on/off command. Used to synchronize/sequence all
channels

e.g. St ar t Up=1, global turn on command

e.g. St ar t Up=0, global turn off command

Start Up

> Procedure

Open a CCS Project

1. Code Composer Studio should still be running from the previous lab exercise. If it is not,
then it will be necessary to setup the debug environment and project from the previous
lab exercise. This can be done by simply loading the last saved workspace. Click:

File > Wrkspace -> Load Wrkspace

In the new window browse open:

C\ Tl _28xxx_SysSW TwoChannel Buck\ Lab1. wks
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Device Initialization, Main, and ISR Files

2. Open TwoChannel Buck- Set ti ngs. h. For this lab we will use incremental build
option 2. Please edit the file so that INCR_BUILD is defined as 2

(i.e. #def i ne 1 NCR_BUI LD 2).

then save the file by clicking:

File - Save

Note: This should be the only change nade to source files for
this |ab.

3. Open and inspect TwoChannel Buck- Mai n. ¢ by double clicking on the filename in
the project window. Notice the code enabled when INCR_BUILD is 2. This section of
code is shown here for convenience. Comments have been added in italics.

e e

#if (INCRBU LD == 2) // Cosed Loop CHL & CH2, with SoftStart using separate lib
/1 bl ocks
e e

/| #defi ne prd 500 /1l Period count = 200 KHz @ 100 Mz

#def i ne prd 333 // Period count = 300 KHz @ 100 MHz

/| #defi ne prd 250 /] Period count = 400 KHz @ 100 MHz

#def i ne NumAct vCh 2 /'l Nunmber of Active Channels

/1 "Raw' (R) ADC neasurenent nane defines, ADC result registers are mrrored
/1 in single cycle read nenory for faster access.

#def i ne Vout RL  AdcM rror. ADCRESULTO

#def i ne Vout R2  AdcM rror. ADCRESULT1

#defi ne loutRL AdcM rror. ADCRESULT8

#def i ne loutR2  AdcM rror. ADCRESULT9

#defi ne TdegR1L  AdcM rror. ADCRESULT10

#defi ne TdegR2  AdcM rror. ADCRESULT11

#defi ne Vi nR AdcM rror. ADCRESULT12

#def i ne tPHS2 37 /'l Phase offset from Master EPWM

ADC Sequencer 1— Vout[1] and Vout[2] used every PWM cycle
/1 ADC Channel Sel ection for Sequencer-1
ChSel [ 0] 8; /1 BO — Vout Rl
ChSel [ 1] 0; /1 A0 — Vout R2

ADC Sequencer 2 — Instrumentation only, round robin scheme
/1 ADC Channel Sel ection for Sequencer-2

ChSel [8] = 9; /1 Bl — loutRL
ChSel [9] = 1; /1 Al — loutR2
ChSel [10] = 10; /1 B2 — TdegRl
ChSel [ 11] = 2; /1 A2 — TdegR2
ChSel [12] = 11, /1 B3 - Vin

Soft-Start parameters for channel 1 &

Qui _OnDel ay[ 1] = O;

Gui _OnDel ay[ 2] = 1000; /1 1 second del ay
Qui _OfDel ay[ 1] = 1000; /1 1 second del ay
Qui _OfDelay[2] = O;

Qui _Vset[1] = 7413; /1 1.8V

Qui _Vset[2] = 13557, /1 3.3V

C2000 System Applications Collateral 17



Lab 2: Closed-Loop Control

Used for Scope feature via Graph window (Setup for CHI)

Gui _Sl ewst ep[ 1]
Qui _Sl ewst ep[ 2]

2048;
2048;

Dat aLogTri gger = 980000;
ScopeGain = 1;
ScopeACnode = 0;

PWM and ADC configure functions

/1

/1

/1

Datalogger is an optional feature, not required for loop to run
DLTST = Dat aLogTi meSt anpTri gger

/1

BuckSi ngl e_CNF(1, prd, 1, 0);

BuckSi ngl e_CNF(2, prd, 0, tPHS2);
EPwnilRegs. CMPB = 193;
/1 EPwnRRegs. CVPB = 120;
EPw2Regs. CMPB = 60;
ADC Dual SeqCNF(ChSel, 1, 2, 1);
ISR Init();
Li b Modul e connection to "nets"
ADC f eedback connecti ons
ADC Rslt = &AdcNet Bus[1];
————————————————————————— CHANNEL- 1

CNTL_2P2Z( 1) connections
CNTL_2P2Z_Ref1 = &Vref NetBus[1];
CNTL_2P2Z CQut1l = &Uout Net Bus[ 1] ;
CNTL_2P2Z_Fdbkl = &AdcNet Bus[ 1] ;
CNTL_2P2Z_Coef 1 = &Coef 2P2Z_1[ 0] ;

BUCK_DRV connecti ons
Buck_I n1 = &Uout Net Bus[ 1] ;

CNTL_2P2Z(2) connections
CNTL_2P2Z_Ref 2 = &Vref Net Bus[ 2] ;
CNTL_2P2Z_CQut2 = &Uout Net Bus[ 2] ;
CNTL_2P2Z_Fdbk2 = &AdcNet Bus[ 2] ;
CNTL_2P2Z_Coef 2 = &Coef 2P2Z_2[ 0] ;

BUCK_DRV connecti ons
Buck_I n2 = &Uout Net Bus|[ 2] ;

Dat a Logger connections,
DLTST_I n1 = &AdcNet Bus[ 1] ;

DLTST_Ti meBasel = &ECaplRegs. TSCTR:

/1
/1

/1

DLTST_Ti neStanpTri gl = &DatalogTri gger;

DLTST _DcOffsetl = O;
DLTST_Gai nl1 = ScopeGai n;

0.25 V/ns
0.25 V/ s

DC node initially

Phase=0
Phase=t PHS2

ePWML, Period=prd, Master,
ePWR, Period=prd, Sl ave,
tCWPBl - | SR trigger point
tCMPB2 - ADC SOS trigger point

t CVMPB2 - ADC SOS trigger point
ACQPS=1, Seql#Conv=2, Seq2#Conv=1
ASM ISR init

point to 1st elenent, i.e. AdcChO

Vrefl
Uout 1
result
first coeff of 1st

point to
point to
1st conv
point to | oop

Chl = ePWMLA

point to Vref2
point to Uout2
2nd conv result
point to first coeff of 2nd | oop

Ch2 = ePWWRA

Compare B event setup to trigger both Sequencer 1 & 2 simultaneously, note: Seql has priority

/1

Trigger ADC SCCA & B from EPW/L
EPwnllRegs. ETSEL. bi t . SOCASEL =
EPwnllRegs. ETSEL. bi t . SOCBSEL =
EPwnllRegs. ETSEL. bi t . SOCAEN = 1;
EPwnllRegs. ETSEL. bi t . SOCBEN = 1;
EPwnlRegs. ETPS. bi t . SOCAPRD = ET_1
EPwnlRegs. ETPS. bi t . SOCBPRD = ET_1

#endi f // (1NCR BU LD == 2)

SOCA on CWVPB event
SOCB on CWVPB event
/1 Enable SCC on A group
/1 Enabl e SCC on B group
/1 Trigger on every event
/1 Trigger on every event

18
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4. Open and inspect TwoChannel Buck- | SR. asm Notice the _| SR I ni t and
_I' SR_Run sections. This is where the PWM driver macro instantiation is done for
initialization and run-time, respectively. The code is shown below for convenience. In
Lab2, incremental build option 2 is used. Note the order for the run time macros:

1) Measure feedback
2) Compensate
3) Update PWM

Also, the ADC is not run in continuous mode, but rather in SOC trigger mode, and

therefore needs to be reset every cycle.

;--- Initialization Tinme
i f(INCR_BU LD = 2)

ADC_NchDRV_INIT 2

Control Law_2P2Z_I N

Control Law_2P2Z_I N

|

|

;2 Channel, (i.e. N=2)

BuckSi ngl eHR DRV INIT 1 . EPWMLA
BuckSingl eHR DRV_INI T 2 ;. EPWWRA
Dat aLogTST_INIT 1 ;1 Channel Data | ogger

.endif

;--- Run Each Time ISR is Ran
.if(INCR BU LD = 2)

ADC_NchDRV 2 ;1 Channel, (N=2) (Measur e)
Control Law_2P2Z 1 ( Conpensat e)
Control Law_2P2Z 2

BuckSi ngl eHR_DRV 1 ;. EPWMLA (Updat e)
BuckSi ngl eHR_DRV 2 . EPWWRA

Dat aLogTST 1
ADC_Reset :
MOVW  DP, #ADCTRL2>>6

;1 Channel Data | ogger

; Reset ADC SEQ

MoV @\DCTRL2, #0x4101 ; RST_SEQL=1, SOCA-SEQL=1, SOCB-SEQ=1

.endif

5. Close the inspected files if desired.

Build and Load the Project

6. Click the “ Rebui | d Al | " button and watch the tools run in the build window. The
output file should automatically load.

7. Under Debug on the menu bar click “ Reset CPU’,“Restart”, and then “ Go
Mai n” . You should now be at the start of Mai n() .

Setup Watch Window and Graph

8. Another watch window will be opened in addition to the one used in the previous lab
exercise. Open the watch window to view the variables used in the project.

Click: Vi ew > Wat ch W ndow on the menu bar.
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Click the “Watch 1” tab at the bottom of the watch window. In the empty box in the
"Name" column, type the symbol names from the following screen capture and be sure to
modify the “Radix” as needed.

F Watch Window =JoEd
M arne: Walue ] R adix |
& ChannelEnable{1] | a dec
% ChannelEnable2] | o dec
& Gui_Vael[1] | 1.80881 gralue12)
& Gui_Vaet[2] | 330581 gralue12)
& Gui_OnDelay[1] |a dec
& Gui_OnDelay[2] | 1000 dec
@ Gui_0fDelay1] | 1000 dec
@ Gui OfDelav[2] | a dec
@ Gui_SlewStep(1] | 025 gqraluel13)
& Gui_SlewStep[2] R gralue(13)
% Startlp |0 dec
& Scopelain ) 1 .dec
& ScopedCmode ) 1] .dec
@ ActiveLoad |n dec
@ Pgain 11 dec
& |gain 11 dec
& Dgain | B dec
2 .
& Watch Locals o4 Watch 1

Note: ScopeGai n, ScopeACnode, Act i veLoad, Pgai n, | gai n, and Dgai n will be
explained and used in the next lab exercise.

The following table gives a description for the variable names:

Variable Description

Channel Enabl e Channel enable array

Qui _Vset Voltage target array

Qi _OnDel ay DelayOn array

Qui _Of f Del ay DelayOff array

Gui _Sl ewSt ep Ramp step size array

Start Up Global turn-on/turn-off integer flag

9. Open and setup a time graph windows to plot the data log buffer (ADC result register).
This graph will show the output voltage of Channel 1.

Click: Vi ew > Graph > Ti e/ Frequency...and set the following values:

20
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Graph Property Dialog
Dizplay Type Single Time @
Graph Title Graphical Digplay
Start Address DLogBuffer
Page Data
Acquisition Buffer Size 300
Index Increment 1
Dizplay D ata Size 300
DSP Data Type 16-bit sighed integer
3-value 0
Sampling Rate [Hz) 1
Plot D ata From Left to Right
Left-shifted Data Display Yes
Autoscale aff
DC Value 0
I axinum Y -walue 32000
Ames Dizplay 0
Time Dizplay Uit T
Statuz Bar Displap uli;
M agnitude Display Scale Linear
[rata Plot Style Line
Gnd Style Zero Line
Curzor Mode Mo Cursor
k. | Cancel | Help J

Select OK to save the graph options.

Save the Workspace

10. Save the current workspace by naming it Lab2. wks and clicking:
File > Wrkspace -> Save Wrkspace As...

and saving in C: \ TI _28xxx_SysSW TwoChannel Buck\ .

Run the Code — TwoChannelBuck

11. Enable real-time mode by selecting:

Debug > Real -tinme Mde

12. A message box may appear. If so, select YES to enable debug events. This will set bit 1
(DGBM bit) of status register 1 (ST1) to a “0”. The DGBM is the debug enable mask bit.
When the DGBM bit is set to “0”, memory and register values can be passed to the host
processor for updating the debugger windows.

13. Check to see if the windows are set to continuously refresh. Click:
View > Real -tinme Refresh Options...

and check “ d obal Conti nuous Refresh”.
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14.

15.

16.

17.

18.

19.

20.

Run the code by using the <F5> key, or using the Run button on the vertical toolbar, or
using Debug > Run on the menu bar.

Turn on the 9-volt DC bus (SW2) on the 2-channel buck EVM and observe variable
Qui _Vi n in the watch-window. It should now be approximately 9V. Also the Graph
window should show a trace hovering at “0V”’.

In the watch window turn on Channel 1 output by setting Channel Enabl e[ 1] =1.
Power stage buck 1 module output voltage should ramp quickly to ~1.8V (be sure that
SW3 on the EVM is positioned to select Chl). Note that directly turning-on (enabling) an
individual channel ignores the Gui _OnDel ay and Gui _Of f Del ay parameters since
synchronization to a global trigger is not utilized.

Enable Channel 2 output by setting Channel Enabl e[ 2] =1. Power stage buck 2

module output voltage should new ramp quickly to ~3.3V (this can be verified by setting
SW2 to select Ch2 and checking the value on the display). Also note that LMP1, the load
for Channel 2, is now lit.

Decrease the value of Gui _Vset [ 1] and Gui _Vset [ 2] to approximately 1.0. The
voltage output of both power stage buck 1 and power stage buck 2 should now be
updated to 1.0V. In the watch windows notice that Gui _| out [ 2] is less than

Qui _l out [ 1] . This is because the LMP1, the load of Channel 2, has more resistance
than the 1Q resistance found across Channel 1. When you are done turn off Channel 1
and Channel 2 by setting Channel Enabl e[ 1] =0 and Channel Enabl e[ 2] =0.

Both channels can also be enabled or disabled by using the global turn-on flag —

St ar t Up. This flag allows for time sequencing of Channel 1 and 2 and uses

Qui _OnDel ay and Gui _Of f Del ay to give the delay before turning on/off each
channel. These values may be modified in the watch window and are set by default to:

Qui _OnDel ay[ 1] = 0;

Qui _OnDel ay[ 2] = 1000; /1 1 second del ay
Qui _OfDelay[1] = 1000; /1 1 second del ay
Qui _OfDelay[2] = O;

For example, modify these values as follows:

Qui _OnDel ay[ 1] =1000
Qui _OnDel ay[ 2] =5000

Qui _OF f Del ay[ 1] =7500
Qui _OF f Del ay[ 2] =2500

Start Up=1

This will trigger the global turn flag. Then Channel 1 will start ramping up after 1000 ms
and Channel 2 will start ramping after 5000 ms. Setting St ar t Up=0 will trigger a
global turn off which will cause Channel 1 to ramp down after 7500 ms and Channel 2 to
begin ramping down after 2500 ms.

22
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21. The ramp-up and ramp-down rates can also be modified for either Channel 1 or Channel
2. In this lab code, up and down ramp rates are the same. The ramp rate for Channel 1 is
set by the parameter QUi _ Sl ewSt ep[ 1] , and the ramp rate of Channel 2 is set by
Qui _Sl ewSt ep[ 2] The default value for both is 0.25 V/ms. Change both to 0.005
V/ms in the watch window and view the result. Follow these steps:

Qui _Sl ewsSt ep[ 1] =0. 005
Qui _Sl ewsSt ep[ 2] =0. 005

Channel Enabl e[ 1] =1 Outputs should now ramp up at slow rate
Channel Enabl e[ 2] =1

Channel Enabl e[ 1] =0 Outputs should also ramp down at a slow rate
Channel Enabl e[ 2] =0

22. Turn off the 9-volt DC bus (SW2) on the 2-channel buck EVM. (Do not turn off the
main power SWI).

23. Fully halt the DSP in real-time mode. First, halt the processor by using Shift <F5>, or
using the Hal t button on the vertical toolbar, or by using Debug - Hal t . Then click
Debug > Real -ti me Mode and uncheck the “ Real -ti me node” to take the
DSP out of real-time mode.

24. Do Not Close Code Composer Studio or it will be necessary to setup the debug
environment windows again for the next lab exercise!

End of Exercise
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Lab 3: Tuning the Loop
» Objective

The objective of this lab exercise is to demonstrate the topics discussed in this module and tune
the closed-loop buck power stage for improved transient performance using visual “trial and
error” methods rather than a mathematical approach. The transient response will be modified by
interactively adjusting the system proportional (P), integral (I), and derivative (D) gains using the
watch window. An active load circuit enabled by software will provide a repetitive step change in
load. The CCS graph window feature will be used to view the transient response in real-time. The
Digital Power software framework, associated files, and library modules will be used. In this lab
you will:

e Tune closed-loop Buck power stage for improved transient performance using visual
“trial and error” approach (as opposed to a mathematical approach)

e Use an active load circuit which, when enable by software, provides a repetive step
change in load

e Use the CCS graph window feature to view and assist you in achieving a desired transient
response

> Project Overview

The software code used in Lab3 is exactly the same code as used in Lab2. All of the files and
build options are identical. The five coefficients to be modified are stored in the arrays

Coef 2P2Z and_1 Coef 2P2Z 2[ n] . Directly manipulating these five coefficients
independently by trial and error is almost impossible, and requires mathematical analysis and/or
assistance from tools such as MATLAB, MathCad, etc. These tools offer Bode plot, root locus
and other features for determining phase margin, gain margin, etc.

To keep loop tuning simple and without the need for complex mathematics or analysis tools, the
coefficient selection problem has been reduced from five degrees of freedom to three, by
conveniently mapping the more intuitive coefficient gains of P, I and D to B0, B1, B2, A1, and
A2. This allows P, I, and D to be adjusted independently and gradually. This method requires a
periodic transient or disturbance to be present, and a means to observe it while interactively
making adjustments. The data-logging feature introduced in Lab2 provides a convenient way to
observe the output transient while the built-in active load (controlled by the ECAP peripheral) on
the EVM can provide the periodic disturbance.

The compensator block (macro) used is Cont r ol Law_2P2Z. This block has 2 poles and 2
zeros and is based on the general IIR filter structure. The transfer function is given by:

U(Z) B bo+biz"' + bz

E(Z) B l+aiz” +axz™?
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The recursive form of the PID controller is given by the difference equation:

u(k)=u(k —1)+ boe(k) + bre(k —1)+ bae(k —2)

where:
bo= K"+ Ki'+Kd'
b =-K,'"+K'-2K.'
b= Ka'

And the z-domain transfer funcion form of this is:

U(Z) _ bo+ bz + boz™? _ boz® + biz + b>
E(Z) -z -z

Comparing this with the general form, we can see that PID is nothing but a special case of a
2pole/2zero controller where:

ar=-1and a2=0
In the lab exercise, you will inspect the C code in which these coefficients are initialized.
Lab Exercise Overview

In Lab2 the software was configured to provide closed-loop voltage control for Chl of the buck
EVM and datalogging of the output which is displayed in a CCS graph window. Lab3 will
additionally allow modification of the five coefficients associated with the 2™ order

Cont r ol Law_2P2Z compensator block. This modification will be done “on the fly” by editing
Pgai n, | gai n and Dgai n in the watch window while the buck output is put under transient
stresses. These stresses are caused by an active load which is switched periodically by the ECAP
peripheral. Note that because the active load is connected to Channel 1, Channel 2 will not be
used in this lab.

The following figure is the system diagram for Lab3.
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Watch Window

PID_ Coeff.
Mapping
(325) B2
B1
BO
A2
SSartSEQ A1
L Buck | E
@_ l Single \'I:V Vin Voutl
R CNTL HR I'm o0—
» Delay 2P2Z DRV y
» Slope  Out > Vref » Ref youtlp Duty[1]»| In W~ EPWMIA DRV
|—> Target —>» FB I
Voltage — —
Controller ADC S - -
. . 1CH .
Gui Scaling DRV c Single Power Stage
(B Tasks) m
p—— VoutR1l — rslt0 W [« ADC-BO

\\ Watch Window Graph Window
1 ohm

2 oh 2 oh:
Gui_Vset[1]
DataLog

Gui_SlewStep[1] N~

- Mem

> 0 Bt ?]

“1 Gui_OnDelay[1] DRV
Gui_OffDelay[1] — —
ECAP1 Active Load

The default coefficient settings chosen for Lab2 provide very poor performance (low gains).
Initially Lab3 will use the same settings. The control loop will be soft-stared to the target Vout
value, the same way it was done in Lab2. At this point, the active load will be enabled and a load
resistor of equal value to the static load will be switched in and out periodically.

In addition to the watch window variables discussed in Lab3, a few others will be used in the loop
tuning process. These include the P, I and D gains, active load enable, and CCS graph window
(scope control). The table below summarises these new variables.

Pgai n Proportional gain; value adjustment : 0 ~ 1000
I gain Integral gain; value adjustment : 0 ~ 1000
Dgai n Derivative gain; value adjustment : 0 ~ 1000

ActivelLoad | Enable (value=1)/ Disable (value=0) flag for the active load circuit

ScopeACnode | Sets the CCS Scope (graph window) to operate in AC mode (i.e. removing the
DC component) and is useful for zooming into the transient only

Scope@ai n Vertical gain adjustment for the CCS scope (much like a real oscilloscope)

26
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> Procedure

Open a CCS Project

1. Code Composer Studio should still be running from the previous lab exercise. If not, then
it will be necessary to setup the project and debug environment from the previous lab
exercises. This can be done by simply loading the last saved workspace. Click:

File > Wrkspace -> Load Wrkspace
In the new window browse open:

C \ Tl _28xxx_SysSW TwoChannel Buck\ Lab2. wks

Device Initialization, Main, and ISR Files

2. Open TwoChannel Buck- Set ti ngs. h. For this lab we will use incremental build
option 2. Please verify that INCR_BUILD is defined as 2
(i.e. #define 1 NCR_BUI LD 2).

If the incremental build is not 2, please edit the file then save it by clicking:

File - Save

Not e: This should be the only change nade to source files for
this I ab.

3. Open and inspect TWwoChannel Buck- Mai n. ¢ by double clicking on the filename in
the project window. Notice the coefficient initialization and P, I, and D mapping
equation. A section of code is shown here for convenience.

Pgain = 1; lgain = 1; Dgain = 5; /1 very "loose" initially
/1 Coefficient init for Single Loop
Coef 2P2Z_1[0] = Dgain * 67108; /Il B2
Coef2P2Z_1[1] = (lgain - Pgain - Dgain - Dgain)*67108; // Bl
Coef 2P2Z_1[2] = (Pgain + lgain + Dgain)*67108; /1 BO
Coef 2P2Z_1[3] = 0; /Il A2 =0
Coef 2P2Z_1[ 4] = 67108864, /I ALl =1in Q6
Coef 2P2Z_1[5] = Dmax[1l] * 67108; // Canmp H limt (Q6)
Coef 2P2Z_1[ 6] = 0x00000000; // danp Lo

(Note: 67108 =~ 0.001 in Q26 format)

4. Close the inspected files if desired.

Build and Load the Project

5. Click the “ Rebui | d Al | ” button and watch the tools run in the build window. The
output file should automatically load.
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6.

Under Debug on the menu bar click “ Reset CPU’, " Restart”, and then “ Go
Mai n” . You should now be at the start of Mai n() .

Save the Workspace

7.

The watch windows and graph window were setup in the previous lab exercise. A
workspace needs to be saved to include the project for this lab exercise. Save the current
workspace by naming it Lab3. wks and clicking:

File > Wrkspace > Save Wrkspace As...

and saving in C: \ TI _F28xxx_SysSW TwoChannel Buck\ .

Run the Code — TwoChannelBuck

8.

10.

11.

12.

13.

14.

Enable real-time mode by selecting:

Debug > Real -tinme Mde

A message box may appear. If so, select YES to enable debug events. This will set bit 1
(DGBM bit) of status register 1 (ST1) to a “0”. The DGBM is the debug enable mask bit.
When the DGBM bit is set to “0”, memory and register values can be passed to the host
processor for updating the debugger windows.

Check to see if the windows are set to continuously refresh. Click:
View > Real-tinme Refresh Options...

and check “ d obal Conti nuous Refresh”.

Run the code by using the <F5> key, or using the Run button on the vertical toolbar, or
using Debug > Run on the menu bar.

Turn on the 9-volt DC bus (SW2) on the TwoChannelBuck EVM and observe variable
Qui _Vi n in the watch-window. It should now be approximately 9V. Also the Graph
window should show a trace hovering at “0V”.

In the watch window turn on Channel 1 output by setting Channel Enabl e[ 1] =1.
Power stage buck 1 module output voltage should ramp quickly to ~1.8V (be sure that
SW3 on the EVM is positioned to select Chl).

Enable the active load circuit by setting variable Act i veLoad = 1 in the watch
window. To better view only the transient or AC component of the output voltage, set the
graph to AC mode by changing variable ScopeACnode = 1. This should put the
output waveform at the graph “zero” line. Optionally, set the scope gain higher by
changing variable ScopeGai n = 4. If lab is working correctly, then the graph window
should look something like the following:

28
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EE| Graphical Display

T "J/.n

The negative going transient is when the extra load is switched in and the positive going
overshoot is when the extra load is removed.

15. While observing the transient in real time, gradually adjust Pgain, Igain, and Dgain in the

Watch Window to get the best transient response (i.c. least pertubation from the zero

line). Gradual adjustment is recommended as a large change may cause the system to go
unstable. A suggested procedure is given below:

Gradually increase Igain until the negative going transient flattens out near the
zero line

Increase Pgain until some oscillation (2~3 cycles) occurs
Increase Dgain to remove some of the oscillation
Increase Igain again

keep iterating very gradually until an acceptable transient response is achieved —
this may look something like the graph shown below:

E5| Graphical Display. =10l x|

16. Reduce the scope vertical gain back to 1 (ScopeGai n = 1) and set the graph back in

DC mode (ScopeACnode = 0). The voltage output response should look something

like this now:
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17. With the active load still enabled, try shutting down Channel 1 output and then bringing it
back up under “soft” shut-down and start-up conditions. The closed loop should be stable
during the ramping even during the switching transients.

18. Turn off the 9-volt DC bus (SW2) on the 2-channel buck EVM. (Do not turn off the
main power SW1I).

19. Fully halt the DSP in real-time mode. First, halt the processor by using Shift <F5>, or
using the Hal t button on the vertical toolbar, or by using Debug - Hal t . Then click
Debug - Real -ti me Mode and uncheck the “ Real -ti me node” to take the
DSP out of real-time mode.

20. Close Code Composer Studio and turn off the power (SW1) to the 2-channel buck EVM.

End of Exercise
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References

QSG-TwoChannelBuck — provides all the information on software and hardware setup
necessary to quickly get started with the TwoChannelBuck project.

C:\Tl_28xxx_SysSW\TwoChannelBuck\~Docs\QSG-TwoChannelBuck.pdf

System Framework Overview — presents more information on the system framework found
in all F28xxx EVM projects.

C:ATI_28xxx_SysSW\~Docs\SystemFrameworkOverview.pdf

QSG-TwoChannelBuck-GUI — gives an overview on how to quickly demo the
TwoChannelProject using an intuitive GUI interface.

C:\TI_28xxx_SysSW\TwoChannelBuck\~Docs\QSG-TwoChannelBuck-GUI.pdf

TwoChannelBuck-Calculations — a spreadsheet showing a few of the key calculations
made within the TwoChannelBuck project.

C:ATI_28xxx_SysSW\TwoChannelBuck\TwoChannelBuck-Calculations.xls

TwoChBuck-HWdevPkg — a folder that contains various files related to the hardware on the
EVM board (schematics, bill of materials, gerber files, pcb layout, etc). All schematics and
pcb files created with the freeware ExpressPCB package.

C:ATI_28xxx_SysHW\TwoChBuck-HWdevPkg

F28xxx User’s Guides -

htto://www.ti.com/f28xuserquides
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