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欢迎使用 Protel DXP 

欢迎来到 Protel DXP 世界--Protel DXP 是一款 Windows NT/XP 的全 32 位电子设计系统。Protel DXP 提供一套完

全集成的设计，这些工具让你很容易地将你的设计从概念形成 终的板设计。 

所有的 Protel DXP 工具需要在一个单一应用环境--设计探索者（the Design Explorer）中运行。启动 Protel DXP，

设计探索者打开，将你所有的设计工具放在你的手指尖。你将从一个单一的、一致的、个性化的用户环境受益。 

这个教程的设计是为了为你提供一个怎样建立一张原理图、从 PCB 更新设计信息以及产生生产输出文件的预览。 

Protel DXP 设计探索者 

设计探索者是你与你的设计和设计工具的界面。要启动 Protel 并打开设计探索者，从 Windows 开始菜单选择

Programs » Altium » Protel DXP。当你打开 Protel DXP 后，将显示 常用的初始任务以便方便选择（如图）。 



 

在你建立了你的设计文件夹后，你就能在编辑器之间转换，例如，原理图编辑器和 PCB 编辑器。设计探索者将根

据你当前所工作的编辑器来改变工具栏和菜单。一些工作区面板的名字 初也会显示在工作区右下角。在这些名

字上点击将会弹出面板，这些面板可以通过移动、固定或隐藏来适应你的工作环境。 

下图展示了当几个文件和编辑器同时打开并且窗口进行平铺时的设计探索者。 

  

设计文件怎样保存 

Protel DXP 将所有的设计文件和输出文件都作为个体文件保存在你的硬盘。你可以使用 Windows Explorer 来查找。

项目文件可以的建立可以包含设计文件的连接，这样使得设计验证和同步成为可能。 

创建一个新项目 

在 Protel DXP 中，一个项目包括所有文件夹的连接和与设计有关的设置。一个项目文件，例如 xxx.PrjPCB，是

一个 ASCII 文本文件，用于列出在项目里有哪些文件以及有关输出的配置，例如打印和 CAM。那些与项目没有关联的文件称作

“自由文件（free  documents）”。与原理图纸和目标输出的连接，例如 PCB、FPGA、VHDL 或库封装，将添加到项目中。一

旦项目被编辑，设计验证、同步和对比就会产生。例如，当项目被编辑后，项目中的原始原理图或 PCB 的任何改变都会被更新。 



建立一个新项目的步骤对各种类型的项目都是相同的。我们将以 PCB 项目为例。首先我们要创建一个项目文件，然后创建一个

空的原理图图纸以添加到新的空项目中。在这个教程的 后我们将创建一个空白 PCB 并将它同样添加到项目中。 

为开始教程，创建一个新的 PCB 项目： 

1、在设计窗口的 Pick a Task 区中点击 Create a new Board Level Design Project。 

 

另外，你以可以在 Files 面板中的 New 区点击 Blank Project (PCB)。如果这个面板未显示，选择 File » New，或点击设

计管理面板底部的 Files 标签。 

2、Projects 面板出现。新的项目文件，PCB Project1.PrjPCB，与“no documents added”文件夹一起列出。 

 

3、通过选择 File »Save Project As 来将新项目重命名（扩展名为*.PrjPCB）。指定你要把这个项目保存在你的硬盘上的位

置，在文件名栏里键入文件名 Multivibrator.PrjPCB并点击 Save。 

下面，我们将创建一个原理图并添加到空项目文件。这个原理图是一个多谐振荡器电路。 

创建一个新的原理图图纸 

创建一个新的原理图图纸按照以下步骤来完成： 

1、在 Files 面板的 New 单元选择 File » New 并点击 Schematic Sheet。一个名为 Sheet1.SchDoc的原理图图纸出现在设计窗

口中，并且原理图文件夹也自动地添加（连接）到项目。这个原理图图纸现在列表在 Projects 标签中的紧挨着项目名下的

Schematic Sheets 文件夹下。 



 

2、通过选择 File » Save As 来将新原理图文件重命名（扩展名为*.SchDoc）。指定你要把这个原理图保存在你的硬盘中的

位置，在文件名栏键入 Multivibrator.SchDoc，并点击 Save。 

3、当空白原理图纸打开后，你将注意到工作区发生了变化。主工具栏增加了一组新的按钮，新的工具栏出现，并且菜单栏增

加了新的菜单项。现在你就在原理图编辑器中了。 

你可以自定义工作区的许多模样。例如，你可以重新放置浮动的工具栏。单击并拖动工具栏的标题区，然后移动鼠标重新定位

工具栏。改变工具栏，可以将其移动到主窗口区的左边、右边、上边或下边。 

现在我们可以在设计开始之前将我们的空白原理图添加到项目中了。 

将原理图图纸添加到项目中 

如果你想添加到一个项目文件中的原理图图纸已经作为自由文件夹被打开，那么在 Projects 面板的 Free Documents

单元 schematic document 文件夹上右击，并选择 Add to Project。现在这个原理图图纸就列表在 Projects 标签中的紧挨着项目

名下的 Schematic Sheets 文件夹下，并连接到项目文件。 

设置原理图选项 

在你开始绘制电路图之前首先要做的是设置正确的文件夹选项。完成以下步骤： 

1、从菜单选择 Design » Options，文件夹选项对话框打开。作为本教程，在此我们唯一需要修改的是将图纸大小（sheet size）

设置为标准 A4 格式。在 Sheet Options 标签，找到 Standard Styles 栏。点击输入框旁的箭头将看见一个图纸样式的列表。 

2、使用滚动栏来向上滚动到 A4 样式并点击选择。 

3、点击 OK 按钮关闭对话框，更新图纸大小。 



4、为将文件再全部显示在可视区，选择 View » Fit Document。 

在 Protel DXP 中，你可以通过只按菜单热键（在菜单名中带下划线的字母）来激活任何菜单。以后任何菜单项也将有你可以

用来激活该项的热键。例如，对于选择 View » Fit Document 菜单项的热键就是在按了 V 键后按 D 键。许多子菜单，诸如 Edit » 

DeSelect 菜单，是可以直接调用的。要激活 Edit » DeSelect » All 菜单项，你只需要按 X 键（用于直接调用 DeSelect 菜单）及 A

键。 

下面我们将进行一般的原理图参数设置： 

1、从菜单选择 Tools » Preferences（热键 T，P）打开原理图参数对话框。这个对话框允许你设置全部参数，这些将应用到你

将继续工作的所有原理图图纸。 

2、点击 Default Primitives 标签以使其为当前，勾选 Permanent。点击 OK 按钮关闭对话框。 

3、在你开始绘制原理图之前，保存这个原理图图纸，因此选择 File » Save（热键 F，S）。 

绘制原理图 

你现在准备开始绘制原理图了。在这个教程中，我们将使用如下图（Figure 1）所示的电路。这个电路用了两个 2N3904

晶体管来完成自激多谐振荡器。 

 

定位元件和加载元件库 

管理数以千计的原理图符号也包括在 Protel DXP 中，原理图编辑器提供强大的库搜索功能。尽管我们需要的元件

已经在默认的安装库中，但对于知道怎样通过库搜索来找到元件还是很有用的。通过以下步骤的操作来定位并添

加本教程电路所要用到的库。 

首先我们要查找晶体管，两个均为 2N3904。 



 

1、点击 Libraries 标签显示库工作区面板。 

2、在库面板中按下 Search 按钮，或选择 Tools» Find Component。这将打开查找库对话框。 

3、确认 Scope 被设置为 Libraries on Path，并且 Path 区含有指向你的库的正确路径。如果你接受安装过程中的默认目

录，路径中会显示 C:\Program Files\Altium\Library\。确认 Include Subdirectories 未被选择（未被勾选）。 

4、我们想查找所有与 3904 有关的，所以在 Search Criteria 单元的 Name 文本框内键入*3904*。 

5、点击 Search 按钮开始查找。当查找进行时 Results 标签将显示。如果你输入的规则正确，一个库将被找到并显示在查找库

对话框。 

6、点击 Miscellaneous Devices.IntLib库以选择它。 

7、点击 Install Library 按钮使这个库在你的原理图中可用。 

8、关闭 Search Libraries 对话框。 

添加的库将显示在库面板的顶总。如果你点击上面列表中的库名，库中的元件会在下面列表。面板中的元件过滤器可以用来在

一个库内快速定位一个元件。 

在原理图中放置元件 

在原理图中我们首先要放置的元件是两个晶体管（transistors），Q1 和 Q2。 



1、从菜单选择 View » Fit Document（热键 V、D）确认你的原理图纸显示在整个窗口中。 

2、点击 Libraries 标签以显示 Libraries 面板。 

3、Q1 和 Q2 是 BJT 晶体管，点击 Miscellaneous Devices.IntLib库使其为当前库。 

4、使用过滤器快速定位你需要的元件。默认通配符（*）将列出在库中找到的所有元件。在库名下的过滤器栏内键入*3904*设

置过滤器。一个有“3904”作为元件名的元件列表将显示。 

5、在列表中点击 2N3904 以选择它，然后点击 Place 按钮。另外，还可以双击元件名。 

光标将变成十字状，并且在光标上“悬浮”着一个晶体管的轮廓。现在你处于元件放置状态。如果你移动光标，晶体管轮廓也

会随之移动。 

6、在原理图上放置元件之前，首先要编辑其属性。在晶体管悬浮在光标上时，按下 TAB 键。这将打开 Component Properties

（元件属性）对话框。我们现在要设置对话框选项如下图所示。 

 

7、在对话框 Properties 单元，在 Designator 栏中键入 Q1 以将其值作为第一个元件序号。 

8、下面我们将检查在 PCB 中用于表示元件的封装。在本教程中，我们已经使用了集成库，这些库已经包括了封装和电路仿真

的模型。确认在模型列表中含有模型名 BCY-W3/D4.7。保留其余栏为默认值。 

现在准备放置元件。 

1、移动光标（附有晶体管符号）到图纸中间偏左一点的位置。 

2、当你对晶体管的位置满意后，左击或按 ENTER 键将晶体管放在原理图上。 



3、移动光标，你会发现晶体管的一个复制品已经放在原理图纸上了，而你仍然处于在光标上悬浮着元件轮廓的元件放置状态。

Protel DXP 的这个功能让你放置许多相同型号的元件。现在让我们放第二个晶体管。这个晶体管同前一个相同，因此在放之前

没必要再编辑它的属性。在你放置一系列元件时 Protel DXP 会自动增加一个元件的序号值。以这个例子中，我们放下的第二个

晶体管会自动标记为 Q2。 

4、如果你查阅原理图（Figure 1），你会发现 Q2 与 Q1 是镜像的。要将悬浮在光标上的晶体管翻过来，按 X 键。这样可以使

元件水平翻转。 

5、移动光标到 Q1 右边的位置。要将元件的位置放得更精确些，按 PAGEUP 键两次以放大两倍。现在你能看见栅格线了。 

6、当你将元件的位置确定后，左击或按 ENTER 键放下 Q2。你所拖动的晶体管的一个复制品再一次放在原理图上后，下一个

晶体管会悬浮在光标上准备放置。 

7、由于我们已经放完了所有的晶体管，我们用右击鼠标或按 ESC 键来退出元件放置状态。光标会恢复到标准箭头。 

下面我们要放四个电阻（resistors） 

1、在 Libraries 面板中，确认 Miscellaneous Devices.IntLib库为当前。 

2、在库名下的过滤器栏里键入 res1来设置过滤器。 

3、在元件列表中点击 RES1 以选择它，然后点击 Place 按钮。现在你会有一个悬浮在光标上的电阻符号。 

4、按 TAB 键编辑电阻的属性。在对话框的 Properties 单元，在 Designator 栏中键入 R1 以将其值作为第一个元件序号。 

5、确认模型名为 AXIAL-0.3包含在模型列表中。 

6、对电阻的 parameter 栏的设置将在原理中显示，并在本教程以后运行电路仿真时会被 DXP 使用。=Value 规则可以作为关于

元件的一般信息在仿真时使用，个别元件除外。我们也可以设置 Comment 来读取这个值，而这也会将 Comment 信息体现在 PCB

设计工具中。没必要将该值输入两次（在规则中的=Value 和 Comment 栏），DXP 提供“间接引用”，这可以用规则中的字符

来替代 Comment 栏的内容。 

在规则列表单元中点击 Add 显示 Parameter Properties 对话框。在 name 中输入 Value以及在 value 中输入 100K。确认 String

作为规则类型被选择，并且 value 的 Visible 框被勾选。点击 OK。 

7、在对话框的 Properties 单元，点击 Comment 栏并从下拉列表中选择=Value，将 Visible 关闭。点击 OK 按钮返回放置模式。 

8、按 SPACEBAR（空格键）将电阻旋转 90°。 

9、将电阻放在 Q1 基极的上边（参见 Figure 1 中的原理图）然后左击或按 ENTER 键放下元件。 

10、接下来在 Q2 的基极上边放另一个 100K 电阻 R2。 

11、剩下两个电阻，R3 和 R4，阻值为 1K，按 TAB 键显示 Component Properties 对话框，改变 Value 栏为 1K（在 Parameters

列表中当 Value 被选择后按 Edit 按钮）。点击 OK 按钮关闭对话框。 

12、参照 Figure 1 中的原理图所示定位并放置 R3 和 R4。 

13、放完所有电阻后，右击或按 ESC 键退出元件放置模式。 



现在放置两个电容（capacitors）： 

1、电容元件也在 Miscellaneous Devices.IntLib库里，该应该已经在 Libraries 面板中被选择。 

2、在 Libraries 面板的元件过滤器栏键入 cap。 

3、在元件列表中点击 CAP 选择它，然后点击 Place 按钮。现在在你的光标上悬浮着一个电容符号。 

4、按 TAB 键编辑电容的属性。在 Component Properties 对话框的 Properties 单元，设置 Designator 为 C1，检查 PCB 封装

模型为 RAD-0.3被添加到 Models 列表中。 

5、规则栏的设置将显示在原理图中。点击规则列表中的 Add 显示 Parameter Properties 对话框。输入名称 Value 以及值

20n。确认 String 作为规则类型被选择，并且 value 的 Visible 框被勾选。点击 OK。 

6、在对话框的 Properties 单元，点击 Comment 栏并从下拉列表中选择=Value，将 Visible 关闭。点击 OK 按钮返回放置模式。 

7、用放置以前的元件的方法放置两个电容。 

8、右击或按 ESC 退出放置模式。 

后要放置的元件是连接器（connector），在 Miscellaneous Connectors.IntLib 库里。 

1、我们想要的连接器是两个引脚的插座，所以设置过滤器为*2*。 

2、在元件列表中选择 HEADER2 并点击 Place 按钮。按 TAB 编辑其属性并设置 Designator 为 Y1，检查 PCB 封装模型为

HDR1X2。由于在仿真电路时我将把这个元件作为电路，所以不需要作规则设置。点击 OK 关闭对话框。 

3、以放置连接器之前，按 X 作水平翻转。在原理图中放下连接器。 

4、右击或按 ESC 退出放置模式。 

5、从菜单选择 File » Save（热键 F，S）保存你的原理图。 

现在你放完了所有的元件。注意在 Figure 2 中的元件之间留有间隔，这样就有大量的空间用来将导线连接到每个元件引脚上。

这很重要，因为你不能将一根导线穿过一个引线的下面来连接在它的范围内的另一个引脚。如果你这样做，两个引脚就都连接

到导线上了。 

如果你需要移动元件，点击并拖动元件体，拖动鼠标重新放置。 



 

连接电路 

连线起着在你的电路中的各种元件之间建立连接的作用。要在原理图中连线，参照 Figure 1 的图示并完成以下步骤： 

1、确认你的原理图图纸有一个好的视图，从菜单选择 View » Fit All Objects（热键 V，F）。 

2、首先用以下方法将电阻 R1 与晶体管 Q1 的基极连接起来。从菜单选择 Place »Wire（热键 P，W）或从 Wiring Tools（连线工

具）工具栏点击 Wire 工具进入连线模式。光标将变为十字形状。 

3、将光标放在 R1 的下端。当你放对位置时，一个红色的连接标记（大的星形标记）会出现在光标处。这表示光标在元件的一

个电气连接点上。 

4、左击或按 ENTER 固定第一个导线点。移动光标你会看见一根导线从光标处延伸到固定点。 

5、将光标移到 R1 的下边 Q1 的基极的水平位置上，左击或按 ENTER 在该点固定导线。在第一个和第二个固定点之间的导线

就放好了。 

6、将光标称到 Q1 的基极上，你会看见光标变为一个红色连接标记。左击或按 ENTER 连接到 Q1 的基极。 

7、完成这部分导线的放置。注意光标仍然为十字形状，表示你准备放置其它导线。要完全退出放置模式恢复箭头光标，你应

该再一次右击或按 ESC--但现在还不能这样做。 



8、现在我们要将 C1 连接到 Q1 和 R1。将光标放在 C1 左边的连接点上，左击或按 ENTER 开始新的连线。

 

9、水平移动光标一直到 Q1 的基极与 R1 的连线上。一个连接标记将出现。 

10、左击或按 ENTER 放置导线段，然后右击或按 ESC 表示你已经完成该导线的放置。注意两条导线是怎样自动连接上的。 

11、参照 Figure 3 连接电路中的剩余部分。 

12、在完成所有的导线之后，右击或按 ESC 退出放置模式。光标恢复为箭头形状。 

网络与网络标签 

彼此连接在一起的一组元件引脚称为网络（net）。例如，一个网络包括 Q1 的基极、R1 的一个引脚和 C1 的一个引脚。 

在设计中识别重要的网络是很容易的，你可以添加网络标签（net labels）。 

在两个电源网络上放置网络标签： 

1、从菜单选择 Place » Net Label。一个虚线框将悬浮在光标上。 

2、在放置网络标签之前应先编辑，按 TAB 键显示 Net Label （网络标签）对话框。 

3、在 Net 栏键入 12V，然后点击 OK 关闭对话框。 

4、将该网络标签放在原理上，使该网络标签的左下角与 上边的导线靠在一起。 

5、放完第一个网络标签后，你仍然处于网络标签放置模式，在放第二个网络标签之前再按 TAB 键进行编辑。 

6、在 Net 栏键入 GND，点击 OK 关闭对话框并放置网络标签。 

7、选择 File » Save（热键 F，S）保存电路。 



祝贺你！你已经用 Protel DXP 完成了你的第一张原理图。 

在我们将原理图转为电路板之前，让我们进行项目选项设置。 

设置项目选项 

项目选项包括错误检查规则、连接矩阵、比较设置、ECO 启动、输出路径和网络选项以及你想指定任何项目规则。在你编辑项

目时 Protel DXP 将使用这些设置。 

当项目被编辑时，详尽的设计和电气规则将应用于验证设计。当所有错误被解决后，原理图设计的再编辑将被启动的 ECO 加载

到目标文件，例如一个 PCB 文件。项目比较允许你找出源文件和目标文件之间的差别，并在相互之间进行更新（同步）。 

所有与项目有关的操作，如错误检查、比较文件和 ECO 启动均在 Options for Project 对话框中设置（Project » Project Options）。 

所有项目输出，如网络表、仿真器、文件的提供（打印）、集合和制造输出及报告在 Outputs for Project 对话框中设置（Project 

» Output Jobs）。参见设置项目输出以获得更多信息。 

1、选择 Project » Project Options，Options for Project 对话框出现。 

 

所有与项目有关的选均通过这个对话框来设置。 

检查原理图的电气参数 

在 Protel DXP 中原理图是不仅仅只是绘图--原理图还包含关于电路的连接信息。你可以使用连接检查器来验证你的设计。当

你编辑项目时，DXP 将根据在 Error Reporting 和 Connection Matrix 标签中的设置来检查错误，如果有错误发生则会显示

在 Messages 面板。 

设置错误报告 



在 Options for Project 对话框中的 Error Reporting 标签用于设置设计草图检查。报告模式（Report Mode）表明违反规则

的严格程度。如果你要修改 Report Mode，点击你要修改的违反规则旁的 Report Mode，并从下拉列表中选择严格程度。在本教

程中我们使用默认设置。 

设置连接矩阵 

连接矩阵标签（Options for Project 对话框）显示的是错误类型的严格性，这将在设计中运行错误报告检查电气连接产生，如引

脚间的连接、元件和图纸输入。这个矩阵给出了一个在原理图中不同类型的连接点以及是否被允许的图表描述。 

例如，在矩阵图的右边找到 Output Pin，从这一行找到 Open Collector Pin 列。在它的相交处是一个橙色的方块，这而这

个表示在原理中从一个 Output Pin 连接到一个 Open Collector Pin 的颜色将在项目被编辑时启动一个错误条件。 

 

你可以用不同的错误程度来设置每一个错误类型，例如对一些致命的错误不予报告。 

修改连接错误： 

1、点击 Options for Project 对话框的 Connection Matrix 标签。 

2、点击两种类型的连接的相交处的方块，例如 Output Sheet Entry and Open Collector Pin。 

3、在方块变为图例中的 errors 表示的颜色时停止点击，例如一个橙色方块表示一个错误将表明这样的连接是否被发

现。 



我们的电路不只包含 Passive Pins（在电阻、电容和连接器上）和 Input Pins（在晶体管上）。让我们来检查一下看看

连接矩阵是否会侦测出未连接的 passive pins。      

 

1、在行标签中找到 Passive Pin，在列标签中找到 Unconnected。它们的相交处的方块表示在原理中当一个 Passive Pin 被发现

未连接时的错误条件。默认是一个绿色方块，表示运行时不给出报告。 

2、点击这个相交处的方块，直到它变为黄色，这样当我们修改项目时，未连接的 passive pins 被发现时就会给出警

告。 

设置比较器 

Options for Project 对话框的 Comparator 标签用于设置当一个项目修改时给出文件之间的不同或忽略。在本教程中，我们不需

要将一些仅表示原理图设计等级的特性（如 rooms）之间的不同显示出来。确认在你忽略元件等级时没有忽略元件。 

1、点击 Comparator 标签并在 Difference Associated with Components 单元找到 Changed Room Definitions、 Extra Room 

Definitions 和 Extra Component Classes。 

2、从这些选项右边的 Mode 列中的下拉列表中选择 Ignore Differences。 

现在我们准备编辑项目并检查所有错误了。 

编辑项目 

编辑一个项目就是在设计文档中检查草图和电气规则错误并将你置于一个调试环境。我们已经在 Options for Project 

对话框中对 Error Checking 和 Connection Matrix 标签中的规则进行了设置。 

1、要编辑我们的 Multivibrator 项目，选择 Project » Compile PCB Project。 



2、当项目被编辑时，任何已经启动的错误均将显示在设计窗口下部的 Messages 面板中。被编辑的文件会与同级的文件、

元件和列出的网络以及一个能浏览的连接模型一起列表在 Compiled 面板中。 

如果你的电路绘制正确，Messages 面板应该是空白的。如果报告给出错误，则检查你的电路并确认所有的导线和连

接是正确的。 

我们现在要小心地加入一个错误到我们的电路中并重新编辑项目： 

1、在设计窗口的顶部点击 Multivibrator.SchDoc标签，以使原理图为当前文档。 

2、点击连接 C1 和 Q1 基极的导线的中部，在导线的端点将出现小的方形编辑热点，一条沿着导线的虚线将显示选

择颜色以表示这条导线被选取了。按 DELETE 键删除这条导线。 

3、重新编辑项目（Project » Compile PCB Project）来检查错误被找到。 

Messages 面板将打开并给出一个警告信号：在你的电路中有一个未连接的输入引脚。一个悬浮输入引脚错误也会运

行，这是因为在 Project Options 对话框的 Error Reporting 标签有一个检查悬浮输入引脚的特殊选项。 

4、在 Messages 面板点击一个错误，Compile Error 窗口将显示违反的详细情况。从这个窗口，你可点击一个错误并

跳转到原理图的违反对象以便检查或修改错误。 

在我们完成教程的本单元之前，让我们将原理图中的错误修复。 

1、点击原理图图纸标签使其为激活。 

2、从菜单选择 Edit » Undo（热键 E，U）。你先前删除的导线现在恢复了。 

3、要检查恢复是否成功，重新编辑项目（Project » Compile PCB Project）来检查将没有错误被发现。Messages 面板应该显示

（no errors）。 

4、从菜单选择 View » Fit All Objects（热键 V，F）恢复原理图视图，并保存无错误原理图。 

创建一个新的 PCB 文件 

在你将设计从原理图编辑器转换到 PCB 编辑器之前，你需要创建一个有 基本的板子轮廓的空白 PCB。在 Protel DXP 中创建一

个新的 PCB 设计的 简单方法是使用 PCB 向导，这将让你选择工业标准板轮廓又创建了你自定义的板子尺寸。在向导的任何阶

段，你都可以使用 Back 按钮来检查或修改以前页的内容。 

要使用 PCB 向导来创建 PCB，完成以下步骤： 

1、在 Files 面板的底部的 New from Template 单元点击 PCB Board Wizard 创建新的 PCB。如果这个选项没有显示在屏幕上，

点向上的箭头图标关闭上面的一些单元。 

2、PCB Board Wizard 打开。你首先看见的是介绍页。点 Next 按钮继续。 

3、设置度量单位为英制（Imperial），注意，1000 mils = 1 inch 。 



4、向导的第三页允许你选择你要使用的板轮廓。在本教程中我们使用我们自定义的板子尺寸。从板轮廓列表中选

择 Custom，点击 Next。 

5、在下一页，你进入了自定义板选项。在本教程电路中，一个 2 x 2 inch 的板子将给我大量的空间。选择 Rectangular 并

在 Width 和 Height 栏键入 2000。取消选择 Title Block & Scale、Legend String 和 Dimension Lines 以及 Corner Cutoff 和 

Inner Cutoff。点击 Next 继续。 

6、在这一页允许你选择板子的层数。我需要两个 signal layer，不需要 power planes。点击 Next 继续。 

7、在设计中使用的过孔（via）样式选择 Thru-hole vias only，点击 Next。 

8、在下一页允许你设置元件/导线的技术（布线）选取项。选择 Thru-hole components 选项，将相邻焊盘（pad)间的导线

数设为 One Track。点击 Next 继续。 

9、下一页允许你设置一些应用到你的板子上的设计规则。设为默认值。点 Next 按钮继续。 

10、 后一页允许你将自定义的板子保存为模板，允许你按你输入的规则来创建新的板子基础。我们不想将我们

的教程板子保存为模板，确认该选项未被选择，点击 Finish 关闭向导。 

 



11、PCB 向导现在收集了它需要的所有的信息来创建你的新板子。PCB 编辑器将显示一个名为 PCB1.PcbDoc的新的

PCB 文件。 

12、PCB 文档显示的是一个默认尺寸的白色图纸和一个空白的板子形状（带栅格的黑色区域）。要关闭图纸，选择 Design » 

Options，在 Board Options 对话框取消选择 Design Sheet。 

 

你可以使用 Protel DXP 从其它 PCB 模板中添加你自己的板框、栅格特性和标题框。要获得关于板子形状、图纸和模板的更多

信息，参见板子形状和图纸教程。 

13、现在图纸被关闭，选择 View » Fit Board（热键 V，F）将只显示板子形状。 

14、PCB 文档会自动添加（连接）到项目，并列表在 Projects 标签中紧靠项目名称的 PCBs 下面。 

15、选择 File » Save As 来将新 PCB 文件重命名（用*.PcbDoc扩展名）。指定你要把这个 PCB 保存在你的硬盘上的位置，在

文件名栏里键入文件名 Multivibrator.PcbDoc并点击 Save。 

将新的 PCB 添加到项目 

如果你想添加到项目的 PCB 是以自由文件打开的，在 Projects 面板的 Free Documents 单元右击 PCB 文件，选择 Add to Project。

这个 PCB 现在就列表在 Projects 标签紧靠项目名称的 PCBs 下面并连接到项目文件。 



转换设计 

在将原理图信息转换到新的空白 PCB 之前，确认与原理图和 PCB 关联的所有库均可用。由于在本教程中只用到默认安装的集成

元件库，所有封装也已经包括在内了。只要项目已经编辑过并且在原理图中的任何错误均已修复，那么使用 Update PCB 命令

来启动 ECO 就能将原理图信息转换到目标 PCB。  

 

更新 PCB 

将项目中的原理图信息发送到目标 PCB： 

1、在原理图编辑器选择 Design » Update PCB (Multivibrator.PcbDoc)。项目修改，Engineering Change Order 对话框出

现。 

2、点击 Validate Changes。如果所有的改变均有效，检查将出现在状态列表中。如果改变无效，关闭对话框，检查 Messages

面板并清除所有错误。 

3、点击 Execute Changes 将改变发送到 PCB。完成后，状态变为完成（Done） 

4、点击 Close，目标 PCB 打开，而元件也在板子上以准备放置。如果你在当前视图不能看见元件，使用热键 V、D

（查看文档）。 

设计 PCB 

现在我们可以开始在 PCB 上放置元件并在板上布线。 

设置 PCB 工作区 

在将元件定位在板子上之前，我们需要设置 PCB 工作区，如栅格、层和设计规则。 

栅格（Grids） 



在开始定位元件之前，我们需要确认放置栅格设置正确。放置在 PCB 工作区的所有对象均排列在称为捕获栅格（snap grid ）

上。这个栅格需要设置得适合我们要使用的布线技术。 

我们的教程电路用的是标准英制元件，其 小引脚间距为 100mil。我们将这个捕获栅格设定为 100mil 的一个平均分数，50 或

25mil，这样所有的元件引脚在放置时均将落在栅格点一。当然，板子上的导线宽度和间距分别是 12mil 和 13mil（这是 PCB

板向导使用的默认值），在平行的导线的中心之间允许 小为 25mil。所以 合适的捕获栅格应设为 25mil。 

完成以下步骤设置捕获栅格： 

1、从菜单选择 Design » Options（热键 D，O）打开 Board Options 对话框。 

2、在 Grids 标签，将对话框中的 Snap X、 Snap Y、 Component X 和 Component Y 栏的值设为 25mil。注意这个对话

框也用来定义电气栅格。电气栅格在你放置一个电气对象时工作，它将忽略捕获栅格而同时捕获电气对象。点击 OK 关闭对

话框。 

让我们设置一些其它选项，这样可以使定位元件更容易些。 

1、从菜单选择 Tools » Preferences（热键 T，P）打开 System Preferences 对话框。在 Options 标签的 Editing Options 单

元，确认 Snap to Center 选项被选中。这会使你在抓住一个元件定位时，光标就会定位在元件的参考点上。 

2、点击 System Preferences 对话框中 Display 标签其为当前。在 Show 单元，将 Show Pad Nets、Show Pad Numbers 和 Via 

Nets 选项取消选择。在 Draft Thresholds 单元，将 Strings 栏设为 4 pixels，然后关闭对话框。 

定义板层和其它非电层 

如果你查看 PCB 工作区的底部，你会看见一系列层标签。PCB 编辑器是一个多层环境，你所做的大多数编辑工作都将在一个特

殊层上。使用 Board Layers 对话框（Design » Board Layers）来显示、添加、删除、重命名、及设置层的颜色。 



 

在 PCB 编辑器中有三种类型的层： 

1、电气层--包括 32 个信号层和 16 个平面层。电气层在设计中添加或移除是在板层管理器中，选择 Design » Layer Stack 

Manager 来显示这个对话框。 

2、机械层--有 16 个用途的机械层，用来定义板轮廓、放置厚度，包括制造说明、或其它设计需要的机械说明。

这些层在打印和底片文件的产生时都是可选择的。在 Board Layers 对话框你可以添加、移除和命名机械层。 

3、特殊层--包括顶层和底层丝印层、阻焊和助焊层、钻孔层、禁止布线层（用于定义电气边界）、多层（用于多

层焊盘和过孔）、连接层、DRC 错误层、栅格层和孔层。在 Board Layers 对话框中控制这些特殊层的显示。 

板层控制器 

本教程是一个简单设计，使用单面板或双面板布线就可以了。如果设计更复杂些，你可以在板层管理器中添加更多的层。 

1、选择 Design » Layer Stack Manager 显示 Layer Stack Manager 对话框。 



 

2、新层和平面添加在当前所选择的层下面。层的参数，如铜厚和非电参数都会用在信号完整分析中。点击 OK 关闭对话框。 

新板打开时会有许多你用不上的可用层，因此，要关闭一些不需要的层。 

完成以下步骤来关闭层： 

1、按快捷键 L 显示 Board Layers 对话框。 

2、右击并选择 Used On 将那些没有东西的层关闭。 

3、确认四个 Mask 层和 Drill Drawing 层名称旁边的 Show 按钮因没有勾选而不会显示。点击 OK 关闭对话框。 

设置新的设计规则 

Protel DXP 的 PCB 编辑器是一个规则驱动环境。这意味着，当你在 PCB 编辑器中工作并执行那些改变设计的操作时，如放置导

线、移动元件、或自动布线，PCB 编辑器将一直监视每一个操作并检查设计是否仍然满足设计规则。 

在你开始在板子上工作之前设置设计规则允许你依然关注你的设计任务，而确信任何设计错误都会立即被标记出以引起你的注

意。 

设计规则分为 10 个类别，并进一步分为设计类型。设计规则覆盖了电气、布线、制造、放置、信号完整要求。 

我们将对电源网络布线宽度设置新的设计规则。 

完成以下步骤来设置这些规则： 

1、PCB 为当前文档时，从菜单选择 Design » Rules。 

2、PCB Rules and Constraints Editor 对话框出现。每一类规则都显示在对话框的设计规则面板（左手边）。双击 Routing 类展

开后可以看见有关布线的规则。然后双击 Width 显示宽度规则为有效。 



 

3、在设计规则面板中每个规则都点击一次来选择。当你在每个规则上点击后，对话框右边会在顶部单元显示规则范围（你所

要的这个规则的目标），而在底部单元显示规则的约束特性。这些规则都是默认值，或已经由板向导在创建新的 PCB 文档时设

置。 

4、点击 Width_1 规则显示它的约束特性和范围。这个规则应用到整个板。 

 

Protel DXP 的设计规则系统的一个强大功能是：可以定义同类型的多重规则，而每个目标对象又不相同。每一个规则目标的同

一组对象在规则的范围里定义。规则系统使用预定义等级来决定将哪个规则应用到每个对象。 

例如，你可能有一个对整个板的宽度约束规则（即所有的导线都必须是这个宽度），而对接地网络需要另一个宽度约束规则（这

个规则忽略前一个规则），在接地网络上的特殊连接却需要第三个宽度约束规则（这个规则忽略前两个规则）。规则依优先权

顺序显示。 



现在，在你的设计中有一个宽度约束规则需要应用到整个板。现在我们要为 12V 和 GND 网络添加一个新的宽度约束规则。要添

加新的宽度约束规则，完成以下步骤： 

1、在 Design Rules 规则面板的 Width 类被选择时，右击并选择 New Rule，将一个宽度约束规则只添加到 12V 网络。 

一个新的名为 Width_2的规则出现。在 Design Rules 面板点击新的规则以修改其范围和约束。 

2、在名称栏键入 12V 或 GND。当你完成规则设置后在 Design Rules 面板点击时 Design Rules 面板中的这个名称会刷新。 

3、下面我们要使用 Query Builder 来设置规则范围，如果你知道正确的语法结构，你也可以直接在范围中键入。 

点击 Where the First object matches 单元的 Net。在 Query Kind 单元里会出现 InNet( )。点击 All 按钮旁的下拉列表，

从有效的网络列表中选择 12V。Query Kind 单元会更新为 InNet (‘12V’)。 

 

4、下面我要使用 Query Builder  将范围扩展到包括 GND 网络。点击 Advanced (Query)，然后点击 Query Builder。Query Helper 

对话框出现。 



 

5、点击 Query 单元的 InNet(‘12V’)的右边，然后点击 Or 按钮。现在 Query 单元的内容变为 InNet(‘12V’) or，

这样就使范围设置为将规则应用到两个网络中。 

6、点击 PCB Functions 类的 Membership Checks，双击 Name 单元的 InNet。 

7、在 Query 单元 InNet( )的括号中间点击一下，以添加 GND 网络的名称。在 PCB Objects List 类点击 Nets，然后

从可用网络列表中双击选择 GND。Query 单元变为 InNet(‘12V’) or InNet(‘GND’)。 

8、点击 Check Syntax，然后点击 OK 关闭结果信息。如果显示错误信息应予以修复。 

9、点击 OK 关闭 Query Helper 对话框。在 Full Query 单元的范围就更新为新的内容。 

10、在 PCB Rules and Constraints Editor 对话框的底部单元，点击旧约束文本（10mil）并键入新值以将 Minimum、Preferred 

和 Maximum 宽度栏改为 25mil。注意你必须在修改 Minimum 值之前先设置 Maximum 宽度栏。现在新的规则已经设置，并

当你选择 Design Rules 面板的其它规则或关闭对话框时将予以保存。 

11、 后，双击 初的板子范围宽度规则名 Width_1，将 Minimum, Maximum and Preferred 宽度栏均设为 12mil。点击 OK

关闭 PCB Rules and Constraints Editor 对话框。 



当你用手工布线或使用自动布线器时，所有的导线均为 12mils，除了 GND 和 12V 的导线为 25mils。

 

在 PCB 中放置元件 

现在我们可以放置右边的元件了。 

1、按快捷键 V、D 将显示整个板子和所有元件。 

2、现在放置连接器 Y1，将光标放在连接器轮廓的中部上方，按下鼠标左键不放。光标会变成一个十字形状并跳到元件的参考

点。 

3、不要松开鼠标左键，移动鼠标拖动元件。 

4、拖动连接时，按下 SPACEBAR 将其旋转 90°，然后将其定位在板子的左边（确认整个元件仍然在板子边界以内），如图

Figure 5 所示。 

 



5、元件定位好后，松开鼠标将其放下，注意飞线是怎样与元件连接的。 

6、参照 Figure 5 所示放置其余的元件。当你拖动元件时，如有必要，使用 SPACEBAR 键来放置元件，这样飞线就

如 Figure 5 所示。 

元件文字可以用同样的方式来重新定位——按下鼠标左键不放来拖动文字，按 SPACEBAR 旋转。在重新定位文字之前，

我要在教程以下部分使用 Protel DXP 强大的批量编辑功能来隐藏元件型号（值），因为这些在 终的板子是不需

要的。 

Protel DXP 具有强大的而灵活的放置工具。让我们使用这些工具来保证四个电阻正确地对齐和间隔。 

1、按住 SHIFT 键，左击选择每一个电阻。在每一个元件周围都将有一个在系统颜色设置的选择颜色的选择块。要

改变选择颜色，选择 Design » Board Layers。 

2、点击元件放置工具中的 Align Tops of Selected Components 按钮。那么四个电阻就会沿着它们的上边对齐。 

3、现在点击元件放置工具中的 Make Horizontal Spacing of Selected Components Equal 按钮。 

4、在设计窗口的其它任何地方点击取消选择所有的电阻。这四个电阻现在就对齐了并且等间距。 

修改封装 

现在我们已经将封装都定位好了，但电容的封装却比我们要求的太大。让我们将电容的封装改成一小的。 

1、首先我们要找到一个新的封装。点击 Libraries 面板，从库列表中选择 Miscellaneous Deivices.IntLib。点击

Footprints 显示当前库中的可用封装。我们要的是一个小一些的 radial 类型的封装，因此在过滤器栏键入 rad。点

击封装名就会看见与这些名字相联系的封装。其中封装 RAD-0.1 就是我们需要的。 

2、双击电容，将 Component 对话框的 Footprint 栏改为 RAD-0.1。 

3、现在你的板子就如下图所示。 

 



每个对象都定位放置好了，现在是放导线的时候了！ 

手工布线 

布线就是放置导线和过孔在板子上将元件连接起来。Protel DXP 提供了许多有用的手工布线工具，使得布线工作非常容易。 

尽管自动布线器提供了一个容易而强大的布线方式，然而仍然有你需要去控制导线的放置的状况——或者你因为个人喜好而要进

行手工布线。在这些状况下，你可以对你的板的部分或全部进行手工布线。在本教程的这部分，我们要将整个板作为单面板来

进行手工布线，所有导线都在底层。 

现在我们要使用预拉线来引导我们将导线放置在板的底层。 

在 Protel DXP 中，PCB 的导线是由一系列直线段组成的。每次方向改变时，新的导线段也会开始。在默认情况下，Protel DXP

初始时会使导线走向为垂直、水平或 45°角，以使很容易地得到专业的结果。这项操作可以根据你的需要自定义，但

在本教程中我们仍然使用默认值。 

1、从菜单选择 Place » Interactive Routing（快捷键 P，T）或点击放置（Placement）工具栏的 Interactive Routing 按钮。

光标变成十字形状，表示你处于导线放置模式。 

2、检查文档工作区底部的层标签。TopLayer 标签当前应该是被激活的。按数字键盘上的*键切换到底层而不需要

退出导线放置模式。这个键仅在可用的信号层之间切换。现在 BottomLayer 标签应该被激活了。 

3、将光标放在连接器 Y1 的 下面一个焊盘上。左击或按 ENTER 固定导线的第一个点。 

4、移动光标到电阻 R1 的下面一个焊盘。注意导线是怎样放置的。在默认情况下，导线走向为垂直、水平或 45°角。

再注意导线有两段。第一段（来自起点）是蓝色实体，是你当前正放置的导线段。第二段（连接在光标上）称作

“look-ahead”段，为空心线，这一段允许你预先查看好你要放的下一段导线的位置以便你很容易地绕开障碍物，

而一直保持初始的 45°/90°导线。 

5、将光标放在电阻 R1 下面的一个焊盘的中间，然后左击或按 ENTER 键。注意第一段导线变为蓝色，表示它已经

放在底层了。往边上移动光标一点，你会看见你仍然有两段导线连接在光标上：一条在下次鼠点击时要放置的实

心蓝色线段和一条帮助你定位导线的空心“look-ahead”线段。 

6、将光标重新定位在 R1 的下面一个焊盘上，会有一条实心蓝色线段从前一条线段延伸到这个焊盘。左击放下这

条实心蓝色线段。 

你已经完成了第一个连接。 

7、移动光标将它定位在电阻 R4 的下面一个焊盘上。注意一条实心蓝色线段延伸到 R4。左击放下这条线段。 

8、现在移动光标到电阻 R3 的下面一个焊盘上。注意这条线段不是实心蓝色，而是空心的表示它是一条“look-ahead”

线段。这是因为你每次放置导线段时，起点模式就在以水平/垂直和 45°之间切换。当前处于 45°模式。按 SPACEBAR

键将线段起点模式切换到水平/垂直。现在这条线段是不实心蓝色的了。左击或按 ENTER 放下线段。 

9、移动光标到电阻 R2 的下面一个焊盘。你需要再一次按 SPACEBAR 键来切换线段起点模式。左击或按 ENTER

放下线段。 



10、你现在完成了第一个网络的布线。右击或按 ESC 键表示你已完成了这条导线的放置。光标仍然是一个十字形

状，表示你仍然处于导线放置模式，准备放置下一条导线。按 END 键重画屏幕，这样你能清楚地看见已经布线的

网络。       

11、现在你可按上述步骤类似的方法来完成板子上剩余的布线。Figure 6 显示了手工布线的板子。 

12、保存设计。 

在你放置导线时注意以下几点： 

1、左击鼠标（或按 ENTER 键）放置实心颜色的导线段。空心线段表示导线的 look-ahead 部分。放置好的导线段用层

颜色来显示。 

2、按 SPACEBAR 键来切换你要放置的导线的 horizontal/vertical 和 start 45° 起点模式。 

3、在任何时候按 END 键来重绘画面。 

4、在任何时候按快捷 V、F 来画面重绘为显示所有对象。 

5、在任何时候按 PAGEUP 和 PAGEDOWN 键来以光标位置为中心放大或缩小。 

6、按 BACKSPACE 键取消放置前一条导线段。 

7、在你完成放置导线后或想要开始一条新的导线时右击或按 ESC 键。 

8、你不能将不应该连接在一起的焊盘连接起来。Protel DXP 将不停地分析板子的连接情况并阻止你进行错误的连

接或跨越导线。 

9、要删除一条导线段，左击选择，这条线段的编辑点出现（导线的其余部分将高亮显示）。按 DELETE 键删除被

选择的导线段。 



10、重新布线在 Protel DXP 中是很容易的——只要布新的导线段即可，在你右击完成后，旧的多余导线段会自动

被移除。 

11、在你完成 PCB 上的所有的导线放置后，右击或按 ESC 键退出放置模式。光标会恢复为一个箭头。 

祝贺你！你已经手工布线完了你的板设计。 

自动布线 

要知道使用 Protel DXP 进行自动布线是如何的容易，完成以下步骤： 

1、首先，从菜单选择 Tools » Un-Route » All（快捷键 U，A）取消板的布线。 

2、选择从菜单选择 Autoroute » All（快捷键 A，A）。 

3、自动布线完成后，按 END 键重绘画面。 

多么简单呀！Protel DXP 的自动布线器提供与一个有经验的板设计师的同等结果，这是因为 Protel DXP 在 PCB

窗口中对你的板进行直接布线，而不需要导出和导入布线文件。 

4、选择 File » Save（快捷键 F，S）保存你的板。 

注意自动布线器所放置的导线有两种颜色：红色表示导线在板的顶层信号层，而蓝色表示底层信号层。自动布线

器所使用的层是由 PCB 板向导设置的 Routing Layers 设计规则中所指明的。你也会注意到连接到连接器的两条电源

网络导线要粗一些，这是由你所设置的两条新的 Width 设计规则所指明的。         

 

不要介意在你的设计中的布线与 Figure 7 所示的不一样；而元件的放置也会不一样，两者都不一样仍然会布线。 

因为我们 初在 PCB 板向导中将我们的板定义为双面板，所以你可以使用顶层和底层来手工将你的板布线为双面板。要这样做，

从菜单选择 Tools » Un-Route » All（快捷键 U，A）取消板的布线。象以前那样开始布线，但要在放置导线时用*键在

层间切换。如果你需要改变层时 Protel DXP 会自动加入过孔。 



验证你的板设计 

Protel DXP 提供一个规则驱动环境来设计 PCB，并允许你定义各种设计规则来保证你的板的完整性。比较典型的是，在设计进

程的开始你就设置好设计规则，然后在设计进程的 后用这些规则来验证设计。 

在教程中我们很早就检验了布线设计规则并添加了一个新的宽度约束规则。我们也注意到已经由 PCB 板向导创建了许多规则。 

为了验证所布线的电路板是符合设计规则的，现在我们要运行设计规则检查（Design Rule Check）（DRC）： 

1、选择 Design » Board Layers（快捷键 L ），确认 System Colors 单元的 DRC Error Markers 选项旁的 Show 按钮被勾

选，这样 DRC error markers 才会显示出来。 

2、从菜单选择 Tools » Design Rule Check（快捷键 T，D）。在 Design Rule Checker 对话框已经框出了 on-line 和一组

DRC 选项。点一个类查看其所有原规则。 

3、保留所有选项为默认值，点击 Run Design Rule Check 按钮。DRC 将运行，其结果将显示在 Messages 面板。当然，

你会发现晶体管的焊盘呈绿色高亮，表示有一个设计规则违反。 

4、查看错误列表。它列出了在 PCB 设计中存在的所有规则违反。注意在 Clearance Constraint 规则下列出了四个违

反。在细节中指出晶体管 Q1 和 Q2 的焊盘违反了 13mil 安全间距规则。

 

5、双击 Messages 面板中一个错误跳转到它在 PCB 中的位置。 

通常你会在设计板、对布线技术和器件的物理属性加以重视之前设置安全间距约束规则。让我们来分析错误然后

查看当前的安全间距设计规则并决定如何解决这个问题。 

找出晶体管焊盘间的实际间距： 

1、在 PCB 文档激活的情况下，将光标放在一个晶体管的中间按 PAGEUP 键放大。 

2、选择 Reports » Measure Primitives（快捷键 R，P）。光标变成十字形状。 

3、将光标放在晶体管的中间一个焊盘的中间，左击或按 ENTER。因为光标是在焊盘和与其连接的导线上，所以会有一

个菜单弹出来让你选择需要的对象。从弹出菜单中选择晶体管的焊盘。 

4、将光标放在晶体管的其余焊盘的其中一个的中间，左击或按 ENTER。再一次从弹出菜单中选择焊盘。一个信息框将打开

显示两个焊盘的边缘之间的 小距离是 10.63mil。 

5、关闭信息框，然后右击或按 ESC 退出测量模式，在且 V、F 快捷键重新缩放文档。 



让我们看看当前安全间距设计规则。 

1、从菜单选择 Design » Rules（快捷键 D，R）打开 PCB Rules and Constraints Editor 对话框。双击 Electrical 类在对话框

的右边显示所有电气规则。双击 Clearance 类型（列在右边）然后点击 Clearance_1打开它。对话框底部区将包括

一个单一的规则，指明整个板的 小安全间距是 13mil。而晶体管焊盘之间的间距小于这个值，这就是为什么我们

选择 DRC 时它们被当作违反。 

2、在 Design Rules 面板选择 Clearance 类型，右击并选择 New Rule 添加一个新的安全间距约束规则。 

3、双击新的安全间距规则，在 Constraints 单元设置 Minimum Clearance 为 10mil。 

4、点击 Advanced (Query) 然后点击 Query Builder，从 Memberships Checks 构建 query ，或在 Query 栏键入

HasFootprintPad(‘BCY-W3/D4.7’,’*’)。“*”表示名为 BCY-W3/D4.7 的“任何焊盘”。 

5、点击 OK 关闭对话框。 

6、你现在可以从 Design Rules Checker 对话框（Tools » Design Rule Check）点击 Run Design Rule Check 按钮重新运行 DRC。

应该不会有违反了。 

做得好！你已经完成了 PCB 设计，准备生成输出文档。 

设置项目输出 

项目输出，如打印和输出文件，是在 Outputs for Project 对话框内设置的。 

1、选择 Project » Output Jobs。Project [project_name] 对话框出现。 

2、点击你想要的输出进行设置。如果 Configure 按钮是激活的（不呈灰色），你就能修改该输出的设置。 

3、完成设置后点击 Close。 

4、如果你要根据输出类型将输出发送到单独的文件夹，则选择 Project » Project Options，点击 Options 标签，再点击 Use 

separate folder for each output type， 后点击 OK。 

打印到 Windows 打印设备 

一旦 PCB 的设计和布线都已完成，你就准备生成输出文档。这个文档应该包括一个描述制造信息的生产描图和一个描述元件位

置信息的集合描图以及加载顺序（命令）。 

要生成这些描图，Protel DXP 包含一个精密的打印引擎，这会让你完成打印进程的控制。你可以在打印之前精确地定义你要打

印的 PCB 层的组合、预览描图（称着打印输出）、设置比例、以及在纸上的位置。 

现在我们要使用默认输出设置创建一个打印预览，然后修改设置。 

1、从 PCB 菜单选择 File » Print Preview。PCB 将被分析并且以默认的输出显示在打印预览窗口。点击 Close。 



2、要检查输出中包括的 PCB 层的组合，选择 Project » Output Jobs。Project [project_name] 对话框出现。从 Documentation 

Outputs 单元选择 Composite Drawing，点击 Configure 按钮。PCB Printout Properties 对话框出现。你可以右击菜单选

项添加或删除层。点击 OK 关闭对话框。 

3、当我们仍然地 Project [project_name] 对话框时，我们要为孔导向组合修改层的参数。选择 Fabrication Outputs 单元的

Composite Drill Drawing，点击 Configure 按钮。在默认情况下，这个打印输出包括孔导向（一个每个钻孔处都有一

个小十字的系统层），和打孔层（在每个钻孔处都有一个唯一表示每种钻孔大小的的特殊符号）。 

在一般的打孔图中孔导向层是不需要的，因此删除它，在 Printouts & Layers 列右击 DrillGuide 层，从菜单中选择 Delete。

点击 OK 关闭对话框。 

4、现在点击 Print Preview 查看打孔图。然后你可以点击 Print 显示打印机设置， 后点击 OK 将该图传送到指定的

打印机。 

5、点击 Close 关闭打印预览窗口。 

6、要修改目标打印机、设置页位置和比例，你可以在 Project [project_name] 对话框选择 Page Setup（或从菜单选择 File 

» Page Setup）。选择你喜欢的打印机并设置打印机页为 Landscape。 

7、完成设置后，关闭所有打开的对话框。 

生产输出文件 

PCB 设计进程的 后阶段是生成生产文件。用于制造和生产 PCB 的文件组合包括底片（Gerber）文件、数控钻（NC drill）

文件、插置（pick and place）文件、材料表和测试点文件。输出文件可以在 Project [project_name] 对话框（Project 

» Output Jobs）或通过 File » Fabrication Outputs 菜单的单独命令来设置。生产文档的设置作为项目文件的一部分保

存。 

生成底片文件 

每一个底片文件对应物理板的一个层——元件丝印、顶层信号层、底层信号层、阻焊层等等。在生成用于生产你的设计的底片

（Gerber）和数控钻（NC drill）文件之前，比较合理的作法是向你的 PCB 制造商咨询以确认他们的要求。 

为本教程的 PCB 创建生产文件： 

1、将 PCB 文档激活，然后选择 File » Fabrication Outputs »Gerber files。Gerber Setup 对话框出现。 

2、点击 OK 接受默认设置。底片（Gerber）文件生成并且 CAMtastic!打开以显示这些文件。底片文件保存在自动创建

在你的项目文件所在文件夹里的 Project Outputs文件夹。每个文件夹有与层名相对应的文件扩展名，例如

Multivibrator.GTO对应于顶层丝印底片。 

材料清单 

1、要创建材料清单，首先设置你的报告。选择 Project » Output Jobs，然后选择 Project 对话框 Report Outputs 单元

的 Bill of Materials。 

2、点击 Create Report。在这个对话框，你可以在 Visible 和 Hidden Column 通过拖拽列标题来为你的 BOM 设置你需要的信息。 



3、点击 Report…显示你的 BOM 的打印预览。这个预览可以使用 Print 按钮来打印或使用 Export 按钮导出为一个文件

格式，如 Microsoft Excel 的.xls。 

4、关闭对话框。 

祝贺！你已经完成了 PCB 设计进程。 

仿真设计 

Protel DXP 允许你从原理图直接运行一个大型电路仿真的阵列。在本教程的以下部分，我们将仿真由我们的多谐振荡器电路所

产生的输出波形。 

设置仿真 

在我们运行仿真之前，我们需要添加一些物件到我们的电路中：振荡器的电压源；用于仿真的参考地和一些我们希望查看波形

的电路点的网络标签。 

1、点击窗口顶部的 Multivibrator.SchDoc使原理图为当前文档。 

2、我们必须再放一个有电压源的连接器。要删除连接器，在连接器体上点击一次选取它，然后按键盘上的 DELETE

键。 

3、这时没有足够的空间来放置电压源，因此我们要移动导线的自由端点。要移动 12V 导线的垂直端，点击一次导

线选取。当小方块编辑点出现时，点击一次导线的自由端的点，然后向上尽可能移动该点到导线改变方向的地方。

再点击放下该点。 

4、对 GND 导线的垂直端重复这个进程，将其移动到图纸的底部。 

5、选择 View » Toolbars » Simulation Sources 显示仿真源工具栏。 

6、点击仿真源工具栏的+12V source 按钮。一个电源符号将悬浮在光标上。按键盘上的 TAB 键编辑其属性。在出现

的对话框中，点击 Attributes 标签使其激活，并设置 Designator 为 V1。点击 OK 按钮关闭对话框，然后将这个电源放

在 12V 和 GND 导线的垂直端点之间。 

7、使用你用于移动 12V 和 GND 导线部分的垂直端点的相同技巧，再将他们移动到电压源的两个端点，如图 Figur

所示。 

我们在运行仿真之前 后的任务是在电路的合适的点放置网络标签，这样我们可以很容易地认出我们希望查看的信号。在本教

程电路中，较好的点是两个晶体管的基极和集电极。 

1、从菜单选择 Place » Net Label（快捷键 P，N）。按 TAB 键编辑网络标签的属性。在 Net Label 对话框，设置 Net 栏

为 Q1B，然后关闭对话框。 

2、将光标放在与 Q1 基极连接的导线上。参照 Figure 9 的网络标签的放置。左击或按 ENTER 将网络标签放在导线

上。 

3、按 TAB 键将 Net 栏改为 Q1C。 



4、将光标放在与 Q2 集电极连接的导线上，左击或按 ENTER 将网络标签放在导线上。 

5、同样地，将 Q2B 和 Q2C 网络标签放在 Q2 的基极和集电极导线上。 

6、完成网络标签的放置后，右击或按 ESC 退出放置模式。 

7、保存准仿真电路为与原原理图不同的文件名，选择 File » Save As 在 Save As 对话框键入 Multivibrator 

simulation.SchDoc。 

运行瞬态特性分析 

你的原理图现在已经具备所有必备的条件了，因此让我们设置一个电路瞬态特性分析。在我们的教程电路中，RC 时间常数为

100k x 20n = 2 ms 。要查看到振荡的 5 个周期，我们就要设置看到波形的一个 10ms 部分。 

1、选择菜单的 Design » Simulate » Mix Sim 显示 Analyses Setup 对话框。所有的仿真选项均在此设置。 

2、首先我们要设置你希望观察到的电路中的中心点。在 Collect Data For 栏，从列表中选择 Node Voltage and Supply Current。

这个选项定义了在仿真运行期间你想计算的数据类型。 

3、在 Available Signals 栏，双击 Q1B、 Q2B、 Q1C 和 Q2C 信号名。在你双击每一个名称时，它会移动到 Active Signals

栏。 

4、为这个分析勾选 Operating Point Analysis 和 Transient/Fourier。如果 Transient/Fourier Analysis Setup 没有自动显示，

点击 Transient/Fourier analysis 名称。 

5、将 Use Transient Defaults 选项设为无效，这样瞬态特性分析规则可用。 

6、要指定一个 10ms 的仿真窗口，将 Transient Stop Time 栏设为 10m 。 

7、现在设置 Transient Step Time 栏为 10u，表示仿真可以每 10us 显示一个点。 

8、在仿真其间，实际的时间间隔是自动随机获取的一簇。在 Maximum Step 栏限制时间间隔大小的随机性，设置

Transient Max Step Time 为 10u 。 

现在准备运行瞬态特性分析。 

1、点击 Analyses Setup 对话框底部的 OK 按钮运行仿真。 

2、仿真执行后，你将看见与图 Figure 10 所示相似的输出波形。 

祝贺你！你已经完成的电路仿真，并显示了它的输出波形。 

如果你喜欢，你可以改变一些原理图中元件参数，再运行仿真看看其变化。试着将 C1 的值改为 47n（双击 C1 编辑其属性），

然后再运行瞬态特性分析。输出波形将显示一个不均匀的占空比波形。  
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